aboutsummaryrefslogtreecommitdiff
path: root/irc/psybnc
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-01-18 14:38:36 +0000
committerChris Rees <crees@FreeBSD.org>2013-01-18 14:38:36 +0000
commitd064f6e8957551f394919ca796dbbf8497632bee (patch)
tree4cf10d782d5ef0deed9ee34626609a14ccf898ef /irc/psybnc
parent0270d540810739c94bff33ac20f089d2518a074b (diff)
downloadports-d064f6e8957551f394919ca796dbbf8497632bee.tar.gz
ports-d064f6e8957551f394919ca796dbbf8497632bee.zip
Notes
Diffstat (limited to 'irc/psybnc')
-rw-r--r--irc/psybnc/Makefile40
-rw-r--r--irc/psybnc/files/patch-Makefile (renamed from irc/psybnc/files/patch-aa)0
-rw-r--r--irc/psybnc/files/patch-ae13
-rw-r--r--irc/psybnc/files/patch-lang_english.lng (renamed from irc/psybnc/files/patch-ab)0
-rw-r--r--irc/psybnc/files/patch-lang_german.lng (renamed from irc/psybnc/files/patch-ac)0
-rw-r--r--irc/psybnc/files/patch-lang_italiano.lng (renamed from irc/psybnc/files/patch-ad)0
-rw-r--r--irc/psybnc/files/patch-src_p_global.h13
-rw-r--r--irc/psybnc/files/patch-src_p_string.c (renamed from irc/psybnc/files/patch-af)0
-rw-r--r--irc/psybnc/files/patch-src_psybnc.c (renamed from irc/psybnc/files/patch-ag)0
-rw-r--r--irc/psybnc/files/patch-tools_autoconf.c (renamed from irc/psybnc/files/patch-ah)11
-rw-r--r--irc/psybnc/files/pkg-message.in10
-rw-r--r--irc/psybnc/pkg-plist508
12 files changed, 311 insertions, 284 deletions
diff --git a/irc/psybnc/Makefile b/irc/psybnc/Makefile
index ab0d1eb34cf2..322654f9c1c3 100644
--- a/irc/psybnc/Makefile
+++ b/irc/psybnc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: psybnc
-# Date created: 24 November 2002
-# Whom: Mina Naguib <webmaster@topfx.com>
-#
+# Created by: Mina Naguib <webmaster@topfx.com>
# $FreeBSD$
-#
PORTNAME= psybnc
DISTVERSION= 2.3.2-9
@@ -15,29 +11,49 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Extremely powerful IRC bouncer
WRKSRC= ${WRKDIR}/psybnc
-PSYBASE= ${PREFIX}/psybnc
+PSYBASE?= ${PREFIX}/psybnc
MAKE_ARGS= PSYBASE=${PSYBASE}
-IS_INTERACTIVE= yes
+SUB_FILES= pkg-message
+SUB_LIST= PSYBASE=${PSYBASE}
+PLIST_SUB= PSYBASE=${PSYBASE:S,^${PREFIX}/,,}
+
+OPTIONS_DEFINE= MENUCONFIG
+MENUCONFIG_DESC=Configure using menu
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMENUCONFIG}
+IS_INTERACTIVE= yes
+.endif
post-patch:
@${REINPLACE_CMD} -e 's#=help/#=${PSYBASE}/help/#' ${WRKSRC}/lang/*
do-configure:
+.if ${PORT_OPTIONS:MMENUCONFIG}
@cd ${WRKSRC} && make menuconfig
+.else
+# Fool makefile.out into believing certs are unnecessary
+ @${TOUCH} ${WRKSRC}/key/psybnc.cert.pem
+.endif
do-install:
@${INSTALL} -d ${PSYBASE}/lang/ ${PSYBASE}/key/ ${PSYBASE}/help/
@${INSTALL_DATA} ${WRKSRC}/lang/INFO ${PSYBASE}/lang/
@${INSTALL_DATA} ${WRKSRC}/lang/*.lng ${PSYBASE}/lang/
- @if [ -f ${WRKSRC}/key/psybnc.cert.pem ]; then ${INSTALL_DATA} ${WRKSRC}/key/psybnc.cert.pem ${PSYBASE}/key/; fi
- @if [ -f ${WRKSRC}/key/psybnc.key.pem ]; then ${INSTALL_DATA} ${WRKSRC}/key/psybnc.key.pem ${PSYBASE}/key/; fi
- @if [ -f ${WRKSRC}/key/psybnc.req.pem ]; then ${INSTALL_DATA} ${WRKSRC}/key/psybnc.req.pem ${PSYBASE}/key/; fi
+ @${INSTALL_DATA} ${WRKSRC}/src/ssl.cnf ${PSYBASE}/key/
@${INSTALL_DATA} ${WRKSRC}/help/*.TXT ${PSYBASE}/help/
@${INSTALL_DATA} ${WRKSRC}/help/*.DEU ${PSYBASE}/help/
@${INSTALL_DATA} ${WRKSRC}/help/*.ITA ${PSYBASE}/help/
${INSTALL_PROGRAM} ${WRKSRC}/psybnc ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/psybnc.conf ${PREFIX}/etc/psybnc.conf.sample
-.include <bsd.port.post.mk>
+post-install:
+ @if [ -f ${WRKSRC}/key/psybnc.req.pem ]; then \
+ ${INSTALL_DATA} ${WRKSRC}/key/psybnc.cert.pem ${PSYBASE}/key/; \
+ ${INSTALL_DATA} ${WRKSRC}/key/psybnc.key.pem ${PSYBASE}/key/; \
+ ${INSTALL_DATA} ${WRKSRC}/key/psybnc.req.pem ${PSYBASE}/key/; \
+ fi
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/irc/psybnc/files/patch-aa b/irc/psybnc/files/patch-Makefile
index 85e3a71c6aed..85e3a71c6aed 100644
--- a/irc/psybnc/files/patch-aa
+++ b/irc/psybnc/files/patch-Makefile
diff --git a/irc/psybnc/files/patch-ae b/irc/psybnc/files/patch-ae
deleted file mode 100644
index 5138e6cbb9e4..000000000000
--- a/irc/psybnc/files/patch-ae
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/p_global.h Sun Jul 7 08:07:23 2002
-+++ ../../psybnc.mina/src/p_global.h Sun Nov 24 18:20:55 2002
-@@ -1264,8 +1264,8 @@
- #define pcontext { strmncpy(ctxt,__FILE__,sizeof(ctxt)); strmncpy(cfunc,__FUNCTION__,sizeof(cfunc)); cline=__LINE__; }
- #define pmalloc(n) __pmalloc((n),__FILE__,__FUNCTION__,__LINE__)
-
--#define SSLCERT "key/psybnc.cert.pem"
--#define SSLKEY "key/psybnc.key.pem"
-+#define SSLCERT PSYBASE "/key/psybnc.cert.pem"
-+#define SSLKEY PSYBASE "/key/psybnc.key.pem"
-
- #ifdef HAVE_SSL
- #ifndef SSLSEC
diff --git a/irc/psybnc/files/patch-ab b/irc/psybnc/files/patch-lang_english.lng
index 67225e322250..67225e322250 100644
--- a/irc/psybnc/files/patch-ab
+++ b/irc/psybnc/files/patch-lang_english.lng
diff --git a/irc/psybnc/files/patch-ac b/irc/psybnc/files/patch-lang_german.lng
index 8f19c8cb4808..8f19c8cb4808 100644
--- a/irc/psybnc/files/patch-ac
+++ b/irc/psybnc/files/patch-lang_german.lng
diff --git a/irc/psybnc/files/patch-ad b/irc/psybnc/files/patch-lang_italiano.lng
index 8b26de115606..8b26de115606 100644
--- a/irc/psybnc/files/patch-ad
+++ b/irc/psybnc/files/patch-lang_italiano.lng
diff --git a/irc/psybnc/files/patch-src_p_global.h b/irc/psybnc/files/patch-src_p_global.h
index 5cf165ba5bd5..67a4f7e3f9f3 100644
--- a/irc/psybnc/files/patch-src_p_global.h
+++ b/irc/psybnc/files/patch-src_p_global.h
@@ -1,3 +1,16 @@
+--- ./src/p_global.h Sun Jul 7 08:07:23 2002
++++ ../../psybnc.mina/src/p_global.h Sun Nov 24 18:20:55 2002
+@@ -1264,8 +1264,8 @@
+ #define pcontext { strmncpy(ctxt,__FILE__,sizeof(ctxt)); strmncpy(cfunc,__FUNCTION__,sizeof(cfunc)); cline=__LINE__; }
+ #define pmalloc(n) __pmalloc((n),__FILE__,__FUNCTION__,__LINE__)
+
+-#define SSLCERT "key/psybnc.cert.pem"
+-#define SSLKEY "key/psybnc.key.pem"
++#define SSLCERT PSYBASE "/key/psybnc.cert.pem"
++#define SSLKEY PSYBASE "/key/psybnc.key.pem"
+
+ #ifdef HAVE_SSL
+ #ifndef SSLSEC
diff -urN src/p_global.h psybnc.new/src/p_global.h
--- src/p_global.h 2005-06-04 22:22:45.000000000 +0400
+++ src/p_global.h 2008-02-25 23:36:21.000000000 +0300
diff --git a/irc/psybnc/files/patch-af b/irc/psybnc/files/patch-src_p_string.c
index 94851f48e29a..94851f48e29a 100644
--- a/irc/psybnc/files/patch-af
+++ b/irc/psybnc/files/patch-src_p_string.c
diff --git a/irc/psybnc/files/patch-ag b/irc/psybnc/files/patch-src_psybnc.c
index 07c3209c5d86..07c3209c5d86 100644
--- a/irc/psybnc/files/patch-ag
+++ b/irc/psybnc/files/patch-src_psybnc.c
diff --git a/irc/psybnc/files/patch-ah b/irc/psybnc/files/patch-tools_autoconf.c
index b93ae35f9bc5..9e281d82e0ef 100644
--- a/irc/psybnc/files/patch-ah
+++ b/irc/psybnc/files/patch-tools_autoconf.c
@@ -1,6 +1,6 @@
---- ./tools/autoconf.c Fri May 17 13:21:08 2002
-+++ ../../psybnc.mina/tools/autoconf.c Sun Nov 24 19:43:42 2002
-@@ -442,9 +442,9 @@
+--- tools/autoconf.c.orig 2006-11-16 00:27:04.000000000 +0000
++++ tools/autoconf.c 2013-01-18 13:55:10.102047624 +0000
+@@ -443,9 +443,9 @@
fprintf(makefile,"INCLUDE = -I./src/ -I.\n");
fprintf(makefile,"OBJS = src/psybnc.o src/match.o src/p_client.o src/p_crypt.o src/p_dcc.o src/p_hash.o src/p_idea.o src/p_inifunc.o src/p_link.o src/p_log.o src/p_memory.o src/p_network.o src/p_parse.o src/p_peer.o src/p_server.o src/p_socket.o src/p_string.o src/p_sysmsg.o src/p_userfile.o src/p_uchannel.o src/p_script.o src/p_topology.o src/p_intnet.o src/p_blowfish.o src/p_translate.o src/p_coredns.o src/snprintf.o %s\n",env);
if(provi==0)
@@ -12,12 +12,13 @@
fprintf(makefile,"TARGET = psybnc\n");
fprintf(makefile,"\n");
fprintf(makefile,"all: $(OBJS)\n");
-@@ -452,7 +452,7 @@
+@@ -453,7 +453,8 @@
fprintf(makefile," @strip $(TARGET)\n");
if(ssl==0)
{
- if(!fexists("key/psybnc.cert.pem")) /* only create, if not exist */
-+ if(!fexists(PSYBASE "/key/psybnc.cert.pem")) /* only create, if not exist */
++ if(!fexists(PSYBASE "/key/psybnc.cert.pem") &&
++ !fexists("key/psybnc.cert.pem")) /* only create, if not exist */
{
mkdir("key",0700);
fprintf(makefile," @echo \"*** GENERATING SSL-KEYS FROM CERTIFICATE **\"\n");
diff --git a/irc/psybnc/files/pkg-message.in b/irc/psybnc/files/pkg-message.in
new file mode 100644
index 000000000000..5adf0b170134
--- /dev/null
+++ b/irc/psybnc/files/pkg-message.in
@@ -0,0 +1,10 @@
+If you have not created SSL certificates for psybnc already, do so using the
+following commands:
+
+cd %%PSYBASE%%
+/usr/bin/openssl req -new -config key/ssl.cnf -out key/psybnc.req.pem \
+ -keyout key/psybnc.key.pem -nodes
+/usr/bin/openssl req -x509 -days 365 -in key/psybnc.req.pem \
+ -key key/psybnc.key.pem -out key/psybnc.cert.pem
+/usr/bin/openssl x509 -subject -dates -fingerprint -noout \
+ -in key/psybnc.cert.pem
diff --git a/irc/psybnc/pkg-plist b/irc/psybnc/pkg-plist
index 7da144e0683e..37cecbd50f50 100644
--- a/irc/psybnc/pkg-plist
+++ b/irc/psybnc/pkg-plist
@@ -1,256 +1,256 @@
bin/psybnc
+@unexec cmp -s %D/etc/psybnc.conf.sample %D/etc/psybnc.conf && rm -f %D/etc/psybnc.conf || true
etc/psybnc.conf.sample
-psybnc/key/psybnc.cert.pem
-psybnc/key/psybnc.key.pem
-psybnc/key/psybnc.req.pem
-psybnc/lang/INFO
-psybnc/lang/english.lng
-psybnc/lang/german.lng
-psybnc/lang/italiano.lng
-psybnc/help/ADDLOG.TXT
-psybnc/help/DELLOG.TXT
-psybnc/help/LISTLOGS.TXT
-psybnc/help/PLAYTRAFFICLOG.TXT
-psybnc/help/PROXY.TXT
-psybnc/help/SETLEAVEMSG.TXT
-psybnc/help/SETAWAYNICK.TXT
-psybnc/help/ADDAUTOOP.TXT
-psybnc/help/DELAUTOOP.TXT
-psybnc/help/LISTAUTOOPS.TXT
-psybnc/help/SRELOAD.TXT
-psybnc/help/ADDALLOW.TXT
-psybnc/help/ADDASK.TXT
-psybnc/help/ADDBAN.TXT
-psybnc/help/ADDDCC.TXT
-psybnc/help/ADDNETWORK.TXT
-psybnc/help/ADDOP.TXT
-psybnc/help/ADDSERVER.TXT
-psybnc/help/ADDUSER.TXT
-psybnc/help/BCONNECT.TXT
-psybnc/help/BHELP.TXT
-psybnc/help/BKILL.TXT
-psybnc/help/BQUIT.TXT
-psybnc/help/BWHO.TXT
-psybnc/help/DELALLOW.TXT
-psybnc/help/DELASK.TXT
-psybnc/help/DELBAN.TXT
-psybnc/help/DELDCC.TXT
-psybnc/help/DELENCRYPT.TXT
-psybnc/help/LISTASK.TXT
-psybnc/help/DELLINK.TXT
-psybnc/help/DELNETWORK.TXT
-psybnc/help/DELOP.TXT
-psybnc/help/DELSERVER.TXT
-psybnc/help/DELTRANSLATE.TXT
-psybnc/help/DELUSER.TXT
-psybnc/help/ENCRYPT.TXT
-psybnc/help/ERASEMAINLOG.TXT
-psybnc/help/ERASEPRIVATELOG.TXT
-psybnc/help/ERASETRAFFICLOG.TXT
-psybnc/help/JUMP.TXT
-psybnc/help/LINKFROM.TXT
-psybnc/help/LINKTO.TXT
-psybnc/help/LISTALLOW.TXT
-psybnc/help/AIDLE.TXT
-psybnc/help/LISTBANS.TXT
-psybnc/help/LISTDCC.TXT
-psybnc/help/LISTENCRYPT.TXT
-psybnc/help/LISTLINKS.TXT
-psybnc/help/LISTOPS.TXT
-psybnc/help/LISTSERVERS.TXT
-psybnc/help/MADMIN.TXT
-psybnc/help/NAMEBOUNCER.TXT
-psybnc/help/PASSWORD.TXT
-psybnc/help/PLAYMAINLOG.TXT
-psybnc/help/PLAYPRIVATELOG.TXT
-psybnc/help/RELAYLINK.TXT
-psybnc/help/SETAWAY.TXT
-psybnc/help/SETUSERNAME.TXT
-psybnc/help/SOCKSTAT.TXT
-psybnc/help/TRANSLATE.TXT
-psybnc/help/UNADMIN.TXT
-psybnc/help/BVHOST.DEU
-psybnc/help/ADDIGNORE.DEU
-psybnc/help/ADDIGNORE.TXT
-psybnc/help/RELINK.TXT
-psybnc/help/DCCCHAT.TXT
-psybnc/help/DCCANSWER.TXT
-psybnc/help/DCCSEND.TXT
-psybnc/help/DCCGET.TXT
-psybnc/help/DCCCANCEL.TXT
-psybnc/help/BREHASH.TXT
-psybnc/help/LISTTASKS.TXT
-psybnc/help/SWITCHNET.TXT
-psybnc/help/DCCENABLE.TXT
-psybnc/help/AUTOREJOIN.TXT
-psybnc/help/LEAVEQUIT.TXT
-psybnc/help/AUTOGETDCC.TXT
-psybnc/help/ADDALLOW.DEU
-psybnc/help/ADDASK.DEU
-psybnc/help/ADDAUTOOP.DEU
-psybnc/help/ADDBAN.DEU
-psybnc/help/ADDDCC.DEU
-psybnc/help/ADDLOG.DEU
-psybnc/help/ADDNETWORK.DEU
-psybnc/help/ADDOP.DEU
-psybnc/help/ADDSERVER.DEU
-psybnc/help/ADDUSER.DEU
-psybnc/help/AIDLE.DEU
-psybnc/help/AUTOGETDCC.DEU
-psybnc/help/AUTOREJOIN.DEU
-psybnc/help/BCONNECT.DEU
-psybnc/help/BHELP.DEU
-psybnc/help/BKILL.DEU
-psybnc/help/BQUIT.DEU
-psybnc/help/BREHASH.DEU
-psybnc/help/BWHO.DEU
-psybnc/help/DCCANSWER.DEU
-psybnc/help/DCCCANCEL.DEU
-psybnc/help/DCCCHAT.DEU
-psybnc/help/DCCENABLE.DEU
-psybnc/help/DCCGET.DEU
-psybnc/help/DCCSEND.DEU
-psybnc/help/DELALLOW.DEU
-psybnc/help/DELASK.DEU
-psybnc/help/DELAUTOOP.DEU
-psybnc/help/DELBAN.DEU
-psybnc/help/DELDCC.DEU
-psybnc/help/DELENCRYPT.DEU
-psybnc/help/DELLINK.DEU
-psybnc/help/DELLOG.DEU
-psybnc/help/DELNETWORK.DEU
-psybnc/help/DELOP.DEU
-psybnc/help/DELSERVER.DEU
-psybnc/help/DELTRANSLATE.DEU
-psybnc/help/DELUSER.DEU
-psybnc/help/ENCRYPT.DEU
-psybnc/help/ERASEMAINLOG.DEU
-psybnc/help/ERASEPRIVATELOG.DEU
-psybnc/help/ERASETRAFFICLOG.DEU
-psybnc/help/JUMP.DEU
-psybnc/help/LEAVEQUIT.DEU
-psybnc/help/LINKFROM.DEU
-psybnc/help/LINKTO.DEU
-psybnc/help/LISTALLOW.DEU
-psybnc/help/LISTASK.DEU
-psybnc/help/LISTAUTOOPS.DEU
-psybnc/help/LISTBANS.DEU
-psybnc/help/LISTDCC.DEU
-psybnc/help/LISTENCRYPT.DEU
-psybnc/help/LISTLINKS.DEU
-psybnc/help/LISTLOGS.DEU
-psybnc/help/LISTOPS.DEU
-psybnc/help/LISTSERVERS.DEU
-psybnc/help/LISTTASKS.DEU
-psybnc/help/MADMIN.DEU
-psybnc/help/NAMEBOUNCER.DEU
-psybnc/help/PASSWORD.DEU
-psybnc/help/PLAYMAINLOG.DEU
-psybnc/help/PLAYPRIVATELOG.DEU
-psybnc/help/PLAYTRAFFICLOG.DEU
-psybnc/help/PROXY.DEU
-psybnc/help/RELAYLINK.DEU
-psybnc/help/RELINK.DEU
-psybnc/help/SETAWAY.DEU
-psybnc/help/SETAWAYNICK.DEU
-psybnc/help/SETLEAVEMSG.DEU
-psybnc/help/DELIGNORE.DEU
-psybnc/help/DELIGNORE.TXT
-psybnc/help/SETUSERNAME.DEU
-psybnc/help/SOCKSTAT.DEU
-psybnc/help/SRELOAD.DEU
-psybnc/help/SWITCHNET.DEU
-psybnc/help/TRANSLATE.DEU
-psybnc/help/UNADMIN.DEU
-psybnc/help/BVHOST.ITA
-psybnc/help/LISTIGNORES.DEU
-psybnc/help/LISTIGNORES.TXT
-psybnc/help/SETLANG.DEU
-psybnc/help/SETLANG.TXT
-psybnc/help/ADDALLOW.ITA
-psybnc/help/ADDASK.ITA
-psybnc/help/ADDAUTOOP.ITA
-psybnc/help/ADDBAN.ITA
-psybnc/help/ADDDCC.ITA
-psybnc/help/ADDIGNORE.ITA
-psybnc/help/ADDLOG.ITA
-psybnc/help/ADDNETWORK.ITA
-psybnc/help/ADDOP.ITA
-psybnc/help/ADDSERVER.ITA
-psybnc/help/ADDUSER.ITA
-psybnc/help/AIDLE.ITA
-psybnc/help/AUTOGETDCC.ITA
-psybnc/help/AUTOREJOIN.ITA
-psybnc/help/BCONNECT.ITA
-psybnc/help/BHELP.ITA
-psybnc/help/BKILL.ITA
-psybnc/help/BQUIT.ITA
-psybnc/help/BREHASH.ITA
-psybnc/help/BWHO.ITA
-psybnc/help/DCCANSWER.ITA
-psybnc/help/DCCCANCEL.ITA
-psybnc/help/DCCCHAT.ITA
-psybnc/help/DCCENABLE.ITA
-psybnc/help/DCCGET.ITA
-psybnc/help/DCCSEND.ITA
-psybnc/help/JUMP.ITA
-psybnc/help/DELALLOW.ITA
-psybnc/help/DELASK.ITA
-psybnc/help/DELAUTOOP.ITA
-psybnc/help/DELBAN.ITA
-psybnc/help/DELDCC.ITA
-psybnc/help/DELENCRYPT.ITA
-psybnc/help/DELIGNORE.ITA
-psybnc/help/DELLINK.ITA
-psybnc/help/DELLOG.ITA
-psybnc/help/DELNETWORK.ITA
-psybnc/help/DELOP.ITA
-psybnc/help/DELSERVER.ITA
-psybnc/help/DELTRANSLATE.ITA
-psybnc/help/DELUSER.ITA
-psybnc/help/ENCRYPT.ITA
-psybnc/help/ERASEMAINLOG.ITA
-psybnc/help/ERASEPRIVATELOG.ITA
-psybnc/help/ERASETRAFFICLOG.ITA
-psybnc/help/LEAVEQUIT.ITA
-psybnc/help/LINKFROM.ITA
-psybnc/help/LINKTO.ITA
-psybnc/help/LISTALLOW.ITA
-psybnc/help/LISTASK.ITA
-psybnc/help/LISTAUTOOPS.ITA
-psybnc/help/LISTBANS.ITA
-psybnc/help/LISTDCC.ITA
-psybnc/help/LISTENCRYPT.ITA
-psybnc/help/LISTIGNORES.ITA
-psybnc/help/LISTLINKS.ITA
-psybnc/help/LISTLOGS.ITA
-psybnc/help/LISTOPS.ITA
-psybnc/help/LISTSERVERS.ITA
-psybnc/help/LISTTASKS.ITA
-psybnc/help/MADMIN.ITA
-psybnc/help/NAMEBOUNCER.ITA
-psybnc/help/PASSWORD.ITA
-psybnc/help/PLAYMAINLOG.ITA
-psybnc/help/PLAYPRIVATELOG.ITA
-psybnc/help/PLAYTRAFFICLOG.ITA
-psybnc/help/PROXY.ITA
-psybnc/help/RELAYLINK.ITA
-psybnc/help/RELINK.ITA
-psybnc/help/SETAWAY.ITA
-psybnc/help/SETAWAYNICK.ITA
-psybnc/help/SETLANG.ITA
-psybnc/help/SETLEAVEMSG.ITA
-psybnc/help/SETUSERNAME.ITA
-psybnc/help/SOCKSTAT.ITA
-psybnc/help/SRELOAD.ITA
-psybnc/help/SWITCHNET.ITA
-psybnc/help/TRANSLATE.ITA
-psybnc/help/UNADMIN.ITA
-psybnc/help/BVHOST.TXT
-psybnc/help/DCCSENDME.TXT
-psybnc/help/DCCSENDME.ITA
-psybnc/help/DCCSENDME.DEU
-@dirrm psybnc/lang
-@dirrm psybnc/key
-@dirrm psybnc/help
-@dirrm psybnc
+@exec cp -np %D/%F %B/psybnc.conf
+%%PSYBASE%%/lang/INFO
+%%PSYBASE%%/lang/english.lng
+%%PSYBASE%%/lang/german.lng
+%%PSYBASE%%/lang/italiano.lng
+%%PSYBASE%%/help/ADDLOG.TXT
+%%PSYBASE%%/help/DELLOG.TXT
+%%PSYBASE%%/help/LISTLOGS.TXT
+%%PSYBASE%%/help/PLAYTRAFFICLOG.TXT
+%%PSYBASE%%/help/PROXY.TXT
+%%PSYBASE%%/help/SETLEAVEMSG.TXT
+%%PSYBASE%%/help/SETAWAYNICK.TXT
+%%PSYBASE%%/help/ADDAUTOOP.TXT
+%%PSYBASE%%/help/DELAUTOOP.TXT
+%%PSYBASE%%/help/LISTAUTOOPS.TXT
+%%PSYBASE%%/help/SRELOAD.TXT
+%%PSYBASE%%/help/ADDALLOW.TXT
+%%PSYBASE%%/help/ADDASK.TXT
+%%PSYBASE%%/help/ADDBAN.TXT
+%%PSYBASE%%/help/ADDDCC.TXT
+%%PSYBASE%%/help/ADDNETWORK.TXT
+%%PSYBASE%%/help/ADDOP.TXT
+%%PSYBASE%%/help/ADDSERVER.TXT
+%%PSYBASE%%/help/ADDUSER.TXT
+%%PSYBASE%%/help/BCONNECT.TXT
+%%PSYBASE%%/help/BHELP.TXT
+%%PSYBASE%%/help/BKILL.TXT
+%%PSYBASE%%/help/BQUIT.TXT
+%%PSYBASE%%/help/BWHO.TXT
+%%PSYBASE%%/help/DELALLOW.TXT
+%%PSYBASE%%/help/DELASK.TXT
+%%PSYBASE%%/help/DELBAN.TXT
+%%PSYBASE%%/help/DELDCC.TXT
+%%PSYBASE%%/help/DELENCRYPT.TXT
+%%PSYBASE%%/help/LISTASK.TXT
+%%PSYBASE%%/help/DELLINK.TXT
+%%PSYBASE%%/help/DELNETWORK.TXT
+%%PSYBASE%%/help/DELOP.TXT
+%%PSYBASE%%/help/DELSERVER.TXT
+%%PSYBASE%%/help/DELTRANSLATE.TXT
+%%PSYBASE%%/help/DELUSER.TXT
+%%PSYBASE%%/help/ENCRYPT.TXT
+%%PSYBASE%%/help/ERASEMAINLOG.TXT
+%%PSYBASE%%/help/ERASEPRIVATELOG.TXT
+%%PSYBASE%%/help/ERASETRAFFICLOG.TXT
+%%PSYBASE%%/help/JUMP.TXT
+%%PSYBASE%%/help/LINKFROM.TXT
+%%PSYBASE%%/help/LINKTO.TXT
+%%PSYBASE%%/help/LISTALLOW.TXT
+%%PSYBASE%%/help/AIDLE.TXT
+%%PSYBASE%%/help/LISTBANS.TXT
+%%PSYBASE%%/help/LISTDCC.TXT
+%%PSYBASE%%/help/LISTENCRYPT.TXT
+%%PSYBASE%%/help/LISTLINKS.TXT
+%%PSYBASE%%/help/LISTOPS.TXT
+%%PSYBASE%%/help/LISTSERVERS.TXT
+%%PSYBASE%%/help/MADMIN.TXT
+%%PSYBASE%%/help/NAMEBOUNCER.TXT
+%%PSYBASE%%/help/PASSWORD.TXT
+%%PSYBASE%%/help/PLAYMAINLOG.TXT
+%%PSYBASE%%/help/PLAYPRIVATELOG.TXT
+%%PSYBASE%%/help/RELAYLINK.TXT
+%%PSYBASE%%/help/SETAWAY.TXT
+%%PSYBASE%%/help/SETUSERNAME.TXT
+%%PSYBASE%%/help/SOCKSTAT.TXT
+%%PSYBASE%%/help/TRANSLATE.TXT
+%%PSYBASE%%/help/UNADMIN.TXT
+%%PSYBASE%%/help/BVHOST.DEU
+%%PSYBASE%%/help/ADDIGNORE.DEU
+%%PSYBASE%%/help/ADDIGNORE.TXT
+%%PSYBASE%%/help/RELINK.TXT
+%%PSYBASE%%/help/DCCCHAT.TXT
+%%PSYBASE%%/help/DCCANSWER.TXT
+%%PSYBASE%%/help/DCCSEND.TXT
+%%PSYBASE%%/help/DCCGET.TXT
+%%PSYBASE%%/help/DCCCANCEL.TXT
+%%PSYBASE%%/help/BREHASH.TXT
+%%PSYBASE%%/help/LISTTASKS.TXT
+%%PSYBASE%%/help/SWITCHNET.TXT
+%%PSYBASE%%/help/DCCENABLE.TXT
+%%PSYBASE%%/help/AUTOREJOIN.TXT
+%%PSYBASE%%/help/LEAVEQUIT.TXT
+%%PSYBASE%%/help/AUTOGETDCC.TXT
+%%PSYBASE%%/help/ADDALLOW.DEU
+%%PSYBASE%%/help/ADDASK.DEU
+%%PSYBASE%%/help/ADDAUTOOP.DEU
+%%PSYBASE%%/help/ADDBAN.DEU
+%%PSYBASE%%/help/ADDDCC.DEU
+%%PSYBASE%%/help/ADDLOG.DEU
+%%PSYBASE%%/help/ADDNETWORK.DEU
+%%PSYBASE%%/help/ADDOP.DEU
+%%PSYBASE%%/help/ADDSERVER.DEU
+%%PSYBASE%%/help/ADDUSER.DEU
+%%PSYBASE%%/help/AIDLE.DEU
+%%PSYBASE%%/help/AUTOGETDCC.DEU
+%%PSYBASE%%/help/AUTOREJOIN.DEU
+%%PSYBASE%%/help/BCONNECT.DEU
+%%PSYBASE%%/help/BHELP.DEU
+%%PSYBASE%%/help/BKILL.DEU
+%%PSYBASE%%/help/BQUIT.DEU
+%%PSYBASE%%/help/BREHASH.DEU
+%%PSYBASE%%/help/BWHO.DEU
+%%PSYBASE%%/help/DCCANSWER.DEU
+%%PSYBASE%%/help/DCCCANCEL.DEU
+%%PSYBASE%%/help/DCCCHAT.DEU
+%%PSYBASE%%/help/DCCENABLE.DEU
+%%PSYBASE%%/help/DCCGET.DEU
+%%PSYBASE%%/help/DCCSEND.DEU
+%%PSYBASE%%/help/DELALLOW.DEU
+%%PSYBASE%%/help/DELASK.DEU
+%%PSYBASE%%/help/DELAUTOOP.DEU
+%%PSYBASE%%/help/DELBAN.DEU
+%%PSYBASE%%/help/DELDCC.DEU
+%%PSYBASE%%/help/DELENCRYPT.DEU
+%%PSYBASE%%/help/DELLINK.DEU
+%%PSYBASE%%/help/DELLOG.DEU
+%%PSYBASE%%/help/DELNETWORK.DEU
+%%PSYBASE%%/help/DELOP.DEU
+%%PSYBASE%%/help/DELSERVER.DEU
+%%PSYBASE%%/help/DELTRANSLATE.DEU
+%%PSYBASE%%/help/DELUSER.DEU
+%%PSYBASE%%/help/ENCRYPT.DEU
+%%PSYBASE%%/help/ERASEMAINLOG.DEU
+%%PSYBASE%%/help/ERASEPRIVATELOG.DEU
+%%PSYBASE%%/help/ERASETRAFFICLOG.DEU
+%%PSYBASE%%/help/JUMP.DEU
+%%PSYBASE%%/help/LEAVEQUIT.DEU
+%%PSYBASE%%/help/LINKFROM.DEU
+%%PSYBASE%%/help/LINKTO.DEU
+%%PSYBASE%%/help/LISTALLOW.DEU
+%%PSYBASE%%/help/LISTASK.DEU
+%%PSYBASE%%/help/LISTAUTOOPS.DEU
+%%PSYBASE%%/help/LISTBANS.DEU
+%%PSYBASE%%/help/LISTDCC.DEU
+%%PSYBASE%%/help/LISTENCRYPT.DEU
+%%PSYBASE%%/help/LISTLINKS.DEU
+%%PSYBASE%%/help/LISTLOGS.DEU
+%%PSYBASE%%/help/LISTOPS.DEU
+%%PSYBASE%%/help/LISTSERVERS.DEU
+%%PSYBASE%%/help/LISTTASKS.DEU
+%%PSYBASE%%/help/MADMIN.DEU
+%%PSYBASE%%/help/NAMEBOUNCER.DEU
+%%PSYBASE%%/help/PASSWORD.DEU
+%%PSYBASE%%/help/PLAYMAINLOG.DEU
+%%PSYBASE%%/help/PLAYPRIVATELOG.DEU
+%%PSYBASE%%/help/PLAYTRAFFICLOG.DEU
+%%PSYBASE%%/help/PROXY.DEU
+%%PSYBASE%%/help/RELAYLINK.DEU
+%%PSYBASE%%/help/RELINK.DEU
+%%PSYBASE%%/help/SETAWAY.DEU
+%%PSYBASE%%/help/SETAWAYNICK.DEU
+%%PSYBASE%%/help/SETLEAVEMSG.DEU
+%%PSYBASE%%/help/DELIGNORE.DEU
+%%PSYBASE%%/help/DELIGNORE.TXT
+%%PSYBASE%%/help/SETUSERNAME.DEU
+%%PSYBASE%%/help/SOCKSTAT.DEU
+%%PSYBASE%%/help/SRELOAD.DEU
+%%PSYBASE%%/help/SWITCHNET.DEU
+%%PSYBASE%%/help/TRANSLATE.DEU
+%%PSYBASE%%/help/UNADMIN.DEU
+%%PSYBASE%%/help/BVHOST.ITA
+%%PSYBASE%%/help/LISTIGNORES.DEU
+%%PSYBASE%%/help/LISTIGNORES.TXT
+%%PSYBASE%%/help/SETLANG.DEU
+%%PSYBASE%%/help/SETLANG.TXT
+%%PSYBASE%%/help/ADDALLOW.ITA
+%%PSYBASE%%/help/ADDASK.ITA
+%%PSYBASE%%/help/ADDAUTOOP.ITA
+%%PSYBASE%%/help/ADDBAN.ITA
+%%PSYBASE%%/help/ADDDCC.ITA
+%%PSYBASE%%/help/ADDIGNORE.ITA
+%%PSYBASE%%/help/ADDLOG.ITA
+%%PSYBASE%%/help/ADDNETWORK.ITA
+%%PSYBASE%%/help/ADDOP.ITA
+%%PSYBASE%%/help/ADDSERVER.ITA
+%%PSYBASE%%/help/ADDUSER.ITA
+%%PSYBASE%%/help/AIDLE.ITA
+%%PSYBASE%%/help/AUTOGETDCC.ITA
+%%PSYBASE%%/help/AUTOREJOIN.ITA
+%%PSYBASE%%/help/BCONNECT.ITA
+%%PSYBASE%%/help/BHELP.ITA
+%%PSYBASE%%/help/BKILL.ITA
+%%PSYBASE%%/help/BQUIT.ITA
+%%PSYBASE%%/help/BREHASH.ITA
+%%PSYBASE%%/help/BWHO.ITA
+%%PSYBASE%%/help/DCCANSWER.ITA
+%%PSYBASE%%/help/DCCCANCEL.ITA
+%%PSYBASE%%/help/DCCCHAT.ITA
+%%PSYBASE%%/help/DCCENABLE.ITA
+%%PSYBASE%%/help/DCCGET.ITA
+%%PSYBASE%%/help/DCCSEND.ITA
+%%PSYBASE%%/help/JUMP.ITA
+%%PSYBASE%%/help/DELALLOW.ITA
+%%PSYBASE%%/help/DELASK.ITA
+%%PSYBASE%%/help/DELAUTOOP.ITA
+%%PSYBASE%%/help/DELBAN.ITA
+%%PSYBASE%%/help/DELDCC.ITA
+%%PSYBASE%%/help/DELENCRYPT.ITA
+%%PSYBASE%%/help/DELIGNORE.ITA
+%%PSYBASE%%/help/DELLINK.ITA
+%%PSYBASE%%/help/DELLOG.ITA
+%%PSYBASE%%/help/DELNETWORK.ITA
+%%PSYBASE%%/help/DELOP.ITA
+%%PSYBASE%%/help/DELSERVER.ITA
+%%PSYBASE%%/help/DELTRANSLATE.ITA
+%%PSYBASE%%/help/DELUSER.ITA
+%%PSYBASE%%/help/ENCRYPT.ITA
+%%PSYBASE%%/help/ERASEMAINLOG.ITA
+%%PSYBASE%%/help/ERASEPRIVATELOG.ITA
+%%PSYBASE%%/help/ERASETRAFFICLOG.ITA
+%%PSYBASE%%/help/LEAVEQUIT.ITA
+%%PSYBASE%%/help/LINKFROM.ITA
+%%PSYBASE%%/help/LINKTO.ITA
+%%PSYBASE%%/help/LISTALLOW.ITA
+%%PSYBASE%%/help/LISTASK.ITA
+%%PSYBASE%%/help/LISTAUTOOPS.ITA
+%%PSYBASE%%/help/LISTBANS.ITA
+%%PSYBASE%%/help/LISTDCC.ITA
+%%PSYBASE%%/help/LISTENCRYPT.ITA
+%%PSYBASE%%/help/LISTIGNORES.ITA
+%%PSYBASE%%/help/LISTLINKS.ITA
+%%PSYBASE%%/help/LISTLOGS.ITA
+%%PSYBASE%%/help/LISTOPS.ITA
+%%PSYBASE%%/help/LISTSERVERS.ITA
+%%PSYBASE%%/help/LISTTASKS.ITA
+%%PSYBASE%%/help/MADMIN.ITA
+%%PSYBASE%%/help/NAMEBOUNCER.ITA
+%%PSYBASE%%/help/PASSWORD.ITA
+%%PSYBASE%%/help/PLAYMAINLOG.ITA
+%%PSYBASE%%/help/PLAYPRIVATELOG.ITA
+%%PSYBASE%%/help/PLAYTRAFFICLOG.ITA
+%%PSYBASE%%/help/PROXY.ITA
+%%PSYBASE%%/help/RELAYLINK.ITA
+%%PSYBASE%%/help/RELINK.ITA
+%%PSYBASE%%/help/SETAWAY.ITA
+%%PSYBASE%%/help/SETAWAYNICK.ITA
+%%PSYBASE%%/help/SETLANG.ITA
+%%PSYBASE%%/help/SETLEAVEMSG.ITA
+%%PSYBASE%%/help/SETUSERNAME.ITA
+%%PSYBASE%%/help/SOCKSTAT.ITA
+%%PSYBASE%%/help/SRELOAD.ITA
+%%PSYBASE%%/help/SWITCHNET.ITA
+%%PSYBASE%%/help/TRANSLATE.ITA
+%%PSYBASE%%/help/UNADMIN.ITA
+%%PSYBASE%%/help/BVHOST.TXT
+%%PSYBASE%%/help/DCCSENDME.TXT
+%%PSYBASE%%/help/DCCSENDME.ITA
+%%PSYBASE%%/help/DCCSENDME.DEU
+%%PSYBASE%%/key/ssl.cnf
+@dirrm %%PSYBASE%%/lang
+@dirrm %%PSYBASE%%/help
+@dirrmtry %%PSYBASE%%/key
+@dirrmtry %%PSYBASE%%