aboutsummaryrefslogtreecommitdiff
path: root/irc/ptlink-ircd/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-10-25 09:31:19 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-10-25 09:31:19 +0000
commite4b4e130b3069c6ad4a7d9ba20f717ea4a3879dc (patch)
tree19f9c59113c059563ac51dc68dea9b49211efb98 /irc/ptlink-ircd/Makefile
parent91046d07ef13f070dde0f499e7ecab785f2ccabf (diff)
downloadports-e4b4e130b3069c6ad4a7d9ba20f717ea4a3879dc.tar.gz
ports-e4b4e130b3069c6ad4a7d9ba20f717ea4a3879dc.zip
Notes
Diffstat (limited to 'irc/ptlink-ircd/Makefile')
-rw-r--r--irc/ptlink-ircd/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/irc/ptlink-ircd/Makefile b/irc/ptlink-ircd/Makefile
new file mode 100644
index 000000000000..bb1c9b36dfa0
--- /dev/null
+++ b/irc/ptlink-ircd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: PTlink IRC daemon
+# Date created: 22 October 2004
+# Whom: Dennis Cabooter <dennis@rootxs.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IRCd
+PORTVERSION= 6.18.2
+CATEGORIES= irc
+MASTER_SITES= ftp://ftp.sunsite.dk/projects/ptlink/ircd/
+PKGNAMEPREFIX= PTlink-
+DISTNAME= PTlink${PORTVERSION}
+
+MAINTAINER= dennis@rootxs.org
+COMMENT= PTlink IRC daemon
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-install:
+.for f in ircd.conf ircd.motd kline.conf main.dconf network.dconf opers.motd
+ @${MV} ${PREFIX}/etc/${f} ${PREFIX}/etc/${f}.sample
+.endfor
+ @${SED} 's,%%PREFIX%%,${PREFIX},g' < ${PKGMESSAGE}
+
+.include <bsd.port.mk>