aboutsummaryrefslogtreecommitdiff
path: root/irc/pure-emacs21
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2007-10-14 09:27:58 +0000
committerVasil Dimov <vd@FreeBSD.org>2007-10-14 09:27:58 +0000
commit9e071a0a240003b6d804de3ce242ce01b71be45e (patch)
treeb368ef7ba61b635ecc0afccda7ad761be096534a /irc/pure-emacs21
parent708e659328998c94156cba4421f18ba99c3a20bb (diff)
downloadports-9e071a0a240003b6d804de3ce242ce01b71be45e.tar.gz
ports-9e071a0a240003b6d804de3ce242ce01b71be45e.zip
Notes
Diffstat (limited to 'irc/pure-emacs21')
-rw-r--r--irc/pure-emacs21/Makefile36
1 files changed, 31 insertions, 5 deletions
diff --git a/irc/pure-emacs21/Makefile b/irc/pure-emacs21/Makefile
index e9689e50b2d7..13d689ae0702 100644
--- a/irc/pure-emacs21/Makefile
+++ b/irc/pure-emacs21/Makefile
@@ -1,13 +1,39 @@
-# New ports collection makefile for: pure (for emacs21)
-# Date Created: 29 Oct 2001
+# New ports collection makefile for: pure (for emacs20)
+# Date Created: 3 May 2001
# Whom: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
#
# $FreeBSD$
#
-MASTERDIR= ${.CURDIR}/../pure-emacs20
+PORTNAME= pure
+PORTVERSION= 0.6
+PORTREVISION= 2
+CATEGORIES= irc elisp
+MASTER_SITES= http://his.luky.org/ftp/mirrors/irchat-pj/2.5/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+DISTNAME= pure-${PORTVERSION}p
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${PORTNAME}-${PORTVERSION}pl2.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= yoichi@FreeBSD.org
+COMMENT= Primitive Universal Relay-chat Environment
+
+USE_BZIP2= yes
USE_EMACS= yes
-EMACS_PORT_NAME= emacs21
+EMACS_PORT_NAME?= emacs21
+LISPDIR?= ${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+EMACS_ONLY?= ""
+XEMACS_ONLY?= "@comment "
+PUREBIN?= bin
+MAKE_ARGS+= LISPDIR=${PREFIX}/${LISPDIR} \
+ PACKDIR=${PREFIX}/${EMACS_LIBDIR}/site-packages \
+ BINDIR=${PREFIX}/${PUREBIN}
+
+PLIST_SUB= PURELISP=${LISPDIR} \
+ EMACS_ONLY=${EMACS_ONLY} \
+ XEMACS_ONLY=${XEMACS_ONLY} \
+ PUREBIN=${PUREBIN}
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>