aboutsummaryrefslogtreecommitdiff
path: root/irc/py-gozerbot/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-04-26 20:47:49 +0000
committerSteve Wills <swills@FreeBSD.org>2014-04-26 20:47:49 +0000
commit6313d7e8357a7128bf39cf69654d2df60cfd1a9a (patch)
tree5df9361d273ceee8c16be4e401ca1172aa5df04e /irc/py-gozerbot/Makefile
parent3d871a37041bd1146669352ed3551d63a7b449a7 (diff)
downloadports-6313d7e8357a7128bf39cf69654d2df60cfd1a9a.tar.gz
ports-6313d7e8357a7128bf39cf69654d2df60cfd1a9a.zip
Notes
Diffstat (limited to 'irc/py-gozerbot/Makefile')
-rw-r--r--irc/py-gozerbot/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/irc/py-gozerbot/Makefile b/irc/py-gozerbot/Makefile
index 0680f70a98b9..11c8d63c1498 100644
--- a/irc/py-gozerbot/Makefile
+++ b/irc/py-gozerbot/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= irc python
MASTER_SITES= http://gozerbot.org/media/tarball/ \
${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= gozerbot-${PORTVERSION}
MAINTAINER= sten@blinkenlights.nl
COMMENT= Gozerbot - A modular Python IRC and Jabber bot
@@ -26,18 +25,17 @@ MAN1= gozerbot.1
RUN_DEPENDS+= ${LOCALBASE}/bin/gpg:${PORTSDIR}/security/gnupg
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
@${CAT} ${PKGMESSAGE}
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
- ${CP} ${WRKSRC}/README ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${STAGEDIR}${DOCSDIR}
+ ${CP} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
- @${INSTALL_MAN} ${WRKSRC}/man/gozerbot.1.FreeBSD ${PREFIX}/man/man1/gozerbot.1
+ @${INSTALL_MAN} ${WRKSRC}/man/gozerbot.1.FreeBSD ${STAGEDIR}${MAN1PREFIX}/gozerbot.1
.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb