aboutsummaryrefslogtreecommitdiff
path: root/irc/py-irc/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-11-22 11:21:39 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-11-22 11:21:39 +0000
commit5697ce41f6a24162cbd7eda53987a4f78552a256 (patch)
tree5ff640bc26d5be279793a548a10788287934441f /irc/py-irc/Makefile
parent6374cb794e7248b3ace0b8be0e9d6c146f83a183 (diff)
downloadports-5697ce41f6a24162cbd7eda53987a4f78552a256.tar.gz
ports-5697ce41f6a24162cbd7eda53987a4f78552a256.zip
Notes
Diffstat (limited to 'irc/py-irc/Makefile')
-rw-r--r--irc/py-irc/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/irc/py-irc/Makefile b/irc/py-irc/Makefile
new file mode 100644
index 000000000000..878f68098c44
--- /dev/null
+++ b/irc/py-irc/Makefile
@@ -0,0 +1,37 @@
+# Created by: Hye-Shik Chang
+# $FreeBSD$
+
+PORTNAME= irc
+PORTVERSION= 5.0.1
+CATEGORIES= irc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= william88@gmail.com
+COMMENT= IRC protocol client library for Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+USE_ZIP= yes
+
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}hgtools>0:${PORTSDIR}/devel/py-hgtools
+
+EXAMPLEFILES= irccat.py irccat2.py servermap.py testbot.py \
+ dccreceive.py dccsend.py
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXAMPLEFILES}
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/${file} ${EXAMPLESDIR}/
+.endfor
+.endif
+
+.if ${PYTHON_REL} < 270
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib>0:${PORTSDIR}/devel/py-importlib
+.endif
+
+.include <bsd.port.post.mk>