aboutsummaryrefslogtreecommitdiff
path: root/irc/quassel
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2008-09-06 22:34:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2008-09-06 22:34:03 +0000
commit3450d3733c98c98ca3ac5c2ddc3e14853439e331 (patch)
treebcaf9a04c1fde64c0ff03718f164f4646a9f7188 /irc/quassel
parent68d50a8eb43ee0d90ab9579af85ac273ecde72ec (diff)
downloadports-3450d3733c98c98ca3ac5c2ddc3e14853439e331.tar.gz
ports-3450d3733c98c98ca3ac5c2ddc3e14853439e331.zip
Notes
Diffstat (limited to 'irc/quassel')
-rw-r--r--irc/quassel/Makefile26
-rw-r--r--irc/quassel/distinfo3
-rw-r--r--irc/quassel/pkg-descr10
-rw-r--r--irc/quassel/pkg-plist6
4 files changed, 45 insertions, 0 deletions
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
new file mode 100644
index 000000000000..a64e152ae1b9
--- /dev/null
+++ b/irc/quassel/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: quassel
+# Date created: 2008-08-10
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quassel
+DISTVERSION= 0.3.0.1
+CATEGORIES= irc
+MASTER_SITES= http://www.quassel-irc.org/pub/
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Qt4 based distributed IRC client
+
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui network script sql dbus xml \
+ qmake_build moc_build rcc_build uic_build
+
+CMAKE_ARGS+= -DWANT_MONO=ON
+
+.include <bsd.port.mk>
diff --git a/irc/quassel/distinfo b/irc/quassel/distinfo
new file mode 100644
index 000000000000..210852e1a2f8
--- /dev/null
+++ b/irc/quassel/distinfo
@@ -0,0 +1,3 @@
+MD5 (quassel-0.3.0.1.tar.bz2) = 20490f97c9fc9a147f5aa5a30afcc413
+SHA256 (quassel-0.3.0.1.tar.bz2) = d1408b8b02c1ee831f24708c71cba2540bf3f8c9b205af76046a40b655926b02
+SIZE (quassel-0.3.0.1.tar.bz2) = 1971442
diff --git a/irc/quassel/pkg-descr b/irc/quassel/pkg-descr
new file mode 100644
index 000000000000..d4e483464292
--- /dev/null
+++ b/irc/quassel/pkg-descr
@@ -0,0 +1,10 @@
+Quassel IRC is a modern, cross-platform, distributed IRC client
+based on the Qt4 framework. Distributed means that one (or multiple)
+client(s) can attach to and detach from a central core that stays
+permanently online. Re-attaching your client will show your IRC
+session in the same state as you left it in (plus whatever happened
+while you were gone), and this even when you re-attach from a
+different location. An optional Beginner's Mode completely hides
+this feature, so Quassel IRC can be used like a traditional client.
+
+WWW: http://www.quassel-irc.org/
diff --git a/irc/quassel/pkg-plist b/irc/quassel/pkg-plist
new file mode 100644
index 000000000000..156da958ca38
--- /dev/null
+++ b/irc/quassel/pkg-plist
@@ -0,0 +1,6 @@
+bin/quassel
+bin/quasselclient
+bin/quasselcore
+share/applications/quassel.desktop
+share/applications/quasselclient.desktop
+@dirrmtry share/applications