aboutsummaryrefslogtreecommitdiff
path: root/irc/quirc/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-14 09:04:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-14 09:04:59 +0000
commit0a1e206bd2ba8dab62b6a60157d4ee27f83da3b5 (patch)
tree565c86a715db994828f1dc96363d9edd114bb54f /irc/quirc/Makefile
parent169d0d8b398a31fefffca9e6bf1b7660fb83d8ca (diff)
downloadports-0a1e206bd2ba8dab62b6a60157d4ee27f83da3b5.tar.gz
ports-0a1e206bd2ba8dab62b6a60157d4ee27f83da3b5.zip
Notes
Diffstat (limited to 'irc/quirc/Makefile')
-rw-r--r--irc/quirc/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/irc/quirc/Makefile b/irc/quirc/Makefile
index 3ed04ac79f93..9d799967ff97 100644
--- a/irc/quirc/Makefile
+++ b/irc/quirc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: QuIRC
-# Date created: 21 May 1999
-# Whom: Chris Piazza <cpiazza@FreeBSD.org>
-#
+# Created by: Chris Piazza <cpiazza@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= quirc
PORTVERSION= 0.9.84
@@ -12,9 +8,9 @@ CATEGORIES= irc tk
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:local/}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An irc client for the X Window System that uses TCL/TK
+COMMENT= Tcl/Tk IRC client for the X Window System
-USE_TK= 84+
+USE_TK= 84
USE_XORG= xt
GNU_CONFIGURE= yes
@@ -23,7 +19,8 @@ MYPORTDOCS= AUTHORS ChangeLog FAQ NEWS README doc/color.txt \
doc/dccresum.txt doc/links.txt doc/nickcomp.txt \
doc/quedit.txt doc/rfc1459.txt doc/tdcc.txt
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
CONFIGURE_ARGS= --with-wish=${WISH} \
--with-tcl-include-dir=${TCL_INCLUDEDIR} \
--with-tk-include-dir=${TK_INCLUDEDIR} \
@@ -38,11 +35,11 @@ post-install:
${LN} -sf ../install.tcl ${DATADIR}/common
@${MKDIR} ${DATADIR}/themes
${LN} -sf ../default.tcl ${DATADIR}/themes
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${MYPORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>