aboutsummaryrefslogtreecommitdiff
path: root/irc/quirc
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-20 10:01:58 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-20 10:01:58 +0000
commit2b0d56f5288bfa58789a16426d08a567bbe8ed81 (patch)
treea21f92d8413d647a3bc4842ceebc4dee2ae8cc0b /irc/quirc
parent735668549a7ab14d96c513ac136b9a19cc1c90e5 (diff)
downloadports-2b0d56f5288bfa58789a16426d08a567bbe8ed81.tar.gz
ports-2b0d56f5288bfa58789a16426d08a567bbe8ed81.zip
Notes
Diffstat (limited to 'irc/quirc')
-rw-r--r--irc/quirc/Makefile28
-rw-r--r--irc/quirc/files/patch-data_Makefile.in11
-rw-r--r--irc/quirc/pkg-plist13
3 files changed, 25 insertions, 27 deletions
diff --git a/irc/quirc/Makefile b/irc/quirc/Makefile
index 84ed7593b026..b05bdb0cc6be 100644
--- a/irc/quirc/Makefile
+++ b/irc/quirc/Makefile
@@ -10,18 +10,20 @@ MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:local/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tcl/Tk IRC client for the X Window System
-USE_TK= 84+
+OPTIONS_DEFINE= DOCS
+
+USES= tk
USE_XORG= xt
GNU_CONFIGURE= yes
+MAKE_ENV+= DESTDIR=${STAGEDIR}
+CFLAGS+= -Wno-deprecated-writable-strings
MYPORTDOCS= AUTHORS ChangeLog FAQ NEWS README doc/color.txt \
doc/dccresum.txt doc/links.txt doc/nickcomp.txt \
doc/quedit.txt doc/rfc1459.txt doc/tdcc.txt
+PORTDOCS= *
-NO_STAGE= yes
-
-OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
@@ -30,20 +32,18 @@ CONFIGURE_ARGS= --with-wish=${WISH} \
--with-tk-include-dir=${TK_INCLUDEDIR} \
--with-tcl-lib-dir=${TCL_LIBDIR} \
--with-tk-lib-dir=${TK_LIBDIR} \
- --with-tcl-lib=tcl${TCL_VER:S/.//} \
- --with-tk-lib=tk${TCL_VER:S/.//} \
+ --with-tcl-lib=tcl${TCL_SHLIB_VER} \
+ --with-tk-lib=tk${TCL_SHLIB_VER} \
--with-tcl-version=${TCL_VER}
post-install:
- @${MKDIR} ${DATADIR}/common
- ${LN} -sf ../install.tcl ${DATADIR}/common
- @${MKDIR} ${DATADIR}/themes
- ${LN} -sf ../default.tcl ${DATADIR}/themes
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/common
+ ${LN} -sf ../install.tcl ${STAGEDIR}${DATADIR}/common
+ @${MKDIR} ${STAGEDIR}${DATADIR}/themes
+ ${LN} -sf ../default.tcl ${STAGEDIR}${DATADIR}/themes
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${MYPORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/irc/quirc/files/patch-data_Makefile.in b/irc/quirc/files/patch-data_Makefile.in
new file mode 100644
index 000000000000..6d3f46306777
--- /dev/null
+++ b/irc/quirc/files/patch-data_Makefile.in
@@ -0,0 +1,11 @@
+--- data/Makefile.in.orig 2014-02-20 11:02:35.000000000 +0100
++++ data/Makefile.in 2014-02-20 11:02:42.000000000 +0100
+@@ -316,7 +316,7 @@
+
+
+ install-exec-local:
+- rm -rf $(pkgdatadir)
++ rm -rf $(DESTDIR)$(pkgdatadir)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/irc/quirc/pkg-plist b/irc/quirc/pkg-plist
index 4b016ef080ac..e3cb2e8a5d5c 100644
--- a/irc/quirc/pkg-plist
+++ b/irc/quirc/pkg-plist
@@ -1,16 +1,4 @@
bin/quirc
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/color.txt
-%%PORTDOCS%%%%DOCSDIR%%/dccresum.txt
-%%PORTDOCS%%%%DOCSDIR%%/links.txt
-%%PORTDOCS%%%%DOCSDIR%%/nickcomp.txt
-%%PORTDOCS%%%%DOCSDIR%%/quedit.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc1459.txt
-%%PORTDOCS%%%%DOCSDIR%%/tdcc.txt
%%DATADIR%%/VERSION
%%DATADIR%%/common/install.tcl
%%DATADIR%%/dal.tcl
@@ -36,4 +24,3 @@ bin/quirc
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%/common
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%