aboutsummaryrefslogtreecommitdiff
path: root/irc/ratbox-services/files
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-28 01:03:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-28 01:03:41 +0000
commit261936f816ba21bbd02ea311453a3e5b3781f410 (patch)
treed9f697d4441d4e0e61ecfa89d19a8d96d99f6165 /irc/ratbox-services/files
parent8c96eddf93e0e73b82f993778ec8eebe42f6cba1 (diff)
downloadports-261936f816ba21bbd02ea311453a3e5b3781f410.tar.gz
ports-261936f816ba21bbd02ea311453a3e5b3781f410.zip
Notes
Diffstat (limited to 'irc/ratbox-services/files')
-rw-r--r--irc/ratbox-services/files/patch-Makefile.in17
-rw-r--r--irc/ratbox-services/files/patch-help_Makefile.in6
-rw-r--r--irc/ratbox-services/files/patch-tools_dbupgrade.pl23
-rw-r--r--irc/ratbox-services/files/patch-tools_generate-schema.pl17
-rw-r--r--irc/ratbox-services/files/pkg-install.in17
-rw-r--r--irc/ratbox-services/files/pkg-message.in46
6 files changed, 103 insertions, 23 deletions
diff --git a/irc/ratbox-services/files/patch-Makefile.in b/irc/ratbox-services/files/patch-Makefile.in
index d5bbdf94849a..469754189a9f 100644
--- a/irc/ratbox-services/files/patch-Makefile.in
+++ b/irc/ratbox-services/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Wed May 18 00:33:18 2005
-+++ Makefile.in Sat Jan 28 22:58:12 2006
+--- ./Makefile.in.orig Mon Apr 10 19:53:23 2006
++++ ./Makefile.in Wed Sep 5 04:08:35 2007
@@ -6,7 +6,7 @@
LIBS=@LIBS@
LDFLAGS=@LDFLAGS@
@@ -9,7 +9,7 @@
prefix=@prefix@
exec_prefix=@prefix@
-@@ -36,17 +36,6 @@
+@@ -37,20 +37,6 @@
done
install: build
@@ -17,13 +17,16 @@
- $(INSTALL) -m 750 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(sbindir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(sysconfdir)
+- $(INSTALL) -m 750 -d $(DESTDIR)$(includedir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(logdir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(rundir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(helpdir)
+- $(INSTALL) -m 750 -d $(DESTDIR)$(includedir)
- $(INSTALL) -m 750 tools/ircd-shortcut.pl $(DESTDIR)$(bindir)
+- $(INSTALL) -m 750 tools/dbupgrade.pl $(DESTDIR)$(bindir)
+- $(INSTALL) -m 640 tools/definetolength.pl $(DESTDIR)$(bindir)
- $(INSTALL) -m 750 src/$(BIN) $(DESTDIR)$(sbindir)
- $(INSTALL) -m 640 doc/example.conf $(DESTDIR)$(sysconfdir)
-- $(INSTALL) -m 640 doc/schema.txt $(DESTDIR)$(sysconfdir)
- @for i in $(SUBDIRS); do \
- echo "install -> $$i"; \
- cd $$i; \
+ $(INSTALL) -m 640 include/setup.h $(DESTDIR)$(includedir)
+ $(INSTALL) -m 640 include/rserv.h $(DESTDIR)$(includedir)
+ $(INSTALL) -m 640 include/channel.h $(DESTDIR)$(includedir)
diff --git a/irc/ratbox-services/files/patch-help_Makefile.in b/irc/ratbox-services/files/patch-help_Makefile.in
index d49a8a82ba6f..2efa0b8b3068 100644
--- a/irc/ratbox-services/files/patch-help_Makefile.in
+++ b/irc/ratbox-services/files/patch-help_Makefile.in
@@ -1,7 +1,7 @@
---- help/Makefile.in.orig Wed Jun 15 15:21:39 2005
-+++ help/Makefile.in Sat Jan 28 23:15:11 2006
+--- ./help/Makefile.in.orig Fri Aug 24 12:32:24 2007
++++ ./help/Makefile.in Fri Aug 24 12:15:25 2007
@@ -10,10 +10,10 @@
- SUBDIRS=alis main operbot chanserv userserv jupeserv operserv nickserv global banserv
+ SUBDIRS=alis main operbot chanserv userserv jupeserv operserv nickserv global banserv watchserv
install:
- $(INSTALL) -m 750 -d $(DESTDIR)$(helpdir)
diff --git a/irc/ratbox-services/files/patch-tools_dbupgrade.pl b/irc/ratbox-services/files/patch-tools_dbupgrade.pl
new file mode 100644
index 000000000000..8ada4c52e9a4
--- /dev/null
+++ b/irc/ratbox-services/files/patch-tools_dbupgrade.pl
@@ -0,0 +1,23 @@
+--- ./tools/dbupgrade.pl.orig Fri Aug 24 13:01:39 2007
++++ ./tools/dbupgrade.pl Fri Aug 24 13:38:23 2007
+@@ -27,9 +27,9 @@
+ exit;
+ }
+
+-unless(-r "../include/setup.h")
++unless(-r "%%PREFIX%%/include/setup.h")
+ {
+- print("Unable to read ../include/setup.h, please run configure first\n");
++ print("Unable to read %%PREFIX%%/include/setup.h, please run configure first\n");
+ exit();
+ }
+
+@@ -71,7 +71,7 @@
+ }
+ else
+ {
+- %vals = &parse_includes("../include");
++ %vals = &parse_includes("%%PREFIX%%/include");
+ }
+
+ while(my ($key, $value) = each(%vals))
diff --git a/irc/ratbox-services/files/patch-tools_generate-schema.pl b/irc/ratbox-services/files/patch-tools_generate-schema.pl
new file mode 100644
index 000000000000..335d2b8ec5ad
--- /dev/null
+++ b/irc/ratbox-services/files/patch-tools_generate-schema.pl
@@ -0,0 +1,17 @@
+--- ./tools/generate-schema.pl.orig Fri Aug 24 12:45:51 2007
++++ ./tools/generate-schema.pl Fri Aug 24 12:49:13 2007
+@@ -15,11 +15,11 @@
+ my @schemas = ("base/schema-mysql.txt", "base/schema-pgsql.txt");
+ my @plain_schemas = ("base/schema-sqlite.txt");
+
+-my %vals = &parse_includes("../include");
++my %vals = &parse_includes("%%PREFIX%%/include");
+
+-unless(-r "../include/setup.h")
++unless(-r "%%PREFIX%%/include/setup.h")
+ {
+- print("Unable to read ../include/setup.h, please run configure first\n");
++ print("Unable to read %%PREFIX%%/include/setup.h, please run configure first\n");
+ exit();
+ }
+
diff --git a/irc/ratbox-services/files/pkg-install.in b/irc/ratbox-services/files/pkg-install.in
index 5aec496c1d8e..f7a260249d5f 100644
--- a/irc/ratbox-services/files/pkg-install.in
+++ b/irc/ratbox-services/files/pkg-install.in
@@ -100,25 +100,22 @@ touch $lf \
&& chown ircservices:ircservices $lf \
&& chmod 640 $lf
-mkdir -p %%DBDIR%%
-db="%%DBDIR%%/ratbox-services.db"
-
-if [ ! -f $db ]; then
- echo "Initialising services database..."
- %%LOCALBASE%%/bin/sqlite $db < %%DATADIR%%/schema.sql
-fi
+mkdir -p %%DBDIR%% \
+&& chown ircservices:ircservices %%DBDIR%% \
+&& chmod 750 %%DBDIR%%
# Secure permissions if we think this is a fresh install
if [ ! -f ${PKG_PREFIX}/ratbox-services.conf ]; then
- chown -R ircservices:ircservices %%DBDIR%%
chown ircservices:ircservices ${PKG_PREFIX}/etc/ratbox-services.conf.sample
- chmod 750 %%DBDIR%%
- chmod 640 $db
chmod 640 ${PKG_PREFIX}/etc/ratbox-services.conf.sample
fi
+cd %%DATADIR%% \
+&& %%PERL%% ./generate-schema.pl
+
+
#-----------------------------------------------------------------------
fi
#-----------------------------------------------------------------------
diff --git a/irc/ratbox-services/files/pkg-message.in b/irc/ratbox-services/files/pkg-message.in
index 197977db07e5..8fc6f848c92c 100644
--- a/irc/ratbox-services/files/pkg-message.in
+++ b/irc/ratbox-services/files/pkg-message.in
@@ -2,11 +2,51 @@
ratbox-services has been successfully installed.
You should now copy %%PREFIX%%/etc/ratbox-services.conf.sample to
-%%PREFIX%%/etc/ratbox-services.conf, and edit it as per the ratbox-services
-documentation. This file is required to start the server.
+%%PREFIX%%/etc/ratbox-services.conf, and edit it as per the
+ratbox-services documentation. This file is required to start services.
+
+You may also need to perform the following steps, if you have not
+already done so:
+
+Initialize Database:
+--------------------
+This must be done before the services server can start, even if you are
+converting from hybserv. Instructions for this are contained in:
+
+ %%DOCSDIR%%/INSTALL.<database_backend>
+
+The following directory has been created for the database to be stored
+in. For consistency, please use this location when generating your
+database instead of the directory specified in the help documentation:
+
+ %%DBDIR%%
+
+IRCD Server Config:
+-------------------
+On the ircd ratbox-services will connect to, add a connect{} block.
+This should have services's server name (name in serverinfo{} in
+ratbox-services.conf) and no autoconnect. 'send_password' and
+'accept_password' should be equal and 'flags=encrypted' should
+not be used.
+
+If you use the ratbox-services compatibility code in ircd-ratbox,
+all servers need service { name = "<ratbox-services's server name>"; };
Once you have added ratbox_services_enable="YES" to /etc/rc.conf, the
server can be started by running:
- %%PREFIX%%/etc/rc.d/ratbox-services.sh start
+ %%PREFIX%%/etc/rc.d/ratbox-services start
+
+Important UPGRADE Note:
+-----------------------
+Upgrading from the 1.0.x series to this current release will likely
+break everything. If upgrading between release versions you should
+read the UPDATING information:
+
+ %%DOCSDIR%%/UPDATING
+
+Common database update tools and scripts referenced in ratbox-services
+documentation can be found in:
+ %%DOCSDIR%%/
+
------------------------------------------------------------------------