aboutsummaryrefslogtreecommitdiff
path: root/irc/talksoup/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-09-10 09:11:49 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-09-10 09:11:49 +0000
commit1bf4e4042ef6d529888a8d4a0f55cac96009ed3a (patch)
tree1bffe631cdf9fc512b7caa1d3fc09f1f30ea8e0f /irc/talksoup/Makefile
parent3b75d510b1de2e1cab99334da2d67aca2ea3e1fc (diff)
downloadports-1bf4e4042ef6d529888a8d4a0f55cac96009ed3a.tar.gz
ports-1bf4e4042ef6d529888a8d4a0f55cac96009ed3a.zip
Notes
Diffstat (limited to 'irc/talksoup/Makefile')
-rw-r--r--irc/talksoup/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/irc/talksoup/Makefile b/irc/talksoup/Makefile
new file mode 100644
index 000000000000..0d921254138a
--- /dev/null
+++ b/irc/talksoup/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: talksoup
+# Date created: 8 Sep 2006
+# Whom: gurkan@linuks.mine.nu
+#
+# $FreeBSD$
+#
+
+PORTNAME= talksoup
+PORTVERSION= 1.0
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= TalkSoup-${PORTVERSION}alpha
+
+MAINTAINER= gurkan@linuks.mine.nu
+COMMENT= IRC client for GNUstep
+
+BUILD_DEPENDS+= ${LOCALLIBDIR}/libnetclasses.so:${PORTSDIR}/${NETCLASSES_PORT}
+RUN_DEPENDS+= ${LOCALLIBDIR}/libnetclasses.so:${PORTSDIR}/${NETCLASSES_PORT}
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+# broken:
+#USE_LDCONFIG= yes
+INSTALLS_SHLIB= yes
+MAKEFILE= GNUmakefile
+NETCLASSES_PORT?= net/netclasses
+PLIST_SUB+= APPVERSION=0.990
+
+.include <bsd.port.mk>