aboutsummaryrefslogtreecommitdiff
path: root/irc/undernet-ircu/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-05-01 00:31:56 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-05-01 00:31:56 +0000
commite9bd50a8448b4222adcc6c0e4a33c31562ceae91 (patch)
tree7ef56e122cc020c2fd1a5c46c8c475b164b3e07f /irc/undernet-ircu/Makefile
parentdb6a4ebb5da25d83baf36a24e10ece1d0a61b4e7 (diff)
downloadports-e9bd50a8448b4222adcc6c0e4a33c31562ceae91.tar.gz
ports-e9bd50a8448b4222adcc6c0e4a33c31562ceae91.zip
Notes
Diffstat (limited to 'irc/undernet-ircu/Makefile')
-rw-r--r--irc/undernet-ircu/Makefile106
1 files changed, 50 insertions, 56 deletions
diff --git a/irc/undernet-ircu/Makefile b/irc/undernet-ircu/Makefile
index 73d4e02baf1d..3e88a6eb839d 100644
--- a/irc/undernet-ircu/Makefile
+++ b/irc/undernet-ircu/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= undernet-ircu
-PORTVERSION= 2.10.11.06
+PORTVERSION= 2.10.12.12
CATEGORIES= irc net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= undernet-ircu
@@ -17,98 +17,92 @@ COMMENT= Undernet IRCU irc daemon
CONFLICTS= ircd-hybrid*
GNU_CONFIGURE= yes
+USE_RC_SUBR= undernet.sh
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-dpath=${PREFIX}/etc --with-symlink=no
+CONFIGURE_ARGS= --with-dpath=${PREFIX}/etc/ --with-symlink=no
-PLIST_FILES= bin/chkconf bin/ircd etc/ircd.conf.example
+PLIST_FILES= bin/ircd bin/umkpasswd bin/convert-conf
+.if exists(${PREFIX}/etc/ircd.conf.example})
+PLIST_FILES+= etc/ircd.conf.example
+.endif
MAN8= ircd.8
-.include <bsd.port.pre.mk>
+OPTIONS= IPV6 "Disable IPv6 support (default is autodetect)" off \
+ POLL "Force poll to be used even if not a sys call" off \
+ DEBUG "Turn on debugging mode" off \
+ ASSERTS "Disable assertion checking" off \
+ PROFILE "Enable profiling support" off \
+ PEDANTIC "Enable pedantic warnings" off \
+ WARNINGS "Enable warnings (add -Wall to CFLAGS)" off \
+ INLINES "Disable inlining for a few critical functions" off \
+ DEVPOLL "Disable the /dev/poll-based engine" off \
+ KQUEUE "Disable the kqueue-based engine" off \
+ EPOLL "Disable the epoll-based engine" off \
+ LEAKDETECT "Turn on the leak detector (reqs patched boehm)" off
-pre-everything::
+.include <bsd.port.pre.mk>
- @${ECHO} ""
- @${ECHO} "Here is a list of possible configuration options:"
- @${ECHO} "(Note that options already selected will not be shown)"
- @${ECHO} ""
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --without-ipv6
+.endif
-.if defined(ENABLE_POLL)
+.if defined(WITH_POLL)
CONFIGURE_ARGS+= --enable-poll
-.else
- @${ECHO} " ENABLE_POLL: Force poll to be used regardless of whether or not"
- @${ECHO} " it is a system call."
.endif
-.if defined(ENABLE_DEBUG)
+.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
-.else
- @${ECHO} " ENABLE_DEBUG: Turn on debugging mode."
.endif
-.if defined(DISABLE_ASSERTS)
+.if defined(WITH_ASSERTS)
CONFIGURE_ARGS+= --disable-asserts
-.else
- @${ECHO} " DISABLE_ASSERTS: Disable assertion checking."
-.endif
-
-.if defined(DISABLE_SYMBOLS)
-CONFIGURE_ARGS+= --disable-symbols
-.else
- @${ECHO} " DISABLE_SYMBOLS: Disable debugging symbols (remove -g from CFLAGS)."
.endif
-.if defined(ENABLE_PROFILE)
+.if defined(WITH_PROFILE)
CONFIGURE_ARGS+= --enable-profile
-.else
- @${ECHO} " ENABLE_PROFILE: Enable profiling support (add -pg to CFLAGS)."
.endif
-.if defined(ENABLE_PEDANTIC)
+.if defined(WITH_PEDANTIC)
CONFIGURE_ARGS+= --enable-pedantic
-.else
- @${ECHO} " ENABLE_PEDANTIC: Enable pedantic warnings (add -pedantic to CFLAGS)."
.endif
-.if defined(ENABLE_WARNINGS)
+.if defined(WITH_WARNINGS)
CONFIGURE_ARGS+= --enable-warnings
-.else
- @${ECHO} " ENABLE_WARNINGS: Enable warnings (add -Wall to CFLAGS)."
.endif
-.if defined(DISABLE_INLINES)
+.if defined(WITH_INLINES)
CONFIGURE_ARGS+= --disable-inlines
-.else
- @${ECHO} " DISABLE_INLINES: Disable inlining for a few critical functions."
.endif
-.if defined(DISABLE_DEVPOLL)
+.if defined(WITH_DEVPOLL)
CONFIGURE_ARGS+= --disable-devpoll
-.else
- @${ECHO} " DISABLE_DEVPOLL: Disable the /dev/poll-based engine."
.endif
-.if defined(DISABLE_KQUEUE)
+.if defined(WITH_KQUEUE)
CONFIGURE_ARGS+= --disable-kqueue
-.else
- @${ECHO} " DISABLE_KQUEUE: Disable the kqueue-based engine."
.endif
-.if defined(DISABLE_EPOLL)
+.if defined(WITH_EPOLL)
CONFIGURE_ARGS+= --disable-epoll
-.else
- @${ECHO} " DISABLE_EPOLL: Disable the epoll-based engine."
.endif
- @${ECHO} ""
- @${ECHO} "To select any of these options CTRL+C now! Then, for example: "
- @${ECHO} " 'make ENABLE_OPTION=1'."
- @${ECHO} ""
+
+.if defined(WITH_LEAKDETECT)
+CONFIGURE_ARGS+= --with-leak-detect
+.endif
+
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
post-install:
- @ ${ECHO} ""
- @ ${ECHO} " PLEASE NOTE:"
- @ ${ECHO} " When you 'make deinstall', a binary file will remain in ${PREFIX}/bin"
- @ ${ECHO} " with the name ircd.YEAR-MONTH-DAY-HOUR-MINUTE (of install). This file"
- @ ${ECHO} " must be removed manually."
- @ ${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " To run undernet ircu you must add 'undernet_enable=\"YES\" to"
+ @${ECHO_MSG} " \"/etc/rc.conf\" . It can then be started with"
+ @${ECHO_MSG} " \"${PREFIX}/etc/rc.d/undernet start\""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " You must also copy \"${PREFIX}/etc/ircd.conf.example\" to"
+ @${ECHO_MSG} " \"${PREFIX}/etc/ircd.conf\" and modify its settings according to"
+ @${ECHO_MSG} " your needs. See documentation at http://coder-com.undernet.org."
+ @${ECHO_MSG} ""
.include <bsd.port.post.mk>