aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat/Makefile
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2006-01-30 15:17:07 +0000
committerAndrej Zverev <az@FreeBSD.org>2006-01-30 15:17:07 +0000
commit43961f5877af62e842f5be6c9de0abed7d209869 (patch)
treea3375f21e05ad453d280780c56076c618149e356 /irc/weechat/Makefile
parent0362e1048fdaa17e0bc28ec9ef31ce868615b9e0 (diff)
Notes
Diffstat (limited to 'irc/weechat/Makefile')
-rw-r--r--irc/weechat/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 5ffaf44ef72a..5cec5f39ee0e 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= weechat
-PORTVERSION= 0.1.6
-PORTREVISION= 1
+PORTVERSION= 0.1.7
CATEGORIES= irc
MASTER_SITES= http://flashcode.free.fr/flashtux/weechat/ \
http://weechat.flashtux.org/download/
@@ -23,7 +22,6 @@ CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= weechat-curses.1
-INFO= weechat_doc_en weechat_doc_es weechat_doc_fr weechat_doc_pt
PLIST_FILES= bin/weechat-curses
PLIST_DIRS= lib/weechat/plugins lib/weechat
@@ -32,7 +30,8 @@ PLIST_DIRS= lib/weechat/plugins lib/weechat
PLIST_FILES+= %%NLS%%share/locale/${lang}/LC_MESSAGES/weechat.mo
.endfor
-.include <bsd.port.pre.mk>
+PLIST_FILES+= %%DOCSDIR%%/html/en/weechat-doc.css %%DOCSDIR%%/html/fr/weechat-doc.css
+PLIST_DIRS+= %%DOCSDIR%%/html/en %%DOCSDIR%%/html/fr %%DOCSDIR%%/html %%DOCSDIR%%
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -45,7 +44,7 @@ PLIST_SUB+= NLS="@comment "
.if defined(WITH_PERL)
.if ${PERL_LEVEL} < 500600
-IGNORE= This port requires perl 5.6.0 or later, Install lang/perl5 then try again
+IGNORE= this port requires perl 5.6.0 or later, Install lang/perl5 then try again
.else
CONFIGURE_ARGS+=--enable-perl
USE_PERL5= yes
@@ -64,4 +63,4 @@ PLIST_FILES+= lib/weechat/plugins/libpython.a lib/weechat/plugins/libpython.la \
pre-configure:
@${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>