aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /irc/weechat
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
converters/libiconv:
- Remove const qualifier from iconv(3) to match POSIX: http://pubs.opengroup.org/onlinepubs/9699919799/functions/iconv.html - Patch iconv.h to expose more GNU extensions when LIBICONV_PLUG is defined because the base system iconv supports these extensions too. Add/remove patches to/from ports to call iconv with non-const arguments. This breaks some ports on FreeBSD 10 because base system iconv.h still has the const qualifier. Fix this by letting USES=iconv add a build dependency on converters/libiconv so ports can use its iconv.h (with LIBICONV_PLUG defined) instead of the base system iconv.h. This exposed some ports that link with libiconv when it is available instead of using libc iconv. In these cases one of the following changes has been made: - patch configure scripts to test for libc iconv first - add ac_cv_lib_iconv_libiconv=no or similar to CONFIGURE_ARGS to disable some configure tests - converters/wkhtmltopdf: this includes Qt4 so add a patch from devel/qt4 - lang/gcc5-aux: respect CFLAGS and friends during configure such that LIBICONV_PLUG is defined in the iconv test, also switch to external gettext - mail/gnarwl: replace patches with CPPFLAGS/LIBS - multimedia/ffmpeg2theora: remove iconv test from SConstruct and use ICONV_LIB in port Makefile instead, also fix a bug in subtitles.c - net-im/licq: finish conversion to cmake - net-mgmt/bandwidthd, net-mgmt/icinga, net-mgmt/nagios, net-mgmt/nagios4: don't need iconv - textproc/p5-XML-TinyXML: finish conversion to USES=perl5 Other changes: - databases/qdbm and slaves: respect CFLAGS and friends, also enable bzip2 and lzo support - games/ldmud: respect CFLAGS and friends - graphics/inventor: replace some patches with MAKE_ARGS/MAKE_ENV to respect CFLAGS and friends, also remove FreeBSD/alpha patch and add missing xorg dependencies PR: 199099 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=384038
Diffstat (limited to 'irc/weechat')
-rw-r--r--irc/weechat/Makefile1
-rw-r--r--irc/weechat/files/patch-cmake-FindIconv.cmake63
2 files changed, 64 insertions, 0 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index b27ee09d4f18..0371cc02509b 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -3,6 +3,7 @@
PORTNAME= weechat
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/ \
http://perturb.me.uk/distfiles/weechat/:mandocs \
diff --git a/irc/weechat/files/patch-cmake-FindIconv.cmake b/irc/weechat/files/patch-cmake-FindIconv.cmake
new file mode 100644
index 000000000000..ae48f766b322
--- /dev/null
+++ b/irc/weechat/files/patch-cmake-FindIconv.cmake
@@ -0,0 +1,63 @@
+--- cmake/FindIconv.cmake.orig 2015-01-25 07:40:23 UTC
++++ cmake/FindIconv.cmake
+@@ -33,39 +33,24 @@ if(ICONV_FOUND)
+ set(ICONV_FIND_QUIETLY TRUE)
+ endif()
+
+-include(CheckLibraryExists)
+ include(CheckFunctionExists)
+
+-find_path(ICONV_INCLUDE_PATH
+- NAMES iconv.h
+- PATHS /usr/include /usr/local/include /usr/pkg/include
+-)
+-
+-find_library(ICONV_LIBRARY
+- NAMES iconv
+- PATHS /lib /usr/lib /usr/local/lib /usr/pkg/lib
+-)
++find_path(ICONV_INCLUDE_PATH iconv.h)
+
+ if(ICONV_INCLUDE_PATH)
+- if(ICONV_LIBRARY)
+- string(REGEX REPLACE "/[^/]*$" "" ICONV_LIB_PATH "${ICONV_LIBRARY}")
+- check_library_exists(iconv libiconv_open ${ICONV_LIB_PATH} LIBICONV_OPEN_FOUND)
+- check_library_exists(iconv iconv_open ${ICONV_LIB_PATH} ICONV_OPEN_FOUND)
+- if(LIBICONV_OPEN_FOUND OR ICONV_OPEN_FOUND)
+- set(ICONV_FOUND TRUE)
+- endif()
+- else()
+- check_function_exists(iconv_open ICONV_FOUND)
+- endif()
++ check_function_exists(iconv ICONV_FOUND)
++ if(NOT ICONV_FOUND)
++ find_library(ICONV_LIBRARY NAMES iconv libiconv libiconv-2)
++ if(ICONV_LIBRARY)
++ set(ICONV_FOUND TRUE)
++ endif(ICONV_LIBRARY)
++ endif(NOT ICONV_FOUND)
+ endif()
+
+ include(CheckCSourceCompiles)
+
+-if(ICONV_LIBRARY)
+- set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARY})
+- set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_PATH})
+-endif()
+-
++set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARY})
++set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_PATH})
+ set(CMAKE_REQUIRED_FLAGS -Werror)
+ check_c_source_compiles("
+ #include <iconv.h>
+@@ -80,6 +65,10 @@ check_c_source_compiles("
+ }
+ " ICONV_2ARG_IS_CONST)
+
++set(CMAKE_REQUIRED_LIBRARIES)
++set(CMAKE_REQUIRED_INCLUDES)
++set(CMAKE_REQUIRED_FLAGS)
++
+ mark_as_advanced(
+ ICONV_INCLUDE_PATH
+ ICONV_LIBRARY