aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2005-11-16 16:08:16 +0000
committerAndrej Zverev <az@FreeBSD.org>2005-11-16 16:08:16 +0000
commitef26a74dd1c2e0e3adf6941b1f1e5235bc49312e (patch)
tree35f85343527a1fca032789d628a432e409a2d413 /irc/weechat
parent311c5b11e76199d37b1273a720cb82ceb85ae402 (diff)
downloadports-ef26a74dd1c2e0e3adf6941b1f1e5235bc49312e.tar.gz
ports-ef26a74dd1c2e0e3adf6941b1f1e5235bc49312e.zip
Notes
Diffstat (limited to 'irc/weechat')
-rw-r--r--irc/weechat/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 8d6cc6ee03b4..323dd3b72a62 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= weechat
PORTVERSION= 0.1.6
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://flashcode.free.fr/flashtux/weechat/ \
http://weechat.flashtux.org/download/
@@ -31,6 +32,8 @@ PLIST_DIRS= lib/weechat/plugins lib/weechat
PLIST_FILES+= %%NLS%%share/locale/${lang}/LC_MESSAGES/weechat.mo
.endfor
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -39,13 +42,16 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-#Tempory disable due problems with perl < 5.6 (4.x)
-#.if defined(WITH_PERL)
-#CONFIGURE_ARGS+=--enable-perl
-#USE_PERL= yes
-#PLIST_FILES+= lib/weechat/plugins/libperl.a lib/weechat/plugins/libperl.la \
-# lib/weechat/plugins/libperl.so lib/weechat/plugins/libperl.so.0
-#.endif
+.if defined(WITH_PERL)
+.if ${PERL_LEVEL} < 500600
+IGNORE= This port requires perl 5.6.0 or later, Install lang/perl5 then try again
+.else
+CONFIGURE_ARGS+=--enable-perl
+USE_PERL5= yes
+PLIST_FILES+= lib/weechat/plugins/libperl.a lib/weechat/plugins/libperl.la \
+ lib/weechat/plugins/libperl.so lib/weechat/plugins/libperl.so.0
+.endif
+.endif
.if defined(WITH_PYTHON)
CONFIGURE_ARGS+=--enable-python
@@ -57,4 +63,4 @@ PLIST_FILES+= lib/weechat/plugins/libpython.a lib/weechat/plugins/libpython.la \
pre-configure:
@${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>