aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-27 01:04:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-27 01:04:15 +0000
commit323547c8f879fdfd655e5aedd5d6752b1b9038d9 (patch)
tree3ad4224aac23af0146b8f60f43afcc154f70d7d4 /irc/weechat
parentb236573620a314ed7ee5f870eb06fc1cf4bba012 (diff)
downloadports-323547c8f879fdfd655e5aedd5d6752b1b9038d9.tar.gz
ports-323547c8f879fdfd655e5aedd5d6752b1b9038d9.zip
Notes
Diffstat (limited to 'irc/weechat')
-rw-r--r--irc/weechat/Makefile73
-rw-r--r--irc/weechat/distinfo6
-rw-r--r--irc/weechat/files/patch-cmake-FindIconv_cmake12
-rw-r--r--irc/weechat/files/patch-cmake-FindRuby_cmake26
-rw-r--r--irc/weechat/files/patch-configure.in29
-rw-r--r--irc/weechat/files/patch-src-plugins-scripts-script_c168
-rw-r--r--irc/weechat/pkg-descr5
-rw-r--r--irc/weechat/pkg-plist73
8 files changed, 106 insertions, 286 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index b9ea52d9fcd5..a1b214217d2b 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -1,35 +1,30 @@
-# New ports collection makefile for: weechat
-# Date created: 2003-03-07
-# Whom: clement
+# New ports collection makefile for: weechat
+# Date created: 2003-03-07
+# Whom: clement
#
# $FreeBSD$
#
PORTNAME= weechat
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.3.1
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/
MAINTAINER= miwi@FreeBSD.org
COMMENT= A lightweight and user friendly ncurse based IRC client
-USE_BZIP2= yes
USE_ICONV= yes
-USE_AUTOTOOLS= autoconf:262
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-lua
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include"\
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-WANT_GNOME= yes
-USE_GNOME= gnomehack
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
OPTIONS= RUBY "Ruby scripting support." Off \
PYTHON "Python scripting support." Off \
PERL "Perl scripting support." Off \
TCL "TCL scripting support." Off \
+ LUA "Lua scripting support." Off \
CHARSET "Charset support." On \
DEBUG "Debugging." Off \
ASPELL "Spell checking." Off \
@@ -40,95 +35,99 @@ OPTIONS= RUBY "Ruby scripting support." Off \
.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --with-debug=2
-.else
-CONFIGURE_ARGS+= --with-debug=0
+CMAKE_BUILD_TYPE= Debug
.endif
.if defined(WITHOUT_CHARSET)
-CONFIGURE_ARGS+= --disable-charset
+CMAKE_ARGS+= -DDISABLE_CHARSET=yes
PLIST_SUB+= CHARSET="@comment "
.else
-CONFIGURE_ARGS+= --enable-charset
PLIST_SUB+= CHARSET=""
.endif
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+CMAKE_ARGS+= -DDISABLE_NLS=yes
PLIST_SUB+= NLS="@comment "
.else
-CONFIGURE_ARGS+= --enable-nls
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
.if defined(WITH_ASPELL)
-CONFIGURE_ARGS+= --enable-aspell
BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
PLIST_SUB+= ASPELL=""
.else
-CONFIGURE_ARGS+= --disable-aspell
+CMAKE_ARGS+= -DDISABLE_ASPELL=yes
PLIST_SUB+= ASPELL="@comment "
.endif
.if defined(WITH_PYTHON)
-CONFIGURE_ARGS+= --enable-python
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""
.else
-CONFIGURE_ARGS+= --disable-python
+CMAKE_ARGS+= -DDISABLE_PYTHON=yes
PLIST_SUB+= PYTHON="@comment "
.endif
.if defined(WITH_RUBY)
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
-CONFIGURE_ARGS+= --enable-ruby
USE_RUBY= yes
PLIST_SUB+= RUBY=""
.else
-CONFIGURE_ARGS+= --disable-ruby
+CMAKE_ARGS+= -DDISABLE_RUBY=yes
PLIST_SUB+= RUBY="@comment "
.endif
.if defined(WITH_GNUTLS)
-CONFIGURE_ARGS+= --enable-gnutls
LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
.else
-CONFIGURE_ARGS+= --disable-gnutls
+CMAKE_ARGS+= -DDISABLE_GNUTLS=yes
.endif
.if defined(WITH_PERL)
-CONFIGURE_ARGS+= --enable-perl
USE_PERL5= yes
PLIST_SUB+= PERL=""
.else
-CONFIGURE_ARGS+= --disable-perl
+CMAKE_ARGS+= -DDISABLE_PERL=yes
PLIST_SUB+= PERL="@comment "
.endif
.if defined(WITH_TCL)
USE_TCL= 83+
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
-CONFIGURE_ARGS+= --enable-tcl
-CONFIGURE_ARGS+= --with-tclconfig=${LOCALBASE}/lib/tcl${TCL_VER}
PLIST_SUB+= TCL=""
.else
-CONFIGURE_ARGS+= --disable-tcl
+CMAKE_ARGS+= -DDISABLE_TCL=yes
PLIST_SUB+= TCL="@comment "
.endif
+.if defined(WITH_LUA)
+USE_LUA= 5.0+
+PLIST_SUB+= LUA=""
+.else
+CMAKE_ARGS+= -DDISABLE_LUA=yes
+PLIST_SUB+= LUA="@comment "
+.endif
+
.if defined(WITH_DOCUMENTATION)
-CONFIGURE_ARGS+= --enable-doc
BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
BUILD_DEPENDS+= source-highlight:${PORTSDIR}/textproc/source-highlight
PLIST_SUB+= DOCUMENTATION=""
-MAN1= weechat-curses.1
.else
-CONFIGURE_ARGS+= --disable-doc
+CMAKE_ARGS+= -DDISABLE_DOC=yes
PLIST_SUB+= DOCUMENTATION="@comment "
.endif
+MAN1= weechat-curses.1
+
+post-extract:
+ @${CP} ${WRKSRC}/doc/weechat-curses.1 ${WRKSRC}/
+
post-patch:
- @${REINPLACE_CMD} -e 's|2.61|2.62|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|$${LIBDIR}/../pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|INSTALL|#INSTALL|' ${WRKSRC}/doc/CMakeLists.txt
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/weechat-curses.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/irc/weechat/distinfo b/irc/weechat/distinfo
index 87fbc6e6152c..db7320b92588 100644
--- a/irc/weechat/distinfo
+++ b/irc/weechat/distinfo
@@ -1,3 +1,3 @@
-MD5 (weechat-0.3.0.tar.bz2) = c31cfc229e964ff9257cc9c7f9e6c9bc
-SHA256 (weechat-0.3.0.tar.bz2) = 0064c647bd057a9e347deeb1a1ee397d23c0b52f42baf218c6313508bb3943d4
-SIZE (weechat-0.3.0.tar.bz2) = 1333413
+MD5 (weechat-0.3.1.tar.gz) = 748c6b5ec600cdb28224e90b6d8efd3b
+SHA256 (weechat-0.3.1.tar.gz) = 6529b6760912c66723a24382566fe250678953ab95211a00cb33fd4b7ebb10e9
+SIZE (weechat-0.3.1.tar.gz) = 2262254
diff --git a/irc/weechat/files/patch-cmake-FindIconv_cmake b/irc/weechat/files/patch-cmake-FindIconv_cmake
new file mode 100644
index 000000000000..726c9f026b8b
--- /dev/null
+++ b/irc/weechat/files/patch-cmake-FindIconv_cmake
@@ -0,0 +1,12 @@
+--- cmake/FindIconv.cmake.orig 2010-01-20 17:31:05.000000000 +0000
++++ cmake/FindIconv.cmake 2010-01-20 17:31:30.000000000 +0000
+@@ -30,6 +30,9 @@
+ set(ICONV_FIND_QUIETLY TRUE)
+ ENDIF(ICONV_FOUND)
+
++INCLUDE(CheckLibraryExists)
++INCLUDE(CheckFunctionExists)
++
+ FIND_PATH(ICONV_INCLUDE_PATH
+ NAMES iconv.h
+ PATHS /usr/include /usr/local/include /usr/pkg/include
diff --git a/irc/weechat/files/patch-cmake-FindRuby_cmake b/irc/weechat/files/patch-cmake-FindRuby_cmake
new file mode 100644
index 000000000000..fa8fba70ed7d
--- /dev/null
+++ b/irc/weechat/files/patch-cmake-FindRuby_cmake
@@ -0,0 +1,26 @@
+--- cmake/FindRuby.cmake.orig 2010-01-05 21:12:22.000000000 +0000
++++ cmake/FindRuby.cmake 2010-01-05 21:14:40.000000000 +0000
+@@ -35,7 +35,7 @@
+
+ IF(RUBY_EXECUTABLE)
+ EXECUTE_PROCESS(
+- COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['rubyhdrdir'] || Config::CONFIG['archdir']"
++ COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['topdir']"
+ OUTPUT_VARIABLE RUBY_ARCH_DIR
+ )
+
+@@ -45,12 +45,12 @@
+ )
+
+ EXECUTE_PROCESS(
+- COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['libdir']"
++ COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::TOPDIR + '/lib'"
+ OUTPUT_VARIABLE RUBY_POSSIBLE_LIB_PATH
+ )
+
+ EXECUTE_PROCESS(
+- COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['rubylibdir']"
++ COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::TOPDIR + '/lib/ruby/' + Config::CONFIG['ruby_version']"
+ OUTPUT_VARIABLE RUBY_RUBY_LIB_PATH
+ )
+
diff --git a/irc/weechat/files/patch-configure.in b/irc/weechat/files/patch-configure.in
deleted file mode 100644
index 5510d034332d..000000000000
--- a/irc/weechat/files/patch-configure.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.in.orig 2009-09-06 08:01:26.000000000 +0000
-+++ configure.in 2009-11-12 14:46:30.000000000 +0000
-@@ -137,6 +137,7 @@
- AC_ARG_WITH(lua-inc, [ --with-lua-inc=DIR, lua include files are in DIR (default=autodetect)],lua_inc=$withval,lua_inc='')
- AC_ARG_WITH(lua-lib, [ --with-lua-lib=DIR, lua library files are in DIR (default=autodetect)],lua_lib=$withval,lua_lib='')
- AC_ARG_WITH(lua-suffix, [ --with-lua-suffix=ARG lua is suffixed with ARG (default=autodetect)],lua_suffix=$withval,lua_suffix='')
-+AC_ARG_WITH(tclconfig, [ --with-tclconfig=DIR directory containing tcl configuration (tclConfig.sh)],tclconfig=$withval,tclconfig='')
- AC_ARG_ENABLE(doc, [ --disable-doc turn off documentation (default=built)],enable_doc=$enableval,enable_doc=yes)
- AC_ARG_WITH(debug, [ --with-debug debugging: 0=no debug, 1=debug compilation (default=1)],debug=$withval,debug=1)
-
-@@ -682,6 +683,9 @@
- AC_MSG_CHECKING(for tclConfig.sh)
- tcl_found="no"
- tcl_dirs="/lib /usr/lib /usr/tcl/lib /usr/lib/tcl8.5 /usr/lib/tcl8.4 /usr/lib/tcl8.3 /usr/local/lib /usr/local/tcl-8.5/lib /usr/local/tcl-8.4/lib /usr/local/tcl-8.3/lib /usr/local/tcl/lib /opt/lib"
-+ if test "x$tclconfig" != "x" ; then
-+ tcl_dirs="$tclconfig $tcl_dirs"
-+ fi
- for tcl_dir in $tcl_dirs ; do
- if test -f ${tcl_dir}/tclConfig.sh ; then
- . ${tcl_dir}/tclConfig.sh
-@@ -870,7 +874,7 @@
- AC_MSG_RESULT(no)
- fi
-
--CFLAGS=`echo $CFLAGS | sed 's/ -g //g'`
-+CFLAGS=`echo $CFLAGS | sed 's/ -g / /g'`
- CFLAGS=`echo $CFLAGS | sed 's/^-g //g'`
- CFLAGS=`echo $CFLAGS | sed 's/ -g$//g'`
- CFLAGS=`echo $CFLAGS | sed 's/^-g$//g'`
diff --git a/irc/weechat/files/patch-src-plugins-scripts-script_c b/irc/weechat/files/patch-src-plugins-scripts-script_c
deleted file mode 100644
index 1c935827582e..000000000000
--- a/irc/weechat/files/patch-src-plugins-scripts-script_c
+++ /dev/null
@@ -1,168 +0,0 @@
---- src/plugins/scripts/script.c.orig 2009-09-04 08:25:47.000000000 +0000
-+++ src/plugins/scripts/script.c 2009-11-16 12:08:54.000000000 +0000
-@@ -439,24 +439,15 @@
- script_search_by_full_name (struct t_plugin_script *scripts,
- const char *full_name)
- {
-- char *full_name_copy, *base_name;
-+ char *base_name;
- struct t_plugin_script *ptr_script;
-
-- full_name_copy = strdup (full_name);
--
-- if (full_name_copy)
-+ for (ptr_script = scripts; ptr_script;
-+ ptr_script = ptr_script->next_script)
- {
-- for (ptr_script = scripts; ptr_script;
-- ptr_script = ptr_script->next_script)
-- {
-- base_name = basename (ptr_script->filename);
-- if (strcmp (base_name, full_name) == 0)
-- {
-- free (full_name_copy);
-- return ptr_script;
-- }
-- }
-- free (full_name_copy);
-+ base_name = basename (ptr_script->filename);
-+ if (strcmp (base_name, full_name) == 0)
-+ return ptr_script;
- }
-
- /* script not found */
-@@ -915,7 +906,8 @@
- int (*script_load)(const char *filename),
- char **list)
- {
-- char **argv, *name, *base_name, *new_path, *autoload_path, *symlink_path;
-+ char **argv, *name, *ptr_base_name, *base_name, *new_path, *autoload_path;
-+ char *symlink_path;
- const char *dir_home, *dir_separator;
- int argc, i, length;
- struct t_plugin_script *ptr_script;
-@@ -930,67 +922,71 @@
- name = strdup (argv[i]);
- if (name)
- {
-- base_name = basename (name);
--
-- /* unload script, if script is loaded */
-- ptr_script = script_search_by_full_name (scripts, base_name);
-- if (ptr_script)
-- (*script_unload) (ptr_script);
-+ ptr_base_name = basename (name);
-+ base_name = strdup (ptr_base_name);
-+ if (base_name)
-+ {
-+ /* unload script, if script is loaded */
-+ ptr_script = script_search_by_full_name (scripts, base_name);
-+ if (ptr_script)
-+ (*script_unload) (ptr_script);
-
-- /* remove script file(s) */
-- script_remove_file (weechat_plugin, base_name, 0);
-+ /* remove script file(s) */
-+ script_remove_file (weechat_plugin, base_name, 0);
-
-- /* move file from install dir to language dir */
-- dir_home = weechat_info_get ("weechat_dir", "");
-- length = strlen (dir_home) + strlen (weechat_plugin->name) +
-- strlen (base_name) + 16;
-- new_path = malloc (length);
-- if (new_path)
-- {
-- snprintf (new_path, length, "%s/%s/%s",
-- dir_home, weechat_plugin->name, base_name);
-- if (rename (name, new_path) == 0)
-+ /* move file from install dir to language dir */
-+ dir_home = weechat_info_get ("weechat_dir", "");
-+ length = strlen (dir_home) + strlen (weechat_plugin->name) +
-+ strlen (base_name) + 16;
-+ new_path = malloc (length);
-+ if (new_path)
- {
-- /* make link in autoload dir */
-- length = strlen (dir_home) +
-- strlen (weechat_plugin->name) + 8 +
-- strlen (base_name) + 16;
-- autoload_path = malloc (length);
-- if (autoload_path)
-+ snprintf (new_path, length, "%s/%s/%s",
-+ dir_home, weechat_plugin->name, base_name);
-+ if (rename (name, new_path) == 0)
- {
-- snprintf (autoload_path, length,
-- "%s/%s/autoload/%s",
-- dir_home, weechat_plugin->name,
-- base_name);
-- dir_separator = weechat_info_get ("dir_separator", "");
-- length = 2 + strlen (dir_separator) +
-- strlen (base_name) + 1;
-- symlink_path = malloc (length);
-- if (symlink_path)
-+ /* make link in autoload dir */
-+ length = strlen (dir_home) +
-+ strlen (weechat_plugin->name) + 8 +
-+ strlen (base_name) + 16;
-+ autoload_path = malloc (length);
-+ if (autoload_path)
- {
-- snprintf (symlink_path, length, "..%s%s",
-- dir_separator, base_name);
-- symlink (symlink_path, autoload_path);
-- free (symlink_path);
-- }
-+ snprintf (autoload_path, length,
-+ "%s/%s/autoload/%s",
-+ dir_home, weechat_plugin->name,
-+ base_name);
-+ dir_separator = weechat_info_get ("dir_separator", "");
-+ length = 2 + strlen (dir_separator) +
-+ strlen (base_name) + 1;
-+ symlink_path = malloc (length);
-+ if (symlink_path)
-+ {
-+ snprintf (symlink_path, length, "..%s%s",
-+ dir_separator, base_name);
-+ symlink (symlink_path, autoload_path);
-+ free (symlink_path);
-+ }
- free (autoload_path);
-- }
-+ }
-
-- /* load script */
-- (*script_load) (new_path);
-- }
-- else
-- {
-- weechat_printf (NULL,
-- _("%s%s: failed to move script %s "
-- "to %s (%s)"),
-- weechat_prefix ("error"),
-- weechat_plugin->name,
-- name,
-- new_path,
-- strerror (errno));
-+ /* load script */
-+ (*script_load) (new_path);
-+ }
-+ else
-+ {
-+ weechat_printf (NULL,
-+ _("%s%s: failed to move script %s "
-+ "to %s (%s)"),
-+ weechat_prefix ("error"),
-+ weechat_plugin->name,
-+ name,
-+ new_path,
-+ strerror (errno));
-+ }
-+ free (new_path);
- }
-- free (new_path);
-+ free (base_name);
- }
- free (name);
- }
diff --git a/irc/weechat/pkg-descr b/irc/weechat/pkg-descr
index fdfc8abd667b..bbdaa12bc428 100644
--- a/irc/weechat/pkg-descr
+++ b/irc/weechat/pkg-descr
@@ -3,4 +3,7 @@ client. Everything can be done with a keyboard, and it is customizable
and extensible with scripts. For the moment, only ncurse GUI is
supported by this port.
-WWW: http://weechat.org
+Note: this is not the official release version, this is a git snapshot, which
+may in some cases be unstable.
+
+WWW: http://git.savannah.gnu.org/gitweb/?p=weechat.git
diff --git a/irc/weechat/pkg-plist b/irc/weechat/pkg-plist
index 6fbe2879634f..1b4a45a2c08f 100644
--- a/irc/weechat/pkg-plist
+++ b/irc/weechat/pkg-plist
@@ -1,73 +1,50 @@
bin/weechat-curses
include/weechat/weechat-plugin.h
-lib/weechat/plugins/alias.a
-lib/weechat/plugins/alias.la
lib/weechat/plugins/alias.so
-lib/weechat/plugins/alias.so.0
-%%ASPELL%%lib/weechat/plugins/aspell.a
-%%ASPELL%%lib/weechat/plugins/aspell.la
-%%ASPELL%%lib/weechat/plugins/aspell.so
-%%ASPELL%%lib/weechat/plugins/aspell.so.0
-%%CHARSET%%lib/weechat/plugins/charset.a
-%%CHARSET%%lib/weechat/plugins/charset.la
-%%CHARSET%%lib/weechat/plugins/charset.so
-%%CHARSET%%lib/weechat/plugins/charset.so.0
-lib/weechat/plugins/fifo.a
-lib/weechat/plugins/fifo.la
lib/weechat/plugins/fifo.so
-lib/weechat/plugins/fifo.so.0
-lib/weechat/plugins/irc.a
-lib/weechat/plugins/irc.la
lib/weechat/plugins/irc.so
-lib/weechat/plugins/irc.so.0
-lib/weechat/plugins/logger.a
-lib/weechat/plugins/logger.la
lib/weechat/plugins/logger.so
-lib/weechat/plugins/logger.so.0
-%%PERL%%lib/weechat/plugins/perl.a
-%%PERL%%lib/weechat/plugins/perl.la
+lib/weechat/plugins/xfer.so
+libdata/pkgconfig/weechat.pc
+%%ASPELL%%lib/weechat/plugins/aspell.so
+%%CHARSET%%lib/weechat/plugins/charset.so
+%%LUA%%lib/weechat/plugins/lua.so
%%PERL%%lib/weechat/plugins/perl.so
-%%PERL%%lib/weechat/plugins/perl.so.0
-%%PYTHON%%lib/weechat/plugins/python.a
-%%PYTHON%%lib/weechat/plugins/python.la
%%PYTHON%%lib/weechat/plugins/python.so
-%%PYTHON%%lib/weechat/plugins/python.so.0
-%%RUBY%%lib/weechat/plugins/ruby.a
-%%RUBY%%lib/weechat/plugins/ruby.la
%%RUBY%%lib/weechat/plugins/ruby.so
-%%RUBY%%lib/weechat/plugins/ruby.so.0
-%%TCL%%lib/weechat/plugins/tcl.so.0
%%TCL%%lib/weechat/plugins/tcl.so
-%%TCL%%lib/weechat/plugins/tcl.la
-%%TCL%%lib/weechat/plugins/tcl.a
-lib/weechat/plugins/xfer.a
-lib/weechat/plugins/xfer.la
-lib/weechat/plugins/xfer.so
-lib/weechat/plugins/xfer.so.0
-libdata/pkgconfig/weechat.pc
+%%DOCUMENTATION%%share/doc/weechat/weechat_faq.de.html
%%DOCUMENTATION%%share/doc/weechat/weechat_faq.en.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_plugin_api.en.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.en.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_scripting.en.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_tester.en.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_user.en.html
%%DOCUMENTATION%%share/doc/weechat/weechat_faq.fr.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_faq.it.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_faq.pl.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_plugin_api.en.html
%%DOCUMENTATION%%share/doc/weechat/weechat_plugin_api.fr.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.de.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.en.html
%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.fr.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.ja.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.it.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.pl.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.ru.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_scripting.en.html
%%DOCUMENTATION%%share/doc/weechat/weechat_scripting.fr.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_tester.de.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_tester.en.html
%%DOCUMENTATION%%share/doc/weechat/weechat_tester.fr.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_user.fr.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_faq.pl.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.pl.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_tester.it.html
%%DOCUMENTATION%%share/doc/weechat/weechat_tester.pl.html
-%%DOCUMENTATION%%share/doc/weechat/weechat_quickstart.de.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_user.en.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_user.fr.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_user.it.html
+%%NLS%%share/locale/cs/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/de/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/es/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/fr/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/hu/LC_MESSAGES/weechat.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/weechat.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/it/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/pl/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/weechat.mo
@dirrmtry lib/weechat/plugins
@dirrmtry lib/weechat
@dirrmtry share/doc/weechat