aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2013-10-18 21:50:45 +0000
committerJase Thew <jase@FreeBSD.org>2013-10-18 21:50:45 +0000
commit9c04ae0823606c63b1de206de54468fd8f81459c (patch)
treeeae103a5a95f21241e77662dcad2b6f86a57001c /irc/weechat
parenta9546cb30148a6a2f7d6bcd318f477be8ca024b5 (diff)
downloadports-9c04ae0823606c63b1de206de54468fd8f81459c.tar.gz
ports-9c04ae0823606c63b1de206de54468fd8f81459c.zip
Notes
Diffstat (limited to 'irc/weechat')
-rw-r--r--irc/weechat/Makefile56
-rw-r--r--irc/weechat/distinfo6
-rw-r--r--irc/weechat/pkg-descr7
-rw-r--r--irc/weechat/pkg-plist13
4 files changed, 61 insertions, 21 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 3a307e867994..1e76fc6c8d71 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= weechat
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 0.4.2
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/
@@ -19,12 +18,12 @@ USES= cmake iconv
CMAKE_ARGS+= -DENABLE_GUILE=no
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
- gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA CHARSET BACKTRACE ASPELL \
- GNUTLS NLS DOCUMENTATION COLOR256 ICON
-OPTIONS_DEFAULT=CHARSET
+ GNUTLS NLS DOCUMENTATION COLOR256 ICON MANPAGES
+OPTIONS_DEFAULT=CHARSET MANPAGES
BACKTRACE_DESC= Provide crash backtraces
CHARSET_DESC= Charset conversion support
@@ -37,7 +36,6 @@ TCL_DESC= Tcl scripting support
COLOR256_DESC= Use ncurses port for 256 color support
ICON_DESC= Desktop icon
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCHARSET}
@@ -84,7 +82,7 @@ PLIST_SUB+= RUBY="@comment "
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-USES+= pkgconfig
+USES+= pkgconfig
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.else
CMAKE_ARGS+= -DENABLE_GNUTLS=no
@@ -121,23 +119,46 @@ PLIST_SUB+= LUA="@comment "
.endif
.if ${PORT_OPTIONS:MDOCUMENTATION}
-BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
-BUILD_DEPENDS+= source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+CMAKE_ARGS+= -DENABLE_DOC=yes
PLIST_SUB+= DOCUMENTATION=""
.else
CMAKE_ARGS+= -DENABLE_DOC=no
PLIST_SUB+= DOCUMENTATION="@comment "
.endif
+.if ${PORT_OPTIONS:MMANPAGES}
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
+ docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl
+.if empty(PORT_OPTIONS:MDOCUMENTATION)
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+.endif
+CMAKE_ARGS+= -DENABLE_MAN=yes -DMANDIR=${MANPREFIX}/man
+.else
+MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:man/}
+MASTER_SITE_SUBDIR+= jase/weechat/:man
+DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DISTNAME}-manpages.tar.gz:man
+CMAKE_ARGS+= -DENABLE_MAN=no
+.endif
+PLIST_SUB+= MANPAGES=""
+.else
+CMAKE_ARGS+= -DENABLE_MAN=no
+PLIST_SUB+= MANPAGES="@comment"
+.endif
+
.if ${PORT_OPTIONS:MBACKTRACE}
LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo
.endif
.if ${PORT_OPTIONS:MCOLOR256}
-USES+= ncurses:port
+USES+= ncurses:port
CMAKE_ARGS+= -DNCURSES_INCLUDE_PATH=${LOCALBASE}/include/ncurses
.else
-USES+= ncurses
+USES+= ncurses
.endif
.if ${PORT_OPTIONS:MICON}
@@ -146,8 +167,6 @@ PLIST_SUB+= ICON=""
PLIST_SUB+= ICON="@comment "
.endif
-MAN1= weechat-curses.1
-
post-patch:
@${REINPLACE_CMD} -e 's|$${LIBDIR}/../pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's|INSTALL|#INSTALL|' ${WRKSRC}/doc/CMakeLists.txt
@@ -173,6 +192,13 @@ pre-configure:
.endif
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/weechat-curses.1 ${MAN1PREFIX}/man/man1
+.if ${PORT_OPTIONS:MMANPAGES} && !defined(MAINTAINER_MODE)
+ ${INSTALL_MAN} ${WRKDIR}/manpages/weechat.1 ${STAGEDIR}${PREFIX}/man/man1
+.for f in de fr it ja
+ @${MKDIR} ${STAGEDIR}${PREFIX}/man/${f}/man1
+ ${INSTALL_MAN} ${WRKDIR}/manpages/${f}/weechat.1 ${STAGEDIR}${PREFIX}/man/${f}/man1
+.endfor
+.endif
+ ${LN} -sf ${PREFIX}/bin/weechat ${STAGEDIR}${PREFIX}/bin/weechat-curses
.include <bsd.port.mk>
diff --git a/irc/weechat/distinfo b/irc/weechat/distinfo
index bc5660c876af..99e1123fc5fc 100644
--- a/irc/weechat/distinfo
+++ b/irc/weechat/distinfo
@@ -1,2 +1,4 @@
-SHA256 (weechat-0.4.1.tar.gz) = 3c110a1397ab1f1e2a7cf80b8900e2c02ea01f80e4b09ef7954706916e05563f
-SIZE (weechat-0.4.1.tar.gz) = 2567828
+SHA256 (weechat-0.4.2.tar.gz) = 3bb9964ef776183adab9513b7e3662170039aaccab21eb71cfbeac494694d70f
+SIZE (weechat-0.4.2.tar.gz) = 2729241
+SHA256 (weechat-0.4.2-manpages.tar.gz) = 1a52d8585e8ffabee048e4f1a0fd122d324ab1bae3d90d1ddf113828e815c7df
+SIZE (weechat-0.4.2-manpages.tar.gz) = 6511
diff --git a/irc/weechat/pkg-descr b/irc/weechat/pkg-descr
index fdfc8abd667b..6db5dde681e1 100644
--- a/irc/weechat/pkg-descr
+++ b/irc/weechat/pkg-descr
@@ -1,6 +1,5 @@
-WeeChat (Wee Enhanced Environment for Chat) is a fast and light IRC
-client. Everything can be done with a keyboard, and it is customizable
-and extensible with scripts. For the moment, only ncurse GUI is
-supported by this port.
+WeeChat (Wee Enhanced Environment for Chat) is a fast and light IRC
+client. Everything can be done with a keyboard, and it is customizable
+and extensible with scripts.
WWW: http://weechat.org
diff --git a/irc/weechat/pkg-plist b/irc/weechat/pkg-plist
index bff95097d82a..2e9e152465be 100644
--- a/irc/weechat/pkg-plist
+++ b/irc/weechat/pkg-plist
@@ -1,3 +1,4 @@
+bin/weechat
bin/weechat-curses
include/weechat/weechat-plugin.h
lib/weechat/plugins/alias.so
@@ -9,6 +10,11 @@ lib/weechat/plugins/rmodifier.so
lib/weechat/plugins/script.so
lib/weechat/plugins/xfer.so
libdata/pkgconfig/weechat.pc
+%%MANPAGES%%man/man1/weechat.1.gz
+%%MANPAGES%%man/de/man1/weechat.1.gz
+%%MANPAGES%%man/fr/man1/weechat.1.gz
+%%MANPAGES%%man/it/man1/weechat.1.gz
+%%MANPAGES%%man/ja/man1/weechat.1.gz
%%ASPELL%%lib/weechat/plugins/aspell.so
%%CHARSET%%lib/weechat/plugins/charset.so
%%LUA%%lib/weechat/plugins/lua.so
@@ -63,8 +69,15 @@ libdata/pkgconfig/weechat.pc
%%NLS%%share/locale/pl/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/ru/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/weechat.mo
@dirrmtry lib/weechat/plugins
@dirrmtry lib/weechat
+%%MANPAGES%%@dirrmtry man/it/man1
+%%MANPAGES%%@dirrmtry man/it
+%%MANPAGES%%@dirrmtry man/fr/man1
+%%MANPAGES%%@dirrmtry man/fr
+%%MANPAGES%%@dirrmtry man/de/man1
+%%MANPAGES%%@dirrmtry man/de
%%DOCUMENTATION%%@dirrmtry share/doc/weechat
%%ICON%%@dirrmtry share/icons/hicolor/32x32/apps
%%ICON%%@dirrmtry share/icons/hicolor/32x32