aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat-fish
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-11-29 19:55:29 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-11-29 19:55:29 +0000
commit033f7347f80266e9e01663ffe8a1a6ffb2dc71c8 (patch)
treec35a98930c7cac2172980f8d63a23ac4ca29b8bd /irc/xchat-fish
parentd52e9113224edfd0381bf138c6c9f910a73eb096 (diff)
Notes
Diffstat (limited to 'irc/xchat-fish')
-rw-r--r--irc/xchat-fish/Makefile31
-rw-r--r--irc/xchat-fish/files/patch-FiSH.c6
2 files changed, 14 insertions, 23 deletions
diff --git a/irc/xchat-fish/Makefile b/irc/xchat-fish/Makefile
index d8617ec22c2b..bb269c3e3e3f 100644
--- a/irc/xchat-fish/Makefile
+++ b/irc/xchat-fish/Makefile
@@ -17,10 +17,9 @@ COMMENT= An encryption plugin for XChat
BUILD_DEPENDS= ${LOCALBASE}/lib/libmiracl.a:${PORTSDIR}/math/miracl
RUN_DEPENDS= xchat:${PORTSDIR}/irc/xchat
-NO_STAGE= yes
-
USE_ZIP= yes
NO_WRKSUBDIR= yes
+USE_DOS2UNIX= yes
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
CCFLAGS+= -Wall -O2 -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -30,27 +29,19 @@ PLIST_FILES= lib/xchat/plugins/xfish.so
PORTDOCS= FiSH-xchat.txt \
FiSH-xchat_History.txt
+.include <bsd.port.options.mk>
+
post-patch:
- @${CP} -pf ${FILESDIR}/Makefile ${WRKSRC}/
- @${RM} -f ${WRKSRC}/mir*
-# \r\n -> \n
- @${FIND} ${WRKSRC} -type f -exec \
- ${REINPLACE_CMD} -E \
- -e 's| ||' \
- {} \;
+ ${RM} -f ${WRKSRC}/mir*
+ ${CP} -pf ${FILESDIR}/Makefile ${WRKSRC}/
do-install:
-# docs
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${doc} \
- ${DOCSDIR}/
-.endfor
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/xchat/plugins
+ ${INSTALL_PROGRAM} ${WRKSRC}/xfish.so \
+ ${STAGEDIR}${PREFIX}/lib/xchat/plugins/
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.endif
-# plugin
- @${MKDIR} ${PREFIX}/lib/xchat/plugins
- @${INSTALL_PROGRAM} ${WRKSRC}/xfish.so \
- ${PREFIX}/lib/xchat/plugins/
.include <bsd.port.mk>
diff --git a/irc/xchat-fish/files/patch-FiSH.c b/irc/xchat-fish/files/patch-FiSH.c
index 16c598bc91ee..1a653cb66bda 100644
--- a/irc/xchat-fish/files/patch-FiSH.c
+++ b/irc/xchat-fish/files/patch-FiSH.c
@@ -1,10 +1,10 @@
--- FiSH.c.orig 2006-03-15 22:17:58.000000000 +0100
+++ FiSH.c 2008-03-29 17:27:33.000000000 +0100
@@ -4,6 +4,7 @@
-
-
+
+
#include "xchat-plugin.h"
+#include <ctype.h>
#include "FiSH.h"
- static xchat_plugin *ph=0; // plugin handle
+ static xchat_plugin *ph=0; // plugin handle