aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat-fish
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-18 01:45:04 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-18 01:45:04 +0000
commit27b595476cc7168f45df2a40edb96ce0ce9883f5 (patch)
tree7da9c81a266e8eea0c4e3ecd5172c0fbaf178599 /irc/xchat-fish
parent79e0c9b3c0e1de0ae7bc4ea82fa9594702f8ce87 (diff)
downloadports-27b595476cc7168f45df2a40edb96ce0ce9883f5.tar.gz
ports-27b595476cc7168f45df2a40edb96ce0ce9883f5.zip
Notes
Diffstat (limited to 'irc/xchat-fish')
-rw-r--r--irc/xchat-fish/Makefile68
-rw-r--r--irc/xchat-fish/distinfo2
-rw-r--r--irc/xchat-fish/pkg-descr11
-rw-r--r--irc/xchat-fish/pkg-plist1
4 files changed, 82 insertions, 0 deletions
diff --git a/irc/xchat-fish/Makefile b/irc/xchat-fish/Makefile
new file mode 100644
index 000000000000..e2e6872f765c
--- /dev/null
+++ b/irc/xchat-fish/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: XChat fish
+# Date created: Mon Jan 17 03:22:41 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fish
+DISTVERSION= 0.97a
+CATEGORIES= irc security
+MASTER_SITES= http://fish.sekure.us/xchat/
+PKGNAMEPREFIX= xchat-
+DISTNAME= FiSH-xchat.v${DISTVERSION}-source
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= An encryption plugin for XChat
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmiracl.a:${PORTSDIR}/math/miracl
+RUN_DEPENDS= xchat:${PORTSDIR}/irc/xchat2
+
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= ys
+
+#
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_FILES= \
+ lib/xchat/plugins/xfish.so
+
+PORTDOCS= \
+ FiSH-xchat.txt \
+ FiSH-xchat_History.txt
+
+post-patch:
+# \r\n -> \n
+ @${FIND} ${WRKSRC} -type f -exec \
+ ${REINPLACE_CMD} -E \
+ -e 's| ||' \
+ {} \;
+# CC safeness
+# CFLAGS safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|gcc|${CC}|' \
+ -e 's|-O2|${CFLAGS}|' \
+ -e 's|-shared|-shared -fPIC -DPIC|' \
+ -e 's|miracl.a|${LOCALBASE}/lib/libmiracl.a|' \
+ ${WRKSRC}/make*
+
+do-build:
+ @cd ${WRKSRC} && ${SH} ./make_all
+
+do-install:
+# docs
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} \
+ ${DOCSDIR}
+.endfor
+.endif
+# plugin
+ @${MKDIR} ${PREFIX}/lib/xchat/plugins
+ @${INSTALL_PROGRAM} ${WRKSRC}/xfish.so \
+ ${PREFIX}/lib/xchat/plugins
+
+.include <bsd.port.mk>
diff --git a/irc/xchat-fish/distinfo b/irc/xchat-fish/distinfo
new file mode 100644
index 000000000000..d8847f43f60a
--- /dev/null
+++ b/irc/xchat-fish/distinfo
@@ -0,0 +1,2 @@
+MD5 (FiSH-xchat.v0.97a-source.zip) = 8a084404116faef27ba081ad1d2004e7
+SIZE (FiSH-xchat.v0.97a-source.zip) = 43088
diff --git a/irc/xchat-fish/pkg-descr b/irc/xchat-fish/pkg-descr
new file mode 100644
index 000000000000..8a8f3ce599a6
--- /dev/null
+++ b/irc/xchat-fish/pkg-descr
@@ -0,0 +1,11 @@
+[ excerpt from developer's web site ]
+
+his is an encryption plugin for xchat, it is based on blowfish and
+is fully compatible to original 'blowcrypt' script. It supports
+private chat and channel encryption. A secure key-exchange system
+is included aswell. Please read the whole document, especially the
+'Installation' section, before installing it!
+
+WWW: http://fish.sekure.us/
+
+-- lioux@FreeBSD.org
diff --git a/irc/xchat-fish/pkg-plist b/irc/xchat-fish/pkg-plist
new file mode 100644
index 000000000000..0a69651fe4a6
--- /dev/null
+++ b/irc/xchat-fish/pkg-plist
@@ -0,0 +1 @@
+@unexec rmdir %D/lib/xchat/plugins 2>/dev/null || true