aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat-gnome
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /irc/xchat-gnome
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'irc/xchat-gnome')
-rw-r--r--irc/xchat-gnome/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 7bd3af38a661..f7403a119c5a 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -26,8 +26,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui gnomedocutils desktopfileutils
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
CONFIGURE_ARGS= --disable-tcl
GCONF_SCHEMAS= apps_xchat.schemas notification.schemas urlscraper.schemas
INSTALLS_ICONS= yes
@@ -70,10 +70,10 @@ PLIST_SUB+= PYTHON="@comment "
.if defined(WITH_TCL)
LIB_DEPENDS+= tcl83.1:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+=--enable-tcl=${LOCALBASE}/lib/tcl8.3
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- -I${LOCALBASE}/include/tcl8.3" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
-L${LOCALBASE}/lib/tcl8.3"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+ -I${LOCALBASE}/include/tcl8.3
PLIST_SUB+= TCL=""
.else
CONFIGURE_ARGS+=--enable-tcl=no