aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat-systray-plugin
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-12-16 19:57:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-12-16 19:57:37 +0000
commit876316f715d3050ac79c93a9776f541df347d756 (patch)
treea9a5d3cfd4ae8208f536a9dd37f4384e37f8e2c4 /irc/xchat-systray-plugin
parent1ff7fa0b8b2b9bf2190fcddfc0a8d944e505cb44 (diff)
downloadports-876316f715d3050ac79c93a9776f541df347d756.tar.gz
ports-876316f715d3050ac79c93a9776f541df347d756.zip
Notes
Diffstat (limited to 'irc/xchat-systray-plugin')
-rw-r--r--irc/xchat-systray-plugin/Makefile4
-rw-r--r--irc/xchat-systray-plugin/files/patch-src-systray.c4
2 files changed, 5 insertions, 3 deletions
diff --git a/irc/xchat-systray-plugin/Makefile b/irc/xchat-systray-plugin/Makefile
index bdcb148fe805..3db9c49fe8f3 100644
--- a/irc/xchat-systray-plugin/Makefile
+++ b/irc/xchat-systray-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xchat-systray-plugin
PORTVERSION= 2.4.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xchat2-plugins
@@ -24,6 +24,8 @@ USE_GNOME= gtk20
post-patch:
@${REINPLACE_CMD} -e 's|-Os|${CFLAGS} -fPIC|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/systray.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/systray.so ${PREFIX}/lib/xchat/plugins/
diff --git a/irc/xchat-systray-plugin/files/patch-src-systray.c b/irc/xchat-systray-plugin/files/patch-src-systray.c
index 2a21d35ce5b9..a7566af9dd78 100644
--- a/irc/xchat-systray-plugin/files/patch-src-systray.c
+++ b/irc/xchat-systray-plugin/files/patch-src-systray.c
@@ -5,7 +5,7 @@
go_change=TRUE;
go_identify=TRUE;
- strcpy(imagepath,xchat_get_info(ph, "xchatdir"));
-+ strcpy(imagepath,"/usr/X11R6/lib/xchat/plugins");
++ strcpy(imagepath,"%%LOCALBASE%%/lib/xchat/plugins");
}
// events handling
@@ -27,7 +27,7 @@
{
if (imagepath) sprintf(temp,"%s/%s/%s", imagepath ,type,filename);
- else sprintf(temp,"%s/%s/%s", xchat_get_info(ph, "xchatdir"),type,filename);
-+ else sprintf(temp,"%s/%s/%s", "/usr/X11R6/lib/xchat/plugins",type,filename);
++ else sprintf(temp,"%s/%s/%s", "%%LOCALBASE%%/lib/xchat/plugins",type,filename);
#ifdef _WIN32_
tempbuffer= ((HICON)LoadImage( tray_inst, temp, IMAGE_ICON, 16, 16, LR_LOADFROMFILE ));
#else