aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-06-13 22:31:23 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-06-13 22:31:23 +0000
commitd50933c749714cdedd7de7390b31bdc405fdb278 (patch)
tree84fb1057e8cbf977b48689c9fd0d1f85b1f61fd4 /irc/xchat/Makefile
parent51eeed9be3058b9dfb7c9a07a541a5c46440ecaf (diff)
downloadports-d50933c749714cdedd7de7390b31bdc405fdb278.tar.gz
ports-d50933c749714cdedd7de7390b31bdc405fdb278.zip
Notes
Diffstat (limited to 'irc/xchat/Makefile')
-rw-r--r--irc/xchat/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 38500306e02b..cf3d0e44ffd2 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xchat
PORTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/2.6/
@@ -69,6 +70,12 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= DBUS="@comment "
.endif
+.if !defined(WITHOUT_GTKSPELL)
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+.else
+CONFIGURE_ARGS+=--disable-spell
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600 || defined(WITHOUT_PERL)
@@ -81,7 +88,7 @@ PLIST_SUB+= PERL=""
.endif
pre-everything::
-.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS) || !defined(WITH_TCL) || !defined(WITHOUT_PERL) || !defined(WITHOUT_DBUS)
+.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS) || !defined(WITH_TCL) || !defined(WITHOUT_PERL) || !defined(WITHOUT_DBUS) || !defined(WITHOUT_GTKSPELL)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
@@ -100,6 +107,9 @@ pre-everything::
.if !defined(WITHOUT_DBUS)
@${ECHO_MSG} "WITHOUT_DBUS=yes to disable dbus support"
.endif
+.if !defined(WITHOUT_GTKSPELL)
+ @${ECHO_MSG} "WITHOUT_GTKSPELL=yes to disable spell check support"
+.endif
post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \