aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat1
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-05-14 21:46:43 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-05-14 21:46:43 +0000
commitbea951197b8e962ec2b87a84936c5f031e257644 (patch)
tree0229647ab33c0f591c7b458362254daf3127dbdb /irc/xchat1
parentade6ec62735eb8df1b1e1112421c3d1639821352 (diff)
downloadports-bea951197b8e962ec2b87a84936c5f031e257644.tar.gz
ports-bea951197b8e962ec2b87a84936c5f031e257644.zip
Notes
Diffstat (limited to 'irc/xchat1')
-rw-r--r--irc/xchat1/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index ccdf7a1aac31..f16e04158568 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xchat
PORTVERSION= 1.8.11
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/1.8/ \
http://xchat.linuxpower.org/files/source/1.8/
@@ -36,6 +36,18 @@ CONFIGURE_ARGS+= --without-included-gettext \
--datadir="${PREFIX}/share" \
--enable-perl
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --enable-openssl
+.endif
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --enable-python
+.else
+CONFIGURE_ARGS+= --disable-python
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_SOCKS)
@@ -44,11 +56,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(WITH_SSL)
-USE_OPENSSL= YES
-CONFIGURE_ARGS+= --enable-openssl
-.endif
-
.if defined(WITH_TRANSPARENCY)
BUILD_DEPENDS+= ${X11BASE}/bin/gdk-pixbuf-config:${PORTSDIR}/graphics/gdk-pixbuf
CONFIGURE_ARGS+= --enable-gdk-pixbuf
@@ -64,13 +71,6 @@ MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps" \
CONFIGURE_ARGS+= --disable-gnome --disable-zvt
.endif
-.if defined(WITH_PYTHON)
-USE_PYTHON= yes
-CONFIGURE_ARGS+= --enable-python
-.else
-CONFIGURE_ARGS+= --disable-python
-.endif
-
post-patch:
@${PERL} -pi \
-e 's|-lpthread|${PTHREAD_LIBS}|g;' \