aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-01-06 01:01:15 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-01-06 01:01:15 +0000
commitb20c5c257d4220a6ce88d6e38d42b7612f9ef218 (patch)
treeacb6929d1e27d1365e11ac09d6dec26148b98824 /irc/xchat
parent4d1bb00790045baf7a98c0cc2c2081d040bc4125 (diff)
downloadports-b20c5c257d4220a6ce88d6e38d42b7612f9ef218.tar.gz
ports-b20c5c257d4220a6ce88d6e38d42b7612f9ef218.zip
Notes
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile1
-rw-r--r--irc/xchat/files/patch-src_common_cfgfiles.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index c699fca2d126..ddbe6adb02c9 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -8,6 +8,7 @@
PORTNAME= xchat
PORTVERSION= 2.8.0
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
diff --git a/irc/xchat/files/patch-src_common_cfgfiles.c b/irc/xchat/files/patch-src_common_cfgfiles.c
new file mode 100644
index 000000000000..b5f462f43698
--- /dev/null
+++ b/irc/xchat/files/patch-src_common_cfgfiles.c
@@ -0,0 +1,11 @@
+--- src/common/cfgfiles.c.orig Fri Jan 5 18:55:27 2007
++++ src/common/cfgfiles.c Fri Jan 5 18:55:40 2007
+@@ -45,7 +45,7 @@
+ int cmd_len = 1, name_len;
+
+ /* remove <2.8.0 stuff */
+- if (!strcmp (cmd, "AWAY") & !strcmp (name, "BACK"))
++ if (!strcmp (cmd, "away") & !strcmp (name, "BACK"))
+ return;
+
+ if (cmd)