aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-06-07 02:21:42 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-06-07 02:21:42 +0000
commitca85956a03a0e1287304add7f0289e4f5bdf5ebf (patch)
tree510ef0a98910a1d025ebe7bcdef29fd401e4c896 /irc/xchat
parentde5a1e12383b4e689bee0c59c0c9689caafcb112 (diff)
downloadports-ca85956a03a0e1287304add7f0289e4f5bdf5ebf.tar.gz
ports-ca85956a03a0e1287304add7f0289e4f5bdf5ebf.zip
Notes
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile2
-rw-r--r--irc/xchat/files/patch-xc282-fixtrayzombies14
2 files changed, 15 insertions, 1 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index d90c9c8b9dd8..e9bf81048d7a 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xchat
PORTVERSION= 2.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
diff --git a/irc/xchat/files/patch-xc282-fixtrayzombies b/irc/xchat/files/patch-xc282-fixtrayzombies
new file mode 100644
index 000000000000..83e2f8cce416
--- /dev/null
+++ b/irc/xchat/files/patch-xc282-fixtrayzombies
@@ -0,0 +1,14 @@
+#
+# Fix defunc processes created by opening tray balloons
+#
+--- src/fe-gtk/plugin-tray.c 20 May 2007 11:08:03 -0000 1.21
++++ src/fe-gtk/plugin-tray.c 31 May 2007 13:12:19 -0000
+@@ -148,7 +148,7 @@
+ argv[5] = title;
+ argv[6] = text = strip_color (text, -1, STRIP_ALL);
+ argv[7] = NULL;
+- util_execv (argv);
++ xchat_execv (argv);
+ g_free ((char *)path);
+ free ((char *)text);
+ }