aboutsummaryrefslogtreecommitdiff
path: root/irc/zircon
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-03-03 17:56:34 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-03-03 17:56:34 +0000
commit16aa9b8b34cd17cc16df1b780af77d439c612c8b (patch)
tree146cd798963345bad7d782d87f4ed06cecdd8975 /irc/zircon
parent3d246ede7ad12c220095ead8e675c31aab003a57 (diff)
downloadports-16aa9b8b34cd17cc16df1b780af77d439c612c8b.tar.gz
ports-16aa9b8b34cd17cc16df1b780af77d439c612c8b.zip
Notes
Diffstat (limited to 'irc/zircon')
-rw-r--r--irc/zircon/Makefile1
-rw-r--r--irc/zircon/files/patch-dcc.tcl18
2 files changed, 19 insertions, 0 deletions
diff --git a/irc/zircon/Makefile b/irc/zircon/Makefile
index f4def8728370..5a06b6414364 100644
--- a/irc/zircon/Makefile
+++ b/irc/zircon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zircon
PORTVERSION= 1.18.256
+PORTREVISION= 1
CATEGORIES= irc tk84
MASTER_SITES= ftp://catless.ncl.ac.uk/pub/ \
${MASTER_SITE_LOCAL}
diff --git a/irc/zircon/files/patch-dcc.tcl b/irc/zircon/files/patch-dcc.tcl
new file mode 100644
index 000000000000..2488a793bfc6
--- /dev/null
+++ b/irc/zircon/files/patch-dcc.tcl
@@ -0,0 +1,18 @@
+--- plugins/Dcc/dcc.tcl.orig Tue Jul 10 17:40:00 2001
++++ plugins/Dcc/dcc.tcl Wed Mar 3 04:24:11 2004
+@@ -46,6 +46,15 @@
+ return 0
+ }
+ switch $posn [set fp [file size $file]] {} default {
++ foreach x [$net autoget] {
++ if {[regexp -- $x $usr]} {
++ $net CTCP DCC [$usr name] "RESUME [deSpace [file tail $file]] $port $fp"
++ global Resume
++ if {![info exists Resume($usr)]} {$usr ref}
++ lappend Resume($usr) [list $file $addr $port $leng $fp]
++ return 0
++ }
++ }
+ switch [tk_dialog .@dg$net {DCC Get} \
+ "File \"$file\" already exists. Select the action you want to take." \
+ warning 0 Overwrite Resume {Rename incoming} \