aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2018-08-01 20:19:59 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2018-08-01 20:19:59 +0000
commit246c4bbc549a0b116d3ce83cfaf3516d1e8e8e0b (patch)
tree36b242897265d140257c0c1ad4c2e559bf404488 /irc
parentf4efaadbc1d9b12f208c71f627d54c9812344632 (diff)
downloadports-246c4bbc549a0b116d3ce83cfaf3516d1e8e8e0b.tar.gz
ports-246c4bbc549a0b116d3ce83cfaf3516d1e8e8e0b.zip
irc/hexchat: add SYSINFO option (off by default)
PR: 227281 Submitted by: pkubaj@anongoth.pl (maintainer) Reported by: lcraft@gmail.com Sponsored by: Miles AS
Notes
Notes: svn path=/head/; revision=476196
Diffstat (limited to 'irc')
-rw-r--r--irc/hexchat/Makefile6
-rw-r--r--irc/hexchat/files/patch-plugins_sysinfo_meson.build18
-rw-r--r--irc/hexchat/pkg-plist1
3 files changed, 23 insertions, 2 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index e671683095f3..91d2cf9cd2a4 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -25,7 +25,7 @@ USES= meson ninja desktop-file-utils libtool pkgconfig ssl shebangfix \
USE_GNOME= cairo gtk20 intltool libxml2
USE_XORG= x11
USE_GITHUB= yes
-MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true -Dwith-sysinfo=false
+MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
@@ -37,7 +37,7 @@ SUB_FILES= pkg-message
PORTDOCS= *
OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA NOTIFY \
- PERL PYTHON TEXTFE
+ PERL PYTHON TEXTFE SYSINFO
OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL PYTHON
@@ -47,6 +47,7 @@ CA_BUNDLE_DESC= Include CA bundle for SSL verification
CANBERRA_DESC= Audio support via Libcanberra
FISHLIM_DESC= FiSHLiM plugin
TEXTFE_DESC= Text frontend
+SYSINFO_DESC= Sysinfo plugin
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
CA_BUNDLE_VARS= CA_BUNDLE="${LOCALBASE}/share/certs/ca-root-nss.crt"
@@ -72,6 +73,7 @@ PYTHON_VARS= SHEBANG_FILES=meson_post_install.py
PYTHON_VARS+= SHEBANG_FILES=plugins/perl/generate_header.py
PYTHON_VARS+= SHEBANG_FILES=src/common/make-te.py
TEXTFE_MESON_TRUE= with-text
+SYSINFO_MESON_TRUE= with-sysinfo
post-patch:
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
diff --git a/irc/hexchat/files/patch-plugins_sysinfo_meson.build b/irc/hexchat/files/patch-plugins_sysinfo_meson.build
new file mode 100644
index 000000000000..a631ef2a7243
--- /dev/null
+++ b/irc/hexchat/files/patch-plugins_sysinfo_meson.build
@@ -0,0 +1,18 @@
+--- plugins/sysinfo/meson.build.orig 2018-05-07 13:58:41 UTC
++++ plugins/sysinfo/meson.build
+@@ -13,13 +13,13 @@ sysinfo_includes = []
+ sysinfo_cargs = []
+
+ system = host_machine.system()
+-if system == 'linux' or system == 'darwin'
++if system == 'linux' or system == 'darwin' or system == 'freebsd'
+ sysinfo_includes += 'shared'
+ sysinfo_sources += [
+ 'shared/df.c'
+ ]
+
+- if system == 'linux'
++ if system == 'linux' or system == 'freebsd'
+ libpci = dependency('libpci', required: false, method: 'pkg-config')
+ if libpci.found()
+ sysinfo_deps += libpci
diff --git a/irc/hexchat/pkg-plist b/irc/hexchat/pkg-plist
index 3498b5238bf5..ef0ac335501a 100644
--- a/irc/hexchat/pkg-plist
+++ b/irc/hexchat/pkg-plist
@@ -6,6 +6,7 @@ lib/hexchat/plugins/checksum.so
%%PERL%%lib/hexchat/plugins/perl.so
%%PYTHON%%lib/hexchat/plugins/python.so
%%LUA%%%%LUA_LIBDIR%%/hexchat/plugins/lua.so
+%%SYSINFO%%lib/hexchat/plugins/sysinfo.so
libdata/pkgconfig/hexchat-plugin.pc
man/man1/hexchat.1.gz
share/metainfo/io.github.Hexchat.appdata.xml