aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2000-12-20 13:44:27 +0000
committerPeter Pentchev <roam@FreeBSD.org>2000-12-20 13:44:27 +0000
commitb35607ee58a9af9dee9acce62e088620ca704071 (patch)
tree931c03018904d129924054e0d4c4f5569da78e5f /irc
parentfcf6d5e013c407e445d2502b00634d6543ad2494 (diff)
downloadports-b35607ee58a9af9dee9acce62e088620ca704071.tar.gz
ports-b35607ee58a9af9dee9acce62e088620ca704071.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 6128374d4988..d084e61bac7c 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= BitchX
PORTVERSION= 1.0c17
+PORTREVISION= 1
CATEGORIES= irc gnome
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/
@@ -44,13 +45,19 @@ CONFIGURE_ARGS+=--enable-sound
.if defined(WITH_TCL)
BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+=--with-tcl \
- --with-tcl-includes=/usr/local/include/tcl8.3 \
- --with-tcl-libs=/usr/local/lib
+ --with-tcl-includes=${LOCALBASE}/include/tcl8.3 \
+ --with-tcl-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3"
post-extract:
@uudecode -p ${FILESDIR}/tcl-freebsd.o.uu > ${WRKSRC}/source/tcl.o
.endif
+.if defined(WITH_SOCKS5)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a${PORTSDIR}/net/socks5
+CONFIGURE_ARGS+=--with-socks5=${LOCALBASE}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
+.endif
+
.if defined(WITH_PLUGINS)
CONFIGURE_ARGS+=--with-plugins=pkga,possum,encrypt,hint,abot,acro,amp,blowfish,scan,wavplay,qmail,fserv,nap,qbx
PLIST_SUB+= PLUGINS:=""
@@ -70,6 +77,7 @@ pre-extract:
@${ECHO} "WITH_PLUGINS - Build the plugins"
@${ECHO} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
@${ECHO} "WITH_TCL - Build BitchX with TCL scripting"
+ @${ECHO} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
post-install:
.if !defined(NOPORTDOCS)