aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-12-28 06:38:13 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-12-28 06:38:13 +0000
commitcca6150fb3bab05227871dd4532c14d0aa9339ff (patch)
treea8d2d0ad0a522546561ef947f496a4422fdac904 /irc
parent1df7965f6abc4ef1bb80e68e8ab6ca5a0b7e9342 (diff)
downloadports-cca6150fb3bab05227871dd4532c14d0aa9339ff.tar.gz
ports-cca6150fb3bab05227871dd4532c14d0aa9339ff.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/iroffer-dinoex/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index 1e7f6adbbc83..a6153474cfaf 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -42,26 +42,16 @@ IROFFER_HTDOCS= iroffer-state.css robots.txt \
OPTIONS_DEFINE= CURL RUBY UPNP GEOIP
OPTIONS_DEFAULT=CURL RUBY UPNP GEOIP
-.include <bsd.port.options.mk>
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_ON= -curl
+RUBY_USE= RUBY=yes LIBRUBY=yes
+RUBY_CONFIGURE_ON= -ruby
+UPNP_LIB_DEPENDS= libminiupnpc.so:${PORTSDIR}/net/miniupnpc
+UPNP_CONFIGURE_ON= -upnp
+GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+GEOIP_CONFIGURE_ON= -geoip
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= -curl
-.endif
-.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
-CONFIGURE_ARGS+= -geoip
-.endif
-.if ${PORT_OPTIONS:MUPNP}
-LIB_DEPENDS+= miniupnpc:${PORTSDIR}/net/miniupnpc
-CONFIGURE_ARGS+= -upnp
-.endif
-.if ${PORT_OPTIONS:MRUBY}
-USE_RUBY= yes
-USE_LIBRUBY= yes
-CONFIGURE_ARGS+= -ruby
-.include "${PORTSDIR}/Mk/bsd.ruby.mk"
-.endif
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/iroffer ${STAGEDIR}${PREFIX}/bin/