aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /irc
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-gnome/Makefile2
-rw-r--r--irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 8c59f58402c6..7bd3af38a661 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xchat
PORTVERSION= 0.26.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= irc gnome ipv6
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/xchat-gnome/${PORTVERSION:R}
diff --git a/irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c b/irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c
new file mode 100644
index 000000000000..330ea57e8040
--- /dev/null
+++ b/irc/xchat-gnome/files/patch-plugins_notify-osd_notify-osd.c
@@ -0,0 +1,11 @@
+--- plugins/notify-osd/notify-osd.c.orig 2011-06-26 13:22:24.000000000 +0200
++++ plugins/notify-osd/notify-osd.c 2011-06-26 13:22:41.000000000 +0200
+@@ -67,7 +67,7 @@
+ gchar *escaped;
+
+ escaped = g_markup_escape_text (message, strlen(message));
+- notify = notify_notification_new (summary, escaped, NULL, NULL);
++ notify = notify_notification_new (summary, escaped, NULL);
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_icon_from_pixbuf (notify, notify_icon);
+ if (!notify_notification_show (notify, &error)) {