aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2015-04-09 10:38:48 +0000
committerRenato Botelho <garga@FreeBSD.org>2015-04-09 10:38:48 +0000
commit4b873a24ae5a772218f79e55c4976debc165c06c (patch)
tree3264aba4f0e0b9dbe54f483367dabe546a556c33 /irc
parentdb7c7144afef9ccf1c56a3c27754418a5a957d84 (diff)
- Update to 3.4
- Added xmlto and libxslt as dependencies, needed to build manpages - Removed IPV6 OPTION, it doesn't exist on configure anymore - Added NSS as a valid option to SSL - Added a new single option EVENTS, glib or libevent2 - Removed dependency of gnutls to OTR, it builds fine with openssl and/or nss - Disabled MSN by default, it was disabled also on configure since latest protocol version stopped working - As suggested by brix, takeover maintainership PR: 199261 Approved by: brix (maintainer)
Notes
Notes: svn path=/head/; revision=383633
Diffstat (limited to 'irc')
-rw-r--r--irc/bitlbee/Makefile43
-rw-r--r--irc/bitlbee/distinfo4
2 files changed, 26 insertions, 21 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index b18991e3178c..c03eee2b27ce 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -1,44 +1,48 @@
# $FreeBSD$
PORTNAME= bitlbee
-PORTVERSION= 3.2.2
-PORTREVISION= 4
+PORTVERSION= 3.4
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brix
-MAINTAINER= brix@FreeBSD.org
+MAINTAINER= garga@FreeBSD.org
COMMENT= IRC to other chat networks gateway
LICENSE= GPLv2
+BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto \
+ xsltproc:${PORTSDIR}/textproc/libxslt
+
SUB_FILES= pkg-message
PORTDOCS= AUTHORS CHANGES CREDITS FAQ README
PORTEXAMPLES= bitlbee.conf motd.txt
GNU_CONFIGURE= yes
USES= gmake pkgconfig
-USE_GNOME= glib20
USE_RC_SUBR= bitlbee
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES IPV6 OTR
+OPTIONS_DEFINE= DEBUG DOCS EXAMPLES OTR
-OPTIONS_SINGLE= SSL
-OPTIONS_SINGLE_SSL= OPENSSL GNUTLS
+OPTIONS_SINGLE= EVENTS SSL
+OPTIONS_SINGLE_EVENTS= GLIB LIBEVENT
+OPTIONS_SINGLE_SSL= OPENSSL GNUTLS NSS
OPTIONS_MULTI= PROTO
OPTIONS_MULTI_PROTO= JABBER LIBPURPLE MSN OSCAR TWITTER YAHOO
-OTR_DESC= Off-the-Record Messaging support (Requires GnuTLS)
+OTR_DESC= Off-the-Record Messaging support
LIBPURPLE_DESC= Use libpurple for protocol support
MSN_DESC= Microsoft Messenger support
OSCAR_DESC= OSCAR (ICQ, AIM) support
TWITTER_DESC= Twitter support
YAHOO_DESC= Yahoo! Messenger support
+GLIB_DESC= Use glib as event handler
+LIBEVENT_DESC= Use libevent as event handler
-OPTIONS_DEFAULT= GNUTLS JABBER MSN OSCAR TWITTER YAHOO
+OPTIONS_DEFAULT= GLIB GNUTLS JABBER OSCAR TWITTER YAHOO
CONFIGURE_ARGS= --config=/var/db/bitlbee --strip=0
@@ -47,30 +51,31 @@ GROUPS= bitlbee
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MOPENSSL} && ${PORT_OPTIONS:MOTR}
-IGNORE=Off-the-Record Messaging support requires GnuTLS support
-.endif
-
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--debug=1
.else
CONFIGURE_ARGS+=--debug=0
.endif
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+=--ipv6=1
-.else
-CONFIGURE_ARGS+=--ipv6=0
-.endif
-
.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+=--ssl=openssl
+.elif ${PORT_OPTIONS:MNSS}
+CONFIGURE_ARGS+=--ssl=nss
+LIB_DEPENDS+= libnss3.so:${PORTSDIR}/security/nss
.elif ${PORT_OPTIONS:MGNUTLS}
CONFIGURE_ARGS+=--ssl=gnutls
LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
.endif
+.if ${PORT_OPTIONS:MGLIB}
+CONFIGURE_ARGS+=--events=glib
+USE_GNOME= glib20
+.elif ${PORT_OPTIONS:MLIBEVENT}
+CONFIGURE_ARGS+=--events=libevent
+LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
+.endif
+
.if ${PORT_OPTIONS:MOTR}
CONFIGURE_ARGS+=--otr=1
LIB_DEPENDS+= libotr.so:${PORTSDIR}/security/libotr
diff --git a/irc/bitlbee/distinfo b/irc/bitlbee/distinfo
index c2c3aecaa0e9..c3b47a839c0b 100644
--- a/irc/bitlbee/distinfo
+++ b/irc/bitlbee/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bitlbee-3.2.2.tar.gz) = ba38939281f23e8a0e71022c7be0cb68f6544248404362c5e20245fa7a67558e
-SIZE (bitlbee-3.2.2.tar.gz) = 661757
+SHA256 (bitlbee-3.4.tar.gz) = cebad646bbfd17c80923743244039fd970e3ca27e8c1b7cf872622e773239d5e
+SIZE (bitlbee-3.4.tar.gz) = 761027