aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-15 15:38:31 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-15 15:38:31 +0000
commitc144d6b20f84130ca262b180000f689fd94d2506 (patch)
tree56c900c9f7f0e837be6c71199cc11ec687126c17 /irc
parentf0332dd31c1ce634cb16429da5fe6b80dba08e37 (diff)
downloadports-c144d6b20f84130ca262b180000f689fd94d2506.tar.gz
ports-c144d6b20f84130ca262b180000f689fd94d2506.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/bip/Makefile6
-rw-r--r--irc/dxirc/Makefile2
-rw-r--r--irc/eggdrop-devel/Makefile2
-rw-r--r--irc/iroffer-dinoex/Makefile2
-rw-r--r--irc/irssi-fish/Makefile2
-rw-r--r--irc/znc/Makefile2
6 files changed, 11 insertions, 5 deletions
diff --git a/irc/bip/Makefile b/irc/bip/Makefile
index e9835f4bd0e8..195d54e1c2ed 100644
--- a/irc/bip/Makefile
+++ b/irc/bip/Makefile
@@ -25,7 +25,9 @@ SUB_FILES= pkg-message
PORTDOCS= AUTHORS BUGS ChangeLog NEWS README TODO
EXAMPLEFILES= bip.conf bip.vim
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
post-install:
@cd ${WRKSRC} && ${INSTALL} bip.1 ${STAGEDIR}${PREFIX}/man/man1
@@ -47,4 +49,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/dxirc/Makefile b/irc/dxirc/Makefile
index bdba24e5432e..00b8941d76b6 100644
--- a/irc/dxirc/Makefile
+++ b/irc/dxirc/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-OPTIONS_DEFINE= NLS TRAY IPV6 SSL LUA ENCHANT NOTIFY
+OPTIONS_DEFINE= NLS TRAY IPV6 SSL LUA ENCHANT NOTIFY DOCS
OPTIONS_DEFAULT= TRAY SSL LUA
TRAY_DESC= Trayicon
diff --git a/irc/eggdrop-devel/Makefile b/irc/eggdrop-devel/Makefile
index 6b369a77ce5e..3ae1642f5978 100644
--- a/irc/eggdrop-devel/Makefile
+++ b/irc/eggdrop-devel/Makefile
@@ -30,6 +30,8 @@ SUB_FILES= pkg-message
CONFLICTS= eggdrop-[0-9]*
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index 0c1e97231732..86dfa50f3d9a 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -39,7 +39,7 @@ IROFFER_EXAMPLES= iroffer.cron \
IROFFER_HTDOCS= iroffer-state.css robots.txt \
info.txt.rb json.txt.rb md5.txt.rb sfv.txt.rb
-OPTIONS_DEFINE= CURL RUBY UPNP GEOIP
+OPTIONS_DEFINE= CURL RUBY UPNP GEOIP DOCS EXAMPLES
OPTIONS_DEFAULT=CURL RUBY UPNP GEOIP
CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
diff --git a/irc/irssi-fish/Makefile b/irc/irssi-fish/Makefile
index 6a69919d74b5..b9e85456cffc 100644
--- a/irc/irssi-fish/Makefile
+++ b/irc/irssi-fish/Makefile
@@ -22,6 +22,8 @@ USE_LDCONFIG= yes
PLIST_FILES= lib/irssi/modules/libfish.so
PORTDOCS= FiSH-irssi.txt FiSH-irssi_History.txt
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index b7463fdbda6c..9c85fb2f6e32 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -17,7 +17,7 @@ USES= pkgconfig iconv gmake
NO_OPTIONS_SORT= yes
-OPTIONS_DEFINE= DEBUG IPV6 OPENSSL CYRUS PERL PYTHON TCL
+OPTIONS_DEFINE= DEBUG IPV6 OPENSSL CYRUS PERL PYTHON TCL DOCS
OPTIONS_DEFAULT= OPENSSL PERL
OPTIONS_SUB= yes