aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-16 02:29:34 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-16 02:29:34 +0000
commit136cc8f44fe06808a711d8d17b4a4edde5528fb2 (patch)
treeb84ea78c60b31723859f75646bb5378e75c71abc /irc
parent23b245ed039e9ae8b8b051e8d072451d35ed49d9 (diff)
downloadports-136cc8f44fe06808a711d8d17b4a4edde5528fb2.tar.gz
ports-136cc8f44fe06808a711d8d17b4a4edde5528fb2.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/cwirc/Makefile2
-rw-r--r--irc/gruftistats/Makefile2
-rw-r--r--irc/infobot/Makefile2
-rw-r--r--irc/ircservices/Makefile2
-rw-r--r--irc/irssistats/Makefile2
-rw-r--r--irc/lostirc/Makefile2
-rw-r--r--irc/miau/Makefile5
-rw-r--r--irc/p5-POE-Component-IRC-Object/pkg-plist4
-rw-r--r--irc/pircbot/Makefile2
-rw-r--r--irc/ratbox-services/Makefile2
-rw-r--r--irc/ruby-irc/Makefile2
-rw-r--r--irc/ruby-rice/Makefile2
-rw-r--r--irc/thales/Makefile2
13 files changed, 24 insertions, 7 deletions
diff --git a/irc/cwirc/Makefile b/irc/cwirc/Makefile
index 7c7e8087518a..4c0c1ed70245 100644
--- a/irc/cwirc/Makefile
+++ b/irc/cwirc/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= xchat:${PORTSDIR}/irc/xchat
USES= pkgconfig
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
diff --git a/irc/gruftistats/Makefile b/irc/gruftistats/Makefile
index 1975cd774c0a..a58b2607f223 100644
--- a/irc/gruftistats/Makefile
+++ b/irc/gruftistats/Makefile
@@ -13,6 +13,8 @@ COMMENT= Produces a web page of statistics and quotes from IRC channel logs
GNU_CONFIGURE= YES
USES= gmake
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
's,strcasestr,strcasestr_x,g' ${WRKSRC}/ircstats.h \
diff --git a/irc/infobot/Makefile b/irc/infobot/Makefile
index bd4f60cca496..4a5b0320a6eb 100644
--- a/irc/infobot/Makefile
+++ b/irc/infobot/Makefile
@@ -14,6 +14,8 @@ USES= perl5
USE_PERL5= run
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
-@${RM} ${WRKSRC}/src/*.orig
.for i in config help users
diff --git a/irc/ircservices/Makefile b/irc/ircservices/Makefile
index c86f4d496de5..a2cc46ee147f 100644
--- a/irc/ircservices/Makefile
+++ b/irc/ircservices/Makefile
@@ -27,6 +27,8 @@ MAKE_JOBS_UNSAFE= yes
IRCSERVICES_LANG?= EN_US
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
diff --git a/irc/irssistats/Makefile b/irc/irssistats/Makefile
index 351d371cbf48..349b0221bd69 100644
--- a/irc/irssistats/Makefile
+++ b/irc/irssistats/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
ALL_TARGET= irssistats
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's|/etc/irssistats.conf|${PREFIX}/etc/irssistats.conf|g' ${WRKSRC}/irssistats.c
${REINPLACE_CMD} -e 's/gcc/$$(CC)/g' ${WRKSRC}/Makefile
diff --git a/irc/lostirc/Makefile b/irc/lostirc/Makefile
index 09d82d80134e..1c23441aed5f 100644
--- a/irc/lostirc/Makefile
+++ b/irc/lostirc/Makefile
@@ -23,6 +23,8 @@ CONFIGURE_ARGS= --disable-kde
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS ChangeLog TODO README INSTALL
diff --git a/irc/miau/Makefile b/irc/miau/Makefile
index 7dffee3d6b60..ad1407e85d51 100644
--- a/irc/miau/Makefile
+++ b/irc/miau/Makefile
@@ -29,9 +29,8 @@ CONFIGURE_ARGS= --enable-dccbounce \
--disable-dependency-tracking
CPPFLAGS+= -I${LOCALBASE}/include
-.if defined(WITH_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
+OPTIONS_DEFINE= DOCS IPV6
+IPV6_CONFIGURE_ON= --enable-ipv6
post-patch:
@${REINPLACE_CMD} -e 's,\$$datadir/doc/miau/examples,${EXAMPLESDIR},g' \
diff --git a/irc/p5-POE-Component-IRC-Object/pkg-plist b/irc/p5-POE-Component-IRC-Object/pkg-plist
index 20d776ad230d..412e391c9e21 100644
--- a/irc/p5-POE-Component-IRC-Object/pkg-plist
+++ b/irc/p5-POE-Component-IRC-Object/pkg-plist
@@ -1,8 +1,8 @@
%%PERL5_MAN3%%/POE::Component::IRC::Object.3.gz
%%SITE_PERL%%/POE/Component/IRC/Object.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Object/.packlist
-%%PORTDOCS%%%%EXAMPLESDIR%%/elizabot.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elizabot.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Object
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
diff --git a/irc/pircbot/Makefile b/irc/pircbot/Makefile
index 6962dfab8a05..7f06c9bb1250 100644
--- a/irc/pircbot/Makefile
+++ b/irc/pircbot/Makefile
@@ -21,6 +21,8 @@ USE_JAVA= yes
SUB_FILES= pkg-message
SUB_LIST= JAVAJARDIR=${JAVAJARDIR}
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_DATA} ${WRKSRC}/pircbot.jar ${STAGEDIR}${JAVAJARDIR}
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/irc/ratbox-services/Makefile b/irc/ratbox-services/Makefile
index 5fcd35456a6b..c67f7049221d 100644
--- a/irc/ratbox-services/Makefile
+++ b/irc/ratbox-services/Makefile
@@ -44,7 +44,7 @@ MAKE_JOBS_UNSAFE=yes
#-- Options ------------------------------------------------------------
OPTIONS_DEFINE= NICKSERV CHANSERV USERSERV OPERSERV ALIS JUPESERV OPERBOT GLOBALMSG \
- BANSERV WATCHSERV MEMOSERV
+ BANSERV WATCHSERV MEMOSERV DOCS
OPTIONS_DEFAULT= NICKSERV CHANSERV USERSERV OPERSERV ALIS JUPESERV OPERBOT GLOBALMSG \
BANSERV WATCHSERV MEMOSERV SQLITE
OPTIONS_MULTI= DB
diff --git a/irc/ruby-irc/Makefile b/irc/ruby-irc/Makefile
index d7f63dcc1bc8..7904c76e4f44 100644
--- a/irc/ruby-irc/Makefile
+++ b/irc/ruby-irc/Makefile
@@ -21,6 +21,8 @@ DOCS_EN= BUGS ChangeLog MANIFEST \
NEWS README TODO
DOCS_JA= MEMO.ja README.ja doc.ja/*
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/localize.rb ${STAGEDIR}${RUBY_SITELIBDIR}
diff --git a/irc/ruby-rice/Makefile b/irc/ruby-rice/Makefile
index ed1c8fedc33f..6716402173b9 100644
--- a/irc/ruby-rice/Makefile
+++ b/irc/ruby-rice/Makefile
@@ -14,6 +14,8 @@ COMMENT= Yet another IRC interface library for Ruby
USE_RUBY= yes
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${CP} -R ${WRKSRC}/rice ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/irc/thales/Makefile b/irc/thales/Makefile
index 15baef49944e..b17de2b64256 100644
--- a/irc/thales/Makefile
+++ b/irc/thales/Makefile
@@ -16,7 +16,7 @@ USES= gmake
USE_MYSQL= yes
USE_RC_SUBR= thales
-OPTIONS_DEFINE= MODES
+OPTIONS_DEFINE= MODES DOCS
OPTIONS_RADIO= IRCD
OPTIONS_RADIO_IRCD= HYBRID IRCDRU UNREAL
OPTIONS_DEFAULT=MODES UNREAL