aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
commit9839011ec3910790376ce9ace5e2a1c5bcb2781f (patch)
tree41c61966bf1404bd3cfce06493a35d6a1a4acfc6 /irc
parent41a56135d1e8a68844e4c575702cdbad451d7322 (diff)
downloadports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.tar.gz
ports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/epic4/Makefile3
-rw-r--r--irc/epic5/Makefile3
-rw-r--r--irc/keitairc/Makefile2
-rw-r--r--irc/nethirc/Makefile10
-rw-r--r--irc/p5-Bot-BasicBot/Makefile8
-rw-r--r--irc/p5-IRC-Bot-Hangman/Makefile8
-rw-r--r--irc/xchat-gnome/Makefile2
7 files changed, 7 insertions, 29 deletions
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index da10e51556fd..3e55d6db52a7 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -57,9 +57,6 @@ CONFIGURE_ARGS+= --with-tcl
# SITE_PERL and PERL_VER to create the path.
#
.if defined(WITH_PERL)
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.1 or newer; we recommend perl 5.8.5
-.endif
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl=${SITE_PERL}/../../${PERL_VER}/mach/CORE
.endif
diff --git a/irc/epic5/Makefile b/irc/epic5/Makefile
index 5f8bb6091250..44bc0d6281d8 100644
--- a/irc/epic5/Makefile
+++ b/irc/epic5/Makefile
@@ -53,9 +53,6 @@ CONFIGURE_ARGS+= --without-tcl
# SITE_PERL and PERL_VER to create the path.
#
.if defined(WITH_PERL)
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires Perl 5.6.1 or newer; we recommend perl 5.8.5
-.endif
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl=${SITE_PERL}/../../${PERL_VER}/mach/CORE
.endif
diff --git a/irc/keitairc/Makefile b/irc/keitairc/Makefile
index ff7d1cf180ba..610675846870 100644
--- a/irc/keitairc/Makefile
+++ b/irc/keitairc/Makefile
@@ -30,6 +30,8 @@ EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= -p
EXTRACT_AFTER_ARGS= ${WRKDIR}
+USE_PERL5= yes
+
post-patch:
${REINPLACE_CMD} -e "s,^#!/usr/bin/perl$$,#!${PERL}," ${WRKSRC}/keitairc
diff --git a/irc/nethirc/Makefile b/irc/nethirc/Makefile
index 436a83ec5f17..8dc917dd1ad1 100644
--- a/irc/nethirc/Makefile
+++ b/irc/nethirc/Makefile
@@ -18,15 +18,9 @@ BUILD_DEPENDS= ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Componen
${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN1= nethirc.pl.1
MAN3= NetHirc.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires Perl 5.8.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/p5-Bot-BasicBot/Makefile b/irc/p5-Bot-BasicBot/Makefile
index cf310fe9502c..eaec9b09006a 100644
--- a/irc/p5-Bot-BasicBot/Makefile
+++ b/irc/p5-Bot-BasicBot/Makefile
@@ -23,10 +23,4 @@ MAN3= Bot::BasicBot.3
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/p5-IRC-Bot-Hangman/Makefile b/irc/p5-IRC-Bot-Hangman/Makefile
index a2d96cdb3327..69a94eb2d475 100644
--- a/irc/p5-IRC-Bot-Hangman/Makefile
+++ b/irc/p5-IRC-Bot-Hangman/Makefile
@@ -36,10 +36,4 @@ MAN3= IRC::Bot::Hangman.3 \
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 66e2a8965986..d963e6335b01 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -84,7 +84,7 @@ PLIST_SUB+= TCL="@comment "
BROKEN= does not build on 4.X
.endif
-.if ${PERL_LEVEL} < 500600 || defined(WITHOUT_PERL)
+.if defined(WITHOUT_PERL)
CONFIGURE_ARGS+=--disable-perl
PLIST_SUB+= PERL="@comment "
.else