aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-06-27 17:59:37 +0000
committerChris Rees <crees@FreeBSD.org>2011-06-27 17:59:37 +0000
commitadc95087e6f5763c77a8c15300c8e52decf3d0aa (patch)
tree259c89a8f7a1cd28b53c828aadbe3a029df23fe4 /irc
parent315975246671d5af353dd4a01782d5c73be6e8f8 (diff)
downloadports-adc95087e6f5763c77a8c15300c8e52decf3d0aa.tar.gz
ports-adc95087e6f5763c77a8c15300c8e52decf3d0aa.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/ircd-ratbox-devel/Makefile4
-rw-r--r--irc/ircd-ratbox-devel/files/pkg-install.in83
2 files changed, 4 insertions, 83 deletions
diff --git a/irc/ircd-ratbox-devel/Makefile b/irc/ircd-ratbox-devel/Makefile
index 25de5fa92b14..031787b5c14a 100644
--- a/irc/ircd-ratbox-devel/Makefile
+++ b/irc/ircd-ratbox-devel/Makefile
@@ -28,6 +28,9 @@ USE_SQLITE= 3
USE_PERL5_BUILD= yes
USE_LDCONFIG= ${PREFIX}/lib/ircd-ratbox
+USERS= ircd
+GROUPS= ${USERS}
+
LOGDIR?= /var/log/${PORTNAME}
RUNDIR?= /var/run/${PORTNAME}
DBDIR?= /var/db/${PORTNAME}
@@ -188,7 +191,6 @@ post-build:
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} m_rsshortcut.la
pre-su-install:
- @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${MKDIR} ${PREFIX}/etc/${PORTNAME}
${MKDIR} ${DATADIR}/help
${MKDIR} ${PREFIX}/lib/${PORTNAME}/modules
diff --git a/irc/ircd-ratbox-devel/files/pkg-install.in b/irc/ircd-ratbox-devel/files/pkg-install.in
index 5b8b8375ec02..189cf6ec4f46 100644
--- a/irc/ircd-ratbox-devel/files/pkg-install.in
+++ b/irc/ircd-ratbox-devel/files/pkg-install.in
@@ -3,92 +3,11 @@
# Adapted from irc/ircd-hybrid's script
#
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
#-----------------------------------------------------------------------
if [ "x$2" = "xPRE-INSTALL" ]; then
#-----------------------------------------------------------------------
-if which -s pw ; then
- :
-else
- cat <<EOF
-Your system does not include the "pw" utility. You should upgrade
-to a newer version of FreeBSD. Without "pw" this script will not
-run.
-EOF
- exit 1
-fi
-
-echo ""
-if pw groupshow ircd 2> /dev/null ; then
- echo "You already have a group \"ircd\", so I will use it."
-else
- if pw groupshow 72 2> /dev/null ; then
- echo "You already have a gid \"72\". Please create a user \"ircd\""
- echo "with a default group of \"ircd\"."
- exit 1
- fi
- echo "You need a group \"ircd\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw groupadd ircd -g 72 || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- if ! pw usershow ircd 2> /dev/null ; then
- echo "While you're at it, please create a user \"ircd\""
- echo 'too, with a default group of "ircd".'
- fi
- exit 1
- fi
-fi
-
-if pw usershow ircd 2> /dev/null ; then
- echo "You already have a user \"ircd\", so I will use it."
-else
- if pw usershow 72 2> /dev/null ; then
- echo "You already have a uid \"72\". Please create a user \"irc
-d\""
- echo "with a default group of \"ircd\"."
- exit 1
- fi
- echo "You need a user \"ircd\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw useradd ircd -g ircd -u 72 -h - -d /nonexistent \
- -s /nonexistent -c "IRC Daemon" || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
-fi
+# ${DO_NADA}
#-----------------------------------------------------------------------
elif [ "x$2" = "xPOST-INSTALL" ]; then