aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-18 15:02:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-18 15:02:03 +0000
commit1d762a91a0e2bacc4d1d8965b9794ba59b28c06b (patch)
tree1ad3621f91799d2db4eea51e340ae9a2e7947439 /irc
parent4813d21b29b3a126efa0fb07d249fc5f6943548c (diff)
downloadports-1d762a91a0e2bacc4d1d8965b9794ba59b28c06b.tar.gz
ports-1d762a91a0e2bacc4d1d8965b9794ba59b28c06b.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/ptlink-ircd/Makefile22
-rw-r--r--irc/ptlink-ircd/distinfo4
-rw-r--r--irc/ptlink-ircd/files/ircd.conf.sample455
-rw-r--r--irc/ptlink-ircd/files/ircd.motd.sample14
-rw-r--r--irc/ptlink-ircd/files/kline.conf.sample1
-rw-r--r--irc/ptlink-ircd/files/main.dconf.sample106
-rw-r--r--irc/ptlink-ircd/files/network.dconf.sample242
-rw-r--r--irc/ptlink-ircd/files/opers.motd.sample5
-rw-r--r--irc/ptlink-ircd/files/patch-tools::install_ircd21
-rw-r--r--irc/ptlink-ircd/files/pkg-message.in11
-rw-r--r--irc/ptlink-ircd/files/ptlink-ircd.sh.in25
-rw-r--r--irc/ptlink-ircd/pkg-install28
-rw-r--r--irc/ptlink-ircd/pkg-message11
-rw-r--r--irc/ptlink-ircd/pkg-plist48
14 files changed, 103 insertions, 890 deletions
diff --git a/irc/ptlink-ircd/Makefile b/irc/ptlink-ircd/Makefile
index e43a71069486..23de2b9f3d72 100644
--- a/irc/ptlink-ircd/Makefile
+++ b/irc/ptlink-ircd/Makefile
@@ -6,26 +6,30 @@
#
PORTNAME= IRCd
-PORTVERSION= 6.19.3
+PORTVERSION= 6.19.4
CATEGORIES= irc
-MASTER_SITES= ftp://ftp.sunsite.dk/projects/ptlink/ircd/ \
- http://www.rootxs.org/pub/FreeBSD/distfiles/
+MASTER_SITES= ftp://ftp.sunsite.dk/projects/ptlink/ircd/
PKGNAMEPREFIX= PTlink-
DISTNAME= PTlink${PORTVERSION}
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= dennis@rootxs.org
COMMENT= PTlink IRC daemon
GNU_CONFIGURE= yes
USE_GMAKE= yes
-SYSCONFDIR= ${PREFIX}/etc/ptlink
-CONFIGURE_ARGS= --sysconfdir=${SYSCONFDIR}
+USE_RC_SUBR= ptlink-ircd.sh
+SUB_FILES= pkg-message
+
+SYSCONFDIR= ${PREFIX}/etc/ptlink-ircd
+LOGDIR= ${PREFIX}/var/log
+
+CONFIGURE_ARGS= --sysconfdir=${SYSCONFDIR} --with-pidfile=${SYSCONFDIR}/ircd.pid
post-install:
- @${INSTALL_DATA} ${FILESDIR}/*.sample ${SYSCONFDIR}
- @${SED} 's,%%SYSCONFDIR%%,${SYSCONFDIR},g' < ${PKGMESSAGE}
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CHOWN} -R ${USER}:${GROUP} ${SYSCONFDIR}
+ @${CHOWN} -R ${USER}:${GROUP} ${LOGDIR}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/irc/ptlink-ircd/distinfo b/irc/ptlink-ircd/distinfo
index 00a8da8fd570..305394788d77 100644
--- a/irc/ptlink-ircd/distinfo
+++ b/irc/ptlink-ircd/distinfo
@@ -1,2 +1,2 @@
-MD5 (PTlink6.19.3.tar.gz) = d46979f76e28757fedc508544dd0b5fa
-SIZE (PTlink6.19.3.tar.gz) = 791346
+MD5 (PTlink6.19.4.tar.gz) = e7c1ac8e0f6eb5486378b84d3949cc2b
+SIZE (PTlink6.19.4.tar.gz) = 786808
diff --git a/irc/ptlink-ircd/files/ircd.conf.sample b/irc/ptlink-ircd/files/ircd.conf.sample
deleted file mode 100644
index 46715285056e..000000000000
--- a/irc/ptlink-ircd/files/ircd.conf.sample
+++ /dev/null
@@ -1,455 +0,0 @@
-# $Id: example.conf.short,v 1.6 2004/05/20 23:02:34 jpinto Exp $
-# IRC - Internet Relay Chat, doc/example.conf
-#
-# CopyRight (C) 2001, Joćo Pinto
-# Short ircd.conf
-# check example.conf for original copyright
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 1, or (at your option)
-# any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-#
-#
-# IRC short example configuration file
-#
-# This file describes the information that should be present in your IRC
-# configuration and how to present it.
-#
-# This is a short version please check example.conf for the full example.
-#
-
-# M: set your server's name. Fields are, in order, host name (domain style),
-# optional bind address, a text name, and unused.
-#
-# NOTE: The "optional bind address" is an address used in binding to a
-# local address when we connect outbound. For example, if your server machine
-# is myhost.example.com (192.168.1.5) and you want IRCD to connect to others
-# from irc.example.com (192.168.1.250), you'd put 192.168.1.250 in the
-# "optional bind address" field. If left blank, UNIX will choose the primary
-# address of the interface closest to the destination.
-#
-# NOTE: As of PTlink6, the port field no longer binds a port by default.
-# It is an inoperative and obsolete field.
-# M:ServerName:bindaddress:Server Description
-M:PTlink6.server.net::PTlink6 IRCd - www.ptlink.net
-
-#
-# A: administrative information. This line should have three fields, which
-# may contain any arbitrary text. It is printed by the /ADMIN command.
-#
-A:IRC Server Admin: :Some Admin <ssadmin@xpto.net>
-
-
-
-#
-# Y: define connection class. A class must be defined in a Y: line before
-# it is used in a C, N, or I line. The fields are, in order, class number,
-# ping frequency in seconds, connect frequency in seconds, maximum
-# number of links (used for auto-connecting), and size of sendq.
-# For servers a sendq of at least 4mb is recommended if not more.
-#
-# N.B. Y lines must be defined before I lines and O lines, since
-# both I lines and O lines make reference to Y lines or classes.
-#
-# For clients, the connect frequency field is used to set the maximum
-# number of connects from same IP address. i.e. setting this field to '1'
-# will limit every I line using this Y, to one connection per IP address.
-# leaving it blank or 0, will disable any such checking.
-#
-
-# in this case, connect-frequency is 0 indicating that this is a client
-# class (servers never connect to clients, it is the other way around).
-
-# -----------------------------------
-# Class 1 - Client connections
-Y:1:90:0:800:100000
-
-# Class 40 - Hub to leaf, autoconnect
-Y:40:90:90:1:3500000
-
-# Class 41 - Hub to leaf, autoconnect
-Y:41:90:90:1:3500000
-
-# Class 50 - Hub to hub, autoconnect
-Y:50:90:60:1:4000000
-
-# Class 51 - Hub to hub, no autoconnect
-Y:51:90:60:0:4000000
-
-#
-# NOTE: Y: lines must be defined before any line that has a class
-# field (I, O, C, and N lines), and therefore must be present
-# in either the base ircd.conf or in the first .include'd
-# conf file.
-
-#
-# .include lines, insert a file from DPATH directory into the conf
-# you could use this to insert a common file between several
-# ircd's if you wished. include files are handled after all the
-# other lines in the conf file are done. i.e. a .include is always
-# as if it was at the end of the conf file.
-#
-#.include "olines.conf"
-
-#
-# I: authorize clients to connect to your server. You can use domains,
-# IP addresses, and asterisk wildcards. The second field can contain a
-# password that the client must use in order to be allowed to connect.
-# The optional fifth field may contain a connection class number.
-#
-I:NOMATCH::-*::1
-
-#I:NOMATCH:password:*.net::1
-
-#
-# You can also limit the number of connections from one host
-# to any value. This can be used to stop cloners
-# This is done using the normally unused confreq line in the Y line.
-#
-# i.e.
-# Allow 100 users in a "bad boy" class, but allow only ONE
-# user per IP to connect at a time.
-#
-Y:3:90:1:100:100000
-
-#
-# Remember to put your "bad boy" I line last in the file, so it
-# seen first and matches first before your standard I lines
-#
-# With PTlink ircd, max connections is taken from the class
-# not per I line. i.e. the 3 I lines following will always add
-# up to 100 or less, not 100 per I line.
-I:NOMATCH::*@*ppp*::3
-I:NOMATCH::*@*slip*::3
-I:NOMATCH::*@*ts*::3
-
-#
-# a name pattern in the first field will never cause a match since it's only
-# ever matched against an IP# in the form a.b.c.d and a number in the third
-# field will never match since a hostname is always compared against this
-# field. The '@' needs to be in the IP# section for ident to be used.
-
-#
-# additional prefix characters in I lines are defined
-#
-#
-# 1) There are noticeable differences in I: lines now.
-# There are 4 special characters that you can stick in front
-# of a hostname or ip# that do special things.
-# These characters are:
-# - This will never put a ~ for a user not running identd
-# + This will force people matching this I: to require identd
-# ! This means to only allow 1 connection per ip# in this I:
-# ^ This will exempt a user from K/G lines, limited protection from D lines
-# > This user is exempt from I line/server side connection limits
-# (old F line)
-# _ This user is exempt from G lines
-#
-# < This user is exempt from idle restrictions if IDLE_CHECK is defined
-#
-
-#
-# Examples:
-#
-# a) I:x::!*@*ppp*::class will only allow X connections per ip# for people
-# who have *ppp* in their hostname where X is given in the Y: line.
-# If there is no ! and you have a limit in your Y: line, then it matches
-# full user@host instead of just host.
-
-# b) I:x::-*@*.cris.com::class will never show a ~, even though they may
-# not be running identd. (This is equivilent to the old way of not
-# specifying a @ in the I: line).
-
-# O: authorize operators. Fields are, in order, host name the operator must
-# be logged in from (wildcards allowed), operator's password, operator's
-# nickname, oper flags, connection class, umodes to be set on /oper,
-# imodes to be set on /oper
-#
-
-# The flags are:
-# K/k - allow/disallow kill and kline
-# O/o - allow/disallow global kill
-# R/r - allow/disallow remote squit/connect
-# U/u - allow/disallow unkline
-# G/g - allow/disallow gline
-# H/h - allow the use of /rehash, default is H for O and o, add h to
-# disable an opers use of /rehash
-# D/d - allow the use of /die or /restart. Default is d for disallowing
-# /die /restart
-#
-# Default flags for opers are GKORUH
-# Default flags for local ops, KUH
-# These flags over-rule what the normal privs of an oper would be,
-# but they cannot allow a local oper to do global kills for example.
-
-# Most operators have encrypted oper passwords. These passwords can be
-# generated using the tools/mkpasswd program included with ircd.
-# Both DES and MD5 passwords are supported as long as the underlying
-# system supports both types.
-# MD5 passwords can be generated by the -m option to mkpasswd.
-#
-
-# NOTE: The easiest way to generate O:Lines is using the mkoline utility
-# cd tools ; ./mkoline
-
-# This example will allow mynick to become global oper from *ptlink.net
-# using password "mypassword", using default oper flags,
-# setting user mode +N (Net Admin), and setting information modes: cdevf
-O:*ptlink.net:mypassword:mynick:O:3:N:cdevf
-
-#
-# This example allow this oper, to global kill, do remote squit/connect
-# unklines, glines
-#
-O:db@*db.net:-encrypted password-:Dianora:ORUG:3
-
-#
-# This example disables this opers use of global kill, unkline, and gline
-# The oper can still do remote squits/connects
-#
-O:newbie@*some.net:-encrypted password-:newbie:oug:3
-
-# C:, N: set up connections to other servers.
-#
-# C: specifies a server that your server may connect to.
-# N: allows a remote server to connect to your own.
-#
-# The two lines are usually given in pairs.
-#
-# These lines may contain a password in the second field. In fact, to
-# maintain proper security, *all* IRC server links must have passwords.
-#
-# If a C: line contains four fields (the fourth being a TCP port number)
-# IRC will actively try to connect to that server. You should have at least
-# one such line.
-#
-# If an N: line contains four fields, the fourth should contain a number that
-# specifies how many components of your own server's name to strip off the
-# front and be replaced with a *. This is done to implement hostmasking.
-# For example, to make hayes.ims.alaska.edu present itself to the world as
-# *.alaska.edu, I would use a 2 (to strip off the first two parts). If you
-# use this, be sure to tell the administrator of the servers you link to --
-# they must add your hostmasked name to their configuration file or you will
-# be unable to connect.
-#
-# C/N rules:
-# The host part of C/N lines MUST contain a valid hostname or IP address
-# The host part in the C:line MUST be identical to the host part in the N:line
-# The name part of the C/N lines MUST match the associated H/L line name,
-# and must match the other server name according to is M:line
-# The fifth field may contain a connection class number.
-# The sixth field on a C:line can be used to specify an IP to be
-# binded for the connection attempt.
-#
-#
-# Syntax:
-#C:host:password:name:port:class[:bindip]
-#N:host:password:name:tostrip:class
-#
-# The following two lines tell my server to try connecting to
-# byron.u.washington.edu.
-#
-#C:byron.u.washington.edu:crunchyfrog:byron.u.washington.edu:6667:40
-#N:byron.u.washington.edu:crunchyfrog:byron.u.washington.edu::40
-#
-# The following two lines allow a server to connect to my server, but my
-# server will not make any attempt to connect to it. Note that since the
-# server is local to me, I am not using hostmasking.
-#
-#C:kaja.gi.alaska.edu:llamas:kaja.gi.alaska.edu::40
-#N:kaja.gi.alaska.edu:llamas:kaja.gi.alaska.edu::40
-#
-# C and N lines may also use the "user@" combination in the same way as
-# the I-lines.
-#
-#C:wisner@kaja.gi.alaska.edu:llamas:kaja.gi.alaska.edu::40
-#N:wisner@kaja.gi.alaska.edu:llamas:kaja.gi.alaska.edu::40
-
-
-
-#
-# K: kill a user automatically upon connecting. This is used to deny
-# troublesome users access to your server. The fields are, in order,
-# hostname (wildcards are allowed), time of day, and username.
-# The second example restricts access from acad3.alaska.edu from
-# 9:00am to noon, and 2:00pm to 5:00pm. This form is only supported if
-# TIMED_KLINES is defined.
-#
-K:*.alaska.edu::FSSPR
-K:acad3.alaska.edu:0900-1200,1400-1700:*
-
-#
-# R: restrict user access. This is an extended form of the K: line.
-# It looks for a match then runs an outside program that will determine
-# whether the person should be allowed on. The fields are hostname,
-# program, and username. A full pathname to the program should be used.
-# The output of the program should be a string of the form "Y <message>"
-# to allow the user, or "N <message>" to block them. In the first case
-# the message is ignored; in the latter, it is sent as an error message
-# to the user. R: lines are only functional if activated in config.h.
-#
-#R:kaja.gi.alaska.edu:/usr/local/lib/irc/does-eric-get-in:ejo
-
-#
-#
-# L: leaf. This forces the server listed to act as a leaf. If such a
-# server allows any other servers to connect to it, its link is
-# dropped. If a port parameter is non-zero, it is used to control the
-# maximum depth that link will allow, where depth is the tree depth of
-# that branch.
-#
-L:::kaja.gi.alaska.edu
-L:::cm5.eng.umd.edu:1
-
-#
-# A new extension to the L-line allows you to be selective
-# about which other servers you wish the connecting server to behave as
-# as a leaf towards. The following would not allow any server connecting
-# with a name that matches *.fi to introduce a server matching *.edu.
-#
-L:*.edu::*.fi
-
-#
-# H: Hub. This is required to allow other servers which connect to you as
-# a hub and introduce other servers.
-#
-# The fields are as follows:
-# H:servers which are permitted entry::hub server #
-
-#
-# The following example allows any *ptlink.net server to connect from some.hub.net
-H:*ptlink.net::some.hub.net
-
-#
-# P : port. The port line allows the server to listen on various ports for
-# connections.
-# The fields are as follows:
-# P:default_codepage:bind_ip:options:port_number
-#
-#
-# NOTES: As of PTlink6, you MUST have at least one P: line defining a port
-# to listen on, or the server won't do much.
-# The default codepage will be the default codepage set for users connection
-# that port, it must be a codepage name loaded with dconf setting CodePages
-#
-# The listener options you can use are:
-# S : Server Only (idea from UnrealIRCd)
-# s : SSL connections
-# W : WebChatPort
-# If defined, user's IP/hostname will be retrived from USER
-# for all connections coming from localhost on WebChatPort
-# J - JavaChat (for CR Java Client)
-# n - No Spoof (don't apply host spoof to users)
-#
-#
-# If you compiled PTlink6 with IPv6 support and want to
-# assing a special IPv6 address with port, put the IPv6 address
-# inside a pair of [] like this example:
-#P::[::1]::6667
-# The above example will make PTlink6 listen on port 6667 on your localhost IPv6
-# address, but you can put any other address that your machine have.
-# To listen in all IPv6 and IPv4 addresses, use a * without the [ ]
-
-# Listen on port 6667 on all available interfaces.
-P::::6667
-
-#Listen on port 6666 for SSL connections
-#P:::s:6666
-# This will try to bind listen port to IP 209.42.128.252, port 313337
-# with default codepage set to iso8859-1
-#P:iso8859-1:209.42.128.252::31337
-
-# Listen on port 6667 on all available interfaces for servers.
-#P:::S:6667
-
-#
-# D : dump. Dumps all connect attempts from the matched IP
-# without any procesing.
-#
-# First arg is target IP and CIDR mask, second is a comment.
-#
-D:208.148.84.3:bot host that changes domain names frequently
-D:128.183.0/24:NASA users aren't supposed to be on IRC
-
-#
-# d : immunity to D dump
-# As in D line , First arg is targe IP and CIDR mask, second is a comment.
-#
-d:199.0.154.0/24:Don't D line ais.net:
-
-#
-# server "clusters"
-# U: lines treat each of these servers as being part of your server cluster
-# klines placed on this server will be forwarded to the servers named
-# in the U lines here. LOCOPS will also be forwarded, but will appear
-# as "SLOCOPS" instead of "LOCOPS"
-#
-# i.e. irc_hub.somewhere.net has leaf servers irc1.somewhere.net
-# irc2.somewhere.net
-
-# Hub server would have
-U:irc1.somewhere.net:
-U:irc2.somewhere.net
-
-# each client server would have
-U:irc_hub.somewhere.net
-
-#
-#
-# Q lines, not the old server Q lines, but Quarantine lines for
-# nicks. Only checked at NICK time, i.e. if added and hashed in
-# will not kill users who match this nick.
-#
-Q:dcc-*:dcc bots not allowed on this server
-Q:lamestbot:You have to be kidding me
-Q:crush:In memory of Janet Pippin
-Q:cwush:In memory of Janet Pippin
-Q:callas:Only allowed from this host:callas@oper.irc.arpa.com
-#
-# X lines.
-# Used to match gecos fields and prohibit users or warn about users
-# who have matching strings in those fields from getting on the server.
-#
-# Field are the match string, reason, unused, and the action value
-#
-# Action values for X lines are 0, 1, and 2.
-# 0 warns opers set +r only
-# 1 rejects the user, and sends a notice to +r opers
-# 2 silently rejects the user.
-#
-# These three examples only warn
-X:*www*:Possible spambot warning 1::0
-X:*http*:Possible spambot warning 2::0
-X:*sex*:Possible spambot warning 3::0
-#
-# These two examples reject the client
-# use this to reject IPHONE users
-X:* vc:IPHONE user::1
-# This is a very probable spambot
-X:*see me at*:This has GOT to be a spambot::1
-X:*hi baby*:This has GOT to be a spambot::1
-
-# It is possible to show a different Message of the Day to a connecting
-# client depending on its origin.
-# T:<hostmask>:<path to motd file>
-#T:*.net:net.motd
-
-# Sample lines for Services
-# Note: services don't listen on any port
-H:*::services.ptlink.net
-C:127.0.0.1:servpass:services.ptlink.net::51
-N:127.0.0.1:servpass:services.ptlink.net::51
-
-# Sample lines for PTOPM
-C:127.0.0.1:xptopass:PTOPM.ptlink.net::51
-N:127.0.0.1:xptopass:PTOPM.ptlink.net::51
diff --git a/irc/ptlink-ircd/files/ircd.motd.sample b/irc/ptlink-ircd/files/ircd.motd.sample
deleted file mode 100644
index 143998594866..000000000000
--- a/irc/ptlink-ircd/files/ircd.motd.sample
+++ /dev/null
@@ -1,14 +0,0 @@
- _____
- / \_________ __ __ __ __ __ ___
- / o / /_|_ | (__) \ | | |/ /
- / ___/___ __/___/ |__|_ | \| | /_
- \___/ / \ |______/_|__|\___|__|\___\(NT)
- \_____/ ### N E T W O R K S
- ###
- _____ _ ### _________
- | | #######\/ / ___
- | |#### #### _____/ | |
- | ### O /###/ ___| |
- | ### \###\___/_ |
- | |####\ #### \ \ |
- |_____|__######_\________\____|
diff --git a/irc/ptlink-ircd/files/kline.conf.sample b/irc/ptlink-ircd/files/kline.conf.sample
deleted file mode 100644
index 3abbc23e78f9..000000000000
--- a/irc/ptlink-ircd/files/kline.conf.sample
+++ /dev/null
@@ -1 +0,0 @@
-# Empty kline file
diff --git a/irc/ptlink-ircd/files/main.dconf.sample b/irc/ptlink-ircd/files/main.dconf.sample
deleted file mode 100644
index 33a498c859fb..000000000000
--- a/irc/ptlink-ircd/files/main.dconf.sample
+++ /dev/null
@@ -1,106 +0,0 @@
-# *****************************************************************
-# * PTlink IRCd is (C) CopyRight PTlink Coders Team 1999-2000 *
-# * http://www.ptlink.net/Coders - coders@PTlink.net *
-# * This program is distributed under GNU Public License *
-# * Please read the file COPYING for copyright information. *
-# *****************************************************************
-
-# File: main.dconf
-# Desc: ircd main dconf file
-# Author: Lamego@PTlink.net
-# Date: Mon 15 Jan 2001 07:18:17 PM WET
-
-
-# Legend:
-# [YES] - If option value is undefined, YES is assumed
-
-# First we include network settings
-.include network.dconf
-
-# Define if you want to try reverse hostname lookup
-# during client's connection [YES]
-ReverseLookup Yes
-
-# Define if you want to use ident lookup
-CheckIdentd No
-
-# Define if you want to hide information notices sent to users
-# during connection.
-HideConnectInfo No
-
-# Define /helpsys paths
-UserHelpFile "help.user"
-OperHelpFile "help.oper"
-AdminHelpFile "help.admin"
-
-# When AllowChanCTCP is NO, only ops or voices can send
-# CTCP's to the entire channel
-AllowChanCTCP NO
-
-# Defines the allowed interval between repeated messsages
-# sent to a noflood (+d) channel
-ChanFloodTime 10
-
-# If defined clock time zone will be set to the specified string
-# on ircd startup
-# NOTE: This is normally required for ircds running on foreign machines
-# related to the network time zone.
-#TimeZone "GMT+0"
-
-# If defined connecting clients will be checked for clones
-# if more than CheckClonesLimit connect from the same host
-# during CheckClonesPeriod that host will be throttled for CheckClonesDelay
-CheckClones YES
-
- # after this number of connections from same host
- CheckClonesLimit 3
-
- # during this period
- CheckClonesPeriod 15s
-
- # throttle this host for this time
- CheckClonesDelay 1m
-
-# CheckTargetLimit:
-#
-# Will block users who are using too many different targets
-# on privmsg/notice during a short period of time.
-# A good option to block spammers
-
-CheckTargetLimit YES
-
-# CheckSpamOnTarget
-#
-# If defined when triggering CheckTargetLimit the message will be checked for spamwords,
-# if a spamword or a channel name is found on the message, the user will get zombie and
-# zombie.
-
-# CheckSpamOnTarget YES
-
-# Defines the maxinum number of channels a user can join
-MaxChansPerUser 5
-
-# Defines the maximum number of channels a registered user can join
-# If defined will override MaxChansPerUser for registered nicks
-MaxChansPerRegUser 20
-
-# Define if you want to use IRCNTP
-# this will make all time stamps to be adjusted with an
-# offset calculated relative to the hub or services time
-# during their connection
-UseIRCNTP Yes
-
-# Path for codepage files needed by unicode translation
-CodePagePath "codepage"
-
-# List of codepage files that should be loaded from CodePagePath
-# a .cp extension will be appended to the filename
-CodePages "iso8859-1,iso8859-5,iso8859-9,cp1251,cp1253,cp850,cp860,cp866"
-
-# Define if you want users to join a given channel after connect
-# NOTES:
-# Do not prefix channel names with the # symbol
-# You can specify multiple channels splitting them with ","
-# AutoJoinChan "PTlink"
-
-# END OF FILE
diff --git a/irc/ptlink-ircd/files/network.dconf.sample b/irc/ptlink-ircd/files/network.dconf.sample
deleted file mode 100644
index 5e281ef55b81..000000000000
--- a/irc/ptlink-ircd/files/network.dconf.sample
+++ /dev/null
@@ -1,242 +0,0 @@
-# *****************************************************************
-# * PTlink IRCd is (C) CopyRight PTlink Coders Team 1999-2000 *
-# * http://www.ptlink.net/Coders - coders@PTlink.net *
-# * This program is distributed under GNU Public License *
-# * Please read the file COPYING for copyright information. *
-# *****************************************************************
-# $Id: network.dconf.sample,v 1.19 2004/12/26 09:54:55 stinger Exp $
-# Legend:
-# [YES] - If option value is undefined, YES is assumed
-
-# File: network.dconf
-# Desc: network configuration file
-# Author: Lamego@PTlink.net
-# Date: Thu 14 Feb 2002 08:45:09 PM WET
-
-# Network name
-NetworkName "PTlink"
-
-# NetworkAUP
-NetworkAUP "Our network AUP can be found at http://www.ptlink.net/aup/"
-
-# host to be advised on server full/no authorization
-RandomHost "irc.ptlink.net"
-
-# Network Description
-NetworkDesc "PTlink IRC Network"
-
-# Help Channel
-HelpChan "#PTlink"
-
-# Services server name
-ServicesServer Services.PTlink.net
-
-# Enable this to hide ServicesServer on /LINKS
-HideServicesServer YES
-
-# will force the use of /service instead of /msg service
-# where services is a services client name (e.g.: nickserv)
-# note that the /service alias is always available [YES]
-ForceServicesAlias YES
-
-# Services flood protection system settings
- # to limit services usage
- ServicesInterval 1m
-
- # maximum services usage count during ServicesInterval
- ServicesUseCount 10
-
-
-# If defined channel admins will be prefixed with '.'
-# on the channel user list [YES]
-AdminWithDot YES
-
-# Spam words (blocked on no spam (+S) channel mode)
-# comma delimited, max: 31 words
-SpamWords "http,www.,/server"
-
-
-# If defined user quit messages will be overridden with NoQuitMsg
-#NoQuitMsg "No quit messages on this server"
-
-# Anti Spam Exit
-# If AntiSpamExitMsg is defined, the clients exit message
-# to be sent to a channel if the client has been on for less than
-# AntiSpamExitTime will be replaced with AntiSpamExitMsg
-# (idea due to ThaDragon)
- AntiSpamExitMsg "Not enough time connected"
- AntiSpamExitTime 2m
-
-# If defined quit messages will be checked for SpamWords,
-# if any word is found, the message will be replaced
-# with NoSpamExitMSg
-#NoSpamExitMsg "No spam on this server"
-
-# If defined colored quit messages will be replaced with NoColorsQuitMsg
-#NoColorsQuitMsg "Good clients don't use colored quits"
-
-# If defined all user quit messages will be prefixed with QuitPrefix
-QuitPrefix "Quit: "
-
-# If defined all quits of a zombied user will be replaced with ZombieQuitMsg
-#ZombieQuitMsg "Hmmzzz, it's spooky out there"
-
-# If defined netsplit message will be override with OverrideNetsplitMessage
-OverrideNetsplitMessage "User lost on netsplit"
-
-# If defined will hide the user's server from the whois reply
-HideServerOnWhois YES
-
-# will replace some part of the user's host in order to protect him
-# from DoS. [YES]
-HostSpoofing YES
-
- # Available masking methods
- # 0 - Prefixed checksum mask
- # 1 - crypt() mutation mask
- SpoofMethod 0
-
- # Prefix to be used for host spoofing, the meaning depends
- # on the spoof method:
- # 0 - String to be merged on soofed host
- # 1 - Salt for crypt()
-
-HostPrefix "PTlink"
-
-# Used for spoof method 0
-# Use a random set of numbers to crypt the hosts
-# NOTE: If you have a network, make sure all network servers use the SAME CryptKey
-CryptKey 77335465
-
-# Spoofed mask settings
-# You can use "+" on the beginning of the mask to provide a @nick.mask format
-
- # TechAdmin mask
- TechAdminMask "Tech@Admin.PTlink.net"
-
- # NetAdmin mask
- NetAdminMask "Net@Admin.PTlink.net"
-
- # Services Admin mask
- SAdminMask "Services@Admin.PTlink.net"
-
- # Server Admin mask
- AdminMask "Server@Admin.PTlink.net"
-
- # Global Operator mask
- OperMask "Oper@PTlink.net"
-
- # Local Operator mask
- LocopMask "LocOp@PTlink.net"
-
- # Helper mask
- HelperMask "Helper.PTlink.net"
-
-
-
-# IRC Operator Options
-
- # If YES a nick needs to have +r before getting /oper [ YES ]
- OnlyRegisteredOper YES
-
- # If YES Opers are able to join +i/+k/+l channels (also if banned)
- OperCanAlwaysJoin NO
-
- # If YES Opers can always send messages to any channel
- OperCanAlwaysSend YES
-
- # if YES Opers are able to change their host with /NEWMASK
- OperCanUseNewMask YES
-
- # if YES Opers cannot be kicked by normal users
- OperKickProtection NO
-
- # if defined allows a IRC Opers to join any channel
- # if using OperByPass string has the key
- OperByPass "operbypass"
-
- # If defined allows self /kills
- EnableSelfKill NO
-
- # If defined will remove oper flag when the user is idle
- # for more than MaxOperIdleTime
- MaxOperIdleTime 1h
-
-# Disable the /links command to users?
-DisableLinksForUsers NO
-
-# Can't send messages #
-NoCTCP_Msg "cannot send CTCP's to channel"
-Moderated_Msg "channel is moderated, you do not have a voice"
-NoExternal_Msg "channel does not allow external messages"
-Banned_Msg "you are banned from this channel"
-NoSpam_Msg "no url/server messages allowed on this channel"
-NoFlood_Msg "cannot send repeated messages to this channel"
-NoDCCSend_Msg "You cannot send files (possible virus infection)"
-
-# You MUST put the "%i", they will be replace with the number of
-# lines and number of seconds
-FloodLimit_Msg "Flood! (%i lines in %i seconds)"
-
-# QModeMsg - +q channel modes quit message
-# If define this message will be used has the quit reason
-# for quitting users on +q channels.
-QModeMsg "Quit"
-
-# If defined will disable nick changes after connect
-# (can be useful for web interfaces)
-LockNickChange NO
-
-# If defined, only IRC opers will be able to join new channels
-# and +r channels will be kept even when after empty.
-# NOTE: This option should be used with no expire channels
-# or else empty non used channels can be kept "forever".
-
-RestrictedChans No
-
-# RestrictedChans - the message that will be sent to users joining
-# a non existing channel with RestrictedChans On
-RestrictedChansMsg "Cannot create new channels on this network, please type /list and join a existing one"
-
-# If defined all other users will see this message as
-# the glined user quit instead of gline reason
-GLineOthersReason "Connection closed"
-
-# If defined all other users will see this message as
-# the glined user quit instead of gline reason
-KLineOthersReason "Connection closed"
-
-# If define this time will be used when no valid time
-# is specified on /GLINE
-DefaultGLineTime 10d
-
-# If define this will be the reason used for glines
-# when no reason is supplied on /GLINE
-DefaultGLineReason "Please read http://www.ptlink.net/aup/"
-
-# Do you want to GLine all users that are killed by Excess Flood?
-# If set 0d it will be disabled
-# GLineOnExcessFlood 1d
-
-# If YES all users will be able to use /IRCOPS to list online opers
-IRCopsForAll Yes
-
-# if YES the numerical IP will be used instead of the real hostname
-# on user info for IRC Opers/Services
-IPIdentifyMode Yes
-
-# if YES modes will only be allowed on registered channels
-# when services are present
-SecureModes Yes
-
-# if YES, anyone will be able to use the SETNAME feature
-# otherwise, only opers can change their real names
-AllowSetNameToEveryone No
-
-# if Yes everyone will see his own realhost on his/her whois, also
-# IRC Operators will see usermodes and realhost of the user they do a /whois on
-WhoisExtension No
-
-# When defined will automatically set users as away when
-# they become idle more than AutoAwayIdleTime .
-AutoAwayIdleTime 1h
diff --git a/irc/ptlink-ircd/files/opers.motd.sample b/irc/ptlink-ircd/files/opers.motd.sample
deleted file mode 100644
index 76d898aaaf0c..000000000000
--- a/irc/ptlink-ircd/files/opers.motd.sample
+++ /dev/null
@@ -1,5 +0,0 @@
-
-Welcome to PTlink IRCd
-----------------------
-Please type /HelpSys for a list of available commands/topics
-
diff --git a/irc/ptlink-ircd/files/patch-tools::install_ircd b/irc/ptlink-ircd/files/patch-tools::install_ircd
deleted file mode 100644
index 9d442b27bae5..000000000000
--- a/irc/ptlink-ircd/files/patch-tools::install_ircd
+++ /dev/null
@@ -1,21 +0,0 @@
---- tools/install_ircd.orig Sun May 15 13:25:29 2005
-+++ tools/install_ircd Sun May 15 13:24:43 2005
-@@ -120,12 +120,12 @@
- # try to install the example files if needed
-
- check_install ${BINPATH}/mkpasswd${EXESUFFIX} tools/mkpasswd${EXESUFFIX}
--check_install_data ${ETCPATH}/ircd.conf samples/example.conf.short
--check_install_data ${ETCPATH}/ircd.motd samples/ptlink.motd
--check_install_data ${ETCPATH}/opers.motd samples/opers.motd
--check_install_data ${ETCPATH} samples/kline.conf
--check_install_data ${ETCPATH}/main.dconf samples/main.dconf.sample
--check_install_data ${ETCPATH}/network.dconf samples/network.dconf.sample
-+#check_install_data ${ETCPATH}/ircd.conf samples/example.conf.short
-+#check_install_data ${ETCPATH}/ircd.motd samples/ptlink.motd
-+#check_install_data ${ETCPATH}/opers.motd samples/opers.motd
-+#check_install_data ${ETCPATH} samples/kline.conf
-+#check_install_data ${ETCPATH}/main.dconf samples/main.dconf.sample
-+#check_install_data ${ETCPATH}/network.dconf samples/network.dconf.sample
- if [ "${EXESUFFIX}" != "" ]; then
- check_install_data ${ETCPATH}/resolv.conf samples/resolv.conf.sample
- fi
diff --git a/irc/ptlink-ircd/files/pkg-message.in b/irc/ptlink-ircd/files/pkg-message.in
new file mode 100644
index 000000000000..e01995cb4b31
--- /dev/null
+++ b/irc/ptlink-ircd/files/pkg-message.in
@@ -0,0 +1,11 @@
+======================================================================
+
+PTlink IRC daemon is now installed.
+
+Edit the configuration files in %%PREFIX%%/etc/ptlink-ircd to suit
+your needs.
+
+Add ircd_enable="YES" to rc.conf and start ircd by running:
+%%PREFIX%%/ptlink-ircd.sh start
+
+======================================================================
diff --git a/irc/ptlink-ircd/files/ptlink-ircd.sh.in b/irc/ptlink-ircd/files/ptlink-ircd.sh.in
new file mode 100644
index 000000000000..3d29474f4e23
--- /dev/null
+++ b/irc/ptlink-ircd/files/ptlink-ircd.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ircd
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+
+# Add the following line(s) to /etc/rc.conf:
+# ircd_enable (bool): Set to "NO" by default, set it to "YES" to enable ircd
+# ircd_user (str): Default to "%%USER%%"
+
+ircd_enable=${ircd_enable-"NO"}
+ircd_user=${ircd_user-"ircd"}
+
+. /etc/rc.subr
+
+name="ircd"
+rcvar=`set_rcvar`
+pidfile="/usr/local/etc/ptlink-ircd/ircd.pid"
+command="/usr/local/bin/ircd"
+
+load_rc_config "$name"
+run_rc_command "$1"
diff --git a/irc/ptlink-ircd/pkg-install b/irc/ptlink-ircd/pkg-install
new file mode 100644
index 000000000000..b998d4565db9
--- /dev/null
+++ b/irc/ptlink-ircd/pkg-install
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+case $2 in
+POST-INSTALL)
+ USER=ircd
+ GROUP=ircd
+ UID=72
+ GID=72
+
+ if pw groupshow "${GROUP}" > /dev/null 2>&1; then
+ echo '===> Using existing group "${GROUP}"'
+ else
+ echo '===> Adding group "${GROUP}"'
+ pw groupadd ${GROUP} -g ${GID} || exit 1
+ fi
+
+ if pw usershow "${USER}" > /dev/null 2>&1; then
+ echo '===> Using existing user "${USER}"'
+ else
+ echo '===> Adding user "${USER}"'
+ pw adduser ${USER} -u ${UID} -g ${GROUP} -h - -d "/nonexistent" \
+ -s "/nonexistent" -c "IRC daemon" || exit 1
+ fi
+ ;;
+esac
diff --git a/irc/ptlink-ircd/pkg-message b/irc/ptlink-ircd/pkg-message
deleted file mode 100644
index e677f6efac6c..000000000000
--- a/irc/ptlink-ircd/pkg-message
+++ /dev/null
@@ -1,11 +0,0 @@
-======================================================================
-
-PTlink IRC daemon is now installed.
-
-Please copy the sample files %%SYSCONFDIR%%/*.conf.sample,*.dconf.sample
-to %%SYSCONFDIR%%/*.conf,*.dconf.
-
-Edit the configuration files %%SYSCONFDIR%%/*.conf,*.dconf to suit your
-needs.
-
-======================================================================
diff --git a/irc/ptlink-ircd/pkg-plist b/irc/ptlink-ircd/pkg-plist
index ee841e7daad6..ed7752ed974c 100644
--- a/irc/ptlink-ircd/pkg-plist
+++ b/irc/ptlink-ircd/pkg-plist
@@ -1,27 +1,27 @@
bin/ircd
bin/mkpasswd
bin/sendbug
-etc/ptlink/codepage/cp1251.cp
-etc/ptlink/codepage/cp1253.cp
-etc/ptlink/codepage/cp850.cp
-etc/ptlink/codepage/cp860.cp
-etc/ptlink/codepage/cp866.cp
-etc/ptlink/codepage/iso8859-1.cp
-etc/ptlink/codepage/iso8859-5.cp
-etc/ptlink/codepage/iso8859-9.cp
-etc/ptlink/codepage/koi8r.cp
-etc/ptlink/codepage/koi8u.cp
-etc/ptlink/codepage/mac.cp
-etc/ptlink/codepage/translit.cp
-etc/ptlink/help.admin
-etc/ptlink/help.oper
-etc/ptlink/help.user
-etc/ptlink/ircd.conf.sample
-etc/ptlink/ircd.motd.sample
-etc/ptlink/kline.conf.sample
-etc/ptlink/main.dconf.sample
-etc/ptlink/network.dconf.sample
-etc/ptlink/opers.motd.sample
-etc/ptlink/version.info
-@dirrm etc/ptlink/codepage
-@unexec rmdir %D/etc/ptlink 2> /dev/null || true
+etc/ptlink-ircd/codepage/cp1251.cp
+etc/ptlink-ircd/codepage/cp1253.cp
+etc/ptlink-ircd/codepage/cp850.cp
+etc/ptlink-ircd/codepage/cp860.cp
+etc/ptlink-ircd/codepage/cp866.cp
+etc/ptlink-ircd/codepage/iso8859-1.cp
+etc/ptlink-ircd/codepage/iso8859-5.cp
+etc/ptlink-ircd/codepage/iso8859-9.cp
+etc/ptlink-ircd/codepage/koi8r.cp
+etc/ptlink-ircd/codepage/koi8u.cp
+etc/ptlink-ircd/codepage/mac.cp
+etc/ptlink-ircd/codepage/translit.cp
+etc/ptlink-ircd/help.admin
+etc/ptlink-ircd/help.oper
+etc/ptlink-ircd/help.user
+etc/ptlink-ircd/ircd.conf
+etc/ptlink-ircd/ircd.motd
+etc/ptlink-ircd/kline.conf
+etc/ptlink-ircd/main.dconf
+etc/ptlink-ircd/network.dconf
+etc/ptlink-ircd/opers.motd
+etc/ptlink-ircd/version.info
+@dirrm etc/ptlink-ircd/codepage
+@unexec rmdir %D/etc/ptlink-ircd 2> /dev/null || true