aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-23 09:54:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-23 09:54:02 +0000
commit3ab1b8443ec60e4983c4666f0e84cedab20e81d2 (patch)
treed13723a66084b6936010f3cea6404da7bbcf103b /irc
parent63d0ab27e8fc88df6e11d9fb8b37620420285dd1 (diff)
downloadports-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.tar.gz
ports-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/bitlbee/Makefile1
-rw-r--r--irc/ctrlproxy/Makefile2
-rw-r--r--irc/ctrlproxy/files/patch-src_gnutls.c18
-rw-r--r--irc/minbif/Makefile2
-rw-r--r--irc/ngircd/Makefile1
-rw-r--r--irc/scrollz/Makefile1
-rw-r--r--irc/weechat-devel/Makefile2
-rw-r--r--irc/weechat/Makefile2
8 files changed, 22 insertions, 7 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index f32e30550a8b..430d0a535ae0 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bitlbee
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/ \
${MASTER_SITE_LOCAL}
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index b3a839c1dcb8..3ab23462b693 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ctrlproxy
PORTVERSION= 3.0.8
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= irc
MASTER_SITES= http://launchpadlibrarian.net/50016234/ \
LOCAL/ashish/
diff --git a/irc/ctrlproxy/files/patch-src_gnutls.c b/irc/ctrlproxy/files/patch-src_gnutls.c
index 78dc64b7977b..fb2c8fe15faa 100644
--- a/irc/ctrlproxy/files/patch-src_gnutls.c
+++ b/irc/ctrlproxy/files/patch-src_gnutls.c
@@ -1,6 +1,3 @@
-
-$FreeBSD$
-
--- src/gnutls.c.orig
+++ src/gnutls.c
@@ -18,7 +18,6 @@
@@ -11,6 +8,21 @@ $FreeBSD$
#include <gnutls/gnutls.h>
#include <gnutls/x509.h>
+@@ -47,11 +46,11 @@
+ static gboolean
+ verify_certificate (gnutls_session session, const char *hostname, GError **err)
+ {
+- int status;
++ int res, status;
+
+- status = gnutls_certificate_verify_peers (session);
++ res = gnutls_certificate_verify_peers2 (session, &status);
+
+- if (status == GNUTLS_E_NO_CERTIFICATE_FOUND) {
++ if (res < 0 || status == GNUTLS_E_NO_CERTIFICATE_FOUND) {
+ g_set_error (err, SSL_ERROR,
+ SSL_ERROR_CERTIFICATE,
+ "No SSL certificate was sent.");
@@ -452,9 +451,6 @@
static void
_gnutls_init (void)
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index 57133227914a..0c82970d0509 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -3,7 +3,7 @@
PORTNAME= minbif
PORTVERSION= 1.0.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= irc net-im
MASTER_SITES= https://symlink.me/attachments/download/148/
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index a1035a1657fa..888d876b96cd 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ngircd
PORTVERSION= 21.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= irc ipv6
MASTER_SITES= http://arthur.barton.de/pub/%SUBDIR%/ \
diff --git a/irc/scrollz/Makefile b/irc/scrollz/Makefile
index e8991d320f06..ecbe90775c0d 100644
--- a/irc/scrollz/Makefile
+++ b/irc/scrollz/Makefile
@@ -3,6 +3,7 @@
PORTNAME= scrollz
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES= irc ipv6
MASTER_SITES= http://www.netraam.net/scrollz/download/ \
http://www.scrollz.org/download/
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index d8e6868f8d7c..ba5fd37c2530 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= weechat
PORTVERSION= 20140213
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc
MASTER_SITES= http://perturb.me.uk/distfiles/weechat-devel/ \
${MASTER_SITE_LOCAL}
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 29038aae6bc3..3aa53945c66f 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= weechat
PORTVERSION= 0.4.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/ \
http://perturb.me.uk/distfiles/weechat/:mandocs \