aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-01 14:19:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-01 14:19:53 +0000
commitf00794b9ea068f5504a39291d0f1eaa4b8bd525d (patch)
tree3554832c650698333fd8948f23ad9a67f5c0770c /irc
parent2b2c074bea06fd52a79e010d278e5e383c42d984 (diff)
downloadports-f00794b9ea068f5504a39291d0f1eaa4b8bd525d.tar.gz
ports-f00794b9ea068f5504a39291d0f1eaa4b8bd525d.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/gseen.mod/Makefile42
-rw-r--r--irc/gseen.mod/distinfo2
-rw-r--r--irc/gseen.mod/pkg-descr12
-rw-r--r--irc/gseen.mod/pkg-plist4
5 files changed, 61 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 04c7fa9c7b0e..d7500ce5eff1 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -22,6 +22,7 @@
SUBDIR += erc
SUBDIR += ezbounce
SUBDIR += gruftistats
+ SUBDIR += gseen.mod
SUBDIR += hybserv
SUBDIR += icbirc
SUBDIR += iip
diff --git a/irc/gseen.mod/Makefile b/irc/gseen.mod/Makefile
new file mode 100644
index 000000000000..02814629fd6c
--- /dev/null
+++ b/irc/gseen.mod/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: gseen.mod
+# Date created: 28 Mai 2004
+# Whom: Gerrit Beine (<tux@pinguru.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= gseen.mod
+PORTVERSION= 1.1.1.p3
+CATEGORIES= irc
+MASTER_SITES= http://www.visions-of-fantasy.de/gseen.mod/
+DISTNAME= ${PORTNAME}.${PORTVERSION:S/p/dev/}
+
+MAINTAINER= tux@pinguru.net
+COMMENT= A seen-module for the eggdrop IRC bot
+
+EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/irc/eggdrop:configure
+RUN_DEPENDS= eggdrop:${PORTSDIR}/irc/eggdrop
+
+WRKSRC= ${WRKDIR}/eggdrop
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${CP} -R ${WRKDIRPREFIX}${.CURDIR}/../../irc/eggdrop/work/eggdrop1.6.15 ${WRKSRC}
+ cd ${WRKSRC}/src/mod && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS}
+
+pre-build:
+ @${ECHO_CMD} gseen.mod >> ${WRKSRC}/.modules
+ @${ECHO_CMD} gseen.mod >> ${WRKSRC}/.known_modules
+ @cd ${WRKSRC} && ./configure
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/gseen.so ${PREFIX}/lib/eggdrop
+ @${INSTALL_DATA} ${WRKSRC}/src/mod/gseen.mod/*lang ${PREFIX}/share/eggdrop/language
+ @${INSTALL_DATA} ${WRKSRC}/src/mod/gseen.mod/gseen.conf ${PREFIX}/etc
+ @${ECHO_MSG} "Please add the line"
+ @${ECHO_MSG} "source /usr/local/etc/gseen.conf"
+ @${ECHO_MSG} "at the end of your eggdrop config file"
+ @${ECHO_MSG} "and .rehash your bot"
+
+.include <bsd.port.mk>
diff --git a/irc/gseen.mod/distinfo b/irc/gseen.mod/distinfo
new file mode 100644
index 000000000000..e038197d4104
--- /dev/null
+++ b/irc/gseen.mod/distinfo
@@ -0,0 +1,2 @@
+MD5 (gseen.mod.1.1.1.dev3.tar.gz) = 8452fca4333f5ea9a6e0ec5a715690fc
+SIZE (gseen.mod.1.1.1.dev3.tar.gz) = 32016
diff --git a/irc/gseen.mod/pkg-descr b/irc/gseen.mod/pkg-descr
new file mode 100644
index 000000000000..8b40eab05307
--- /dev/null
+++ b/irc/gseen.mod/pkg-descr
@@ -0,0 +1,12 @@
+gseen.mod
+
+gseen works similar to countless seen scripts. It logs for each user
+when he or she was last seen in the channel and makes this information
+publically available. It takes switching nick names into consideration
+and supports wildcards in search-requests.
+
+The advantage of gseen in contrast to most other seen scripts is it's speed.
+gseen can handle databases of several thousand nicks without a lag in seen
+requests. It also supports several languages.
+
+WWW: http://www.visions-of-fantasy.de/gseen.mod/
diff --git a/irc/gseen.mod/pkg-plist b/irc/gseen.mod/pkg-plist
new file mode 100644
index 000000000000..67ad5e5db041
--- /dev/null
+++ b/irc/gseen.mod/pkg-plist
@@ -0,0 +1,4 @@
+etc/gseen.conf
+lib/eggdrop/gseen.so
+share/eggdrop/language/gseen.de.lang
+share/eggdrop/language/gseen.en.lang