aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-04-21 19:39:45 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-04-21 19:39:45 +0000
commitf1ac672a0022212949c9e51d956f869a97f35505 (patch)
tree5dfb649305ef9b78995cda091cc44dfb56926dc4 /irc
parenta0793ceb455bc836ee1812cc9d70de612ead6a68 (diff)
downloadports-f1ac672a0022212949c9e51d956f869a97f35505.tar.gz
ports-f1ac672a0022212949c9e51d956f869a97f35505.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/minbif/Makefile28
-rw-r--r--irc/minbif/distinfo6
-rw-r--r--irc/minbif/files/patch-src-sockwrap-sockwrap.h14
3 files changed, 27 insertions, 21 deletions
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index 78bd5e8013f5..93930cb91b30 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= minbif
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= irc net-im
-MASTER_SITES= http://symlink.me/attachments/download/39/
+MASTER_SITES= http://symlink.me/attachments/download/45/
MAINTAINER= steinex@nognu.de
COMMENT= An IRC to instant messaging gateway
@@ -25,13 +25,16 @@ PLIST_FILES= bin/minbif %%ETCDIR%%/minbif.conf-dist \
%%ETCDIR%%/minbif.motd-dist
PLIST_DIRS= %%ETCDIR%%
+USE_EFL= imlib2
USE_CMAKE= yes
+CMAKE_ARGS= -DENABLE_IMLIB:BOOL=ON
USE_RC_SUBR= minbif
PKGMESSAGE= ${WRKDIR}/pkg-message
PORTDOCS= *
# right now WITH_PLUGINS installs prpl-coincoin and prpl-gayattitude
OPTIONS= CACA "Buddy icon display using libcaca" On \
+ GNUTLS "Compile with GnuTLS support" Off \
VIDEO "Webcam display using libcaca (depends on CACA)" Off \
PLUGINS "Compile additional libpurple-plugins" Off
@@ -43,22 +46,6 @@ SUB_LIST+= USERS=${USERS}
BROKEN= does not link on 6.X
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||g' ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's|-Wall||g' ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e \
- 's|message.c_str(), NULL);|message.c_str(), (char*)NULL);|g' \
- ${WRKSRC}/src/im/account.cpp
- @${REINPLACE_CMD} -e \
- 's|#include <libpurple/purple.h>|#include <purple.h>|g' \
- ${WRKSRC}/src/core/callback.h ${WRKSRC}/src/core/minbif.cpp \
- ${WRKSRC}/src/core/util.h ${WRKSRC}/src/im/account.h \
- ${WRKSRC}/src/im/buddy.h ${WRKSRC}/src/im/conversation.h \
- ${WRKSRC}/src/im/ft.h ${WRKSRC}/src/im/media.h \
- ${WRKSRC}/src/im/protocol.h ${WRKSRC}/src/im/purple.cpp \
- ${WRKSRC}/src/im/request.h ${WRKSRC}/src/im/roomlist.h \
- ${WRKSRC}/src/irc/nick.h
-
.include <bsd.port.options.mk>
.if defined(WITH_CACA)
@@ -89,6 +76,11 @@ PLIST_FILES+= lib/purple-2/libcoincoin.so \
CMAKE_ARGS+= -DENABLE_PLUGIN:BOOL=OFF
.endif
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
+CMAKE_ARGS+= -DENABLE_GNUTLS:BOOL=ON
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/minbif.8 ${MAN8PREFIX}/man/man8
diff --git a/irc/minbif/distinfo b/irc/minbif/distinfo
index 78fe7c91c046..c3b957e56ff7 100644
--- a/irc/minbif/distinfo
+++ b/irc/minbif/distinfo
@@ -1,3 +1,3 @@
-MD5 (minbif-1.0.1.tar.gz) = b3eb1f09fd33b6e9c811b0dc34653e2f
-SHA256 (minbif-1.0.1.tar.gz) = 52e632974b65dc82396013979f3c76b8546366728f9f0e4b3685434a670e7771
-SIZE (minbif-1.0.1.tar.gz) = 152815
+MD5 (minbif-1.0.2.tar.gz) = 32418078a1741da3b4028269666f2bac
+SHA256 (minbif-1.0.2.tar.gz) = c9c48d3dbae94c74bd99c97a1f90062b442db2eba0c0ea301a80267dfee54fbd
+SIZE (minbif-1.0.2.tar.gz) = 165340
diff --git a/irc/minbif/files/patch-src-sockwrap-sockwrap.h b/irc/minbif/files/patch-src-sockwrap-sockwrap.h
new file mode 100644
index 000000000000..025468f14c3f
--- /dev/null
+++ b/irc/minbif/files/patch-src-sockwrap-sockwrap.h
@@ -0,0 +1,14 @@
+--- src/sockwrap/sockwrap.h.orig 2010-04-21 19:04:39.000000000 +0200
++++ src/sockwrap/sockwrap.h 2010-04-21 19:05:00.000000000 +0200
+@@ -24,6 +24,11 @@
+ #include "core/config.h"
+ #include "core/callback.h"
+
++#if defined(__FreeBSD__) || defined(__FreeBSD)
++#include <sys/types.h>
++#include <sys/socket.h>
++#endif
++
+ #ifndef PF_SOCKWRAP_H
+ #define PF_SOCKWRAP_H
+