aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-07-18 11:27:24 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-07-18 11:27:24 +0000
commit21d92d5d8cc226c8346b42dc5698a453de606da9 (patch)
tree636f493f862d9dfdf170ce7b4fa10554118dc15a /irc
parente8c4266a1bd4526b1b43c58462a68b67c4bb60e8 (diff)
downloadports-21d92d5d8cc226c8346b42dc5698a453de606da9.tar.gz
ports-21d92d5d8cc226c8346b42dc5698a453de606da9.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat/Makefile4
-rw-r--r--irc/weechat/files/patch-cmake_FindTCL.cmake18
2 files changed, 21 insertions, 1 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 539c7c355fb1..4ab07de002bc 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -66,9 +66,11 @@ MANPAGES_CMAKE_ON= -DMANDIR=${MANPREFIX}/man
MANPAGES_BUILD_DEPENDS= ${LOCALBASE}/bin/asciidoctor:textproc/rubygem-asciidoctor
NLS_USES= gettext
PERL_USES= perl5
-PHP_USES= php:embed
+PHP_USES= php:build,embed
PYTHON_USES= python
RUBY_USE= ruby=yes
+TCL_CMAKE_ON= -DTCL_VERSION:STRING="${TCL_VER}" \
+ -DTCL_TCLSH:PATH="${TCLSH}"
TCL_USES= tcl:85+
.include <bsd.port.pre.mk>
diff --git a/irc/weechat/files/patch-cmake_FindTCL.cmake b/irc/weechat/files/patch-cmake_FindTCL.cmake
new file mode 100644
index 000000000000..b59f788c7ade
--- /dev/null
+++ b/irc/weechat/files/patch-cmake_FindTCL.cmake
@@ -0,0 +1,18 @@
+--- cmake/FindTCL.cmake.orig 2018-07-14 10:35:10 UTC
++++ cmake/FindTCL.cmake
+@@ -99,6 +99,7 @@ endif()
+
+ find_library(TCL_LIBRARY
+ NAMES
++ tcl87 tcl8.7
+ tcl86 tcl8.6
+ tcl85 tcl8.5
+ tcl
+@@ -128,6 +129,7 @@ set(TCL_POSSIBLE_INCLUDE_PATHS
+ /usr/local/include
+ /usr/include/tcl${TCL_VERSION}
+ /usr/local/include/tcl${TCL_VERSION}
++ /usr/local/include/tcl8.7
+ /usr/local/include/tcl8.6
+ /usr/local/include/tcl8.5
+ )