aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2016-10-09 13:44:29 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2016-10-09 13:44:29 +0000
commit330d0f6b76aea72faeb3f77cc46875601d3baae5 (patch)
tree147eaf2a3486b582b19b405b4886b532d02923d6 /irc
parent07b20f48b1ef2c8c2ef127e0f36be13c645dd97e (diff)
downloadports-330d0f6b76aea72faeb3f77cc46875601d3baae5.tar.gz
ports-330d0f6b76aea72faeb3f77cc46875601d3baae5.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/ratbox-respond/Makefile32
-rw-r--r--irc/ratbox-respond/distinfo3
-rw-r--r--irc/ratbox-respond/files/pkg-message.in9
-rw-r--r--irc/ratbox-respond/pkg-descr6
5 files changed, 51 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 4151db1c99ec..404ac3531658 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -100,6 +100,7 @@
SUBDIR += py-supybot-plugins
SUBDIR += quassel
SUBDIR += quirc
+ SUBDIR += ratbox-respond
SUBDIR += ratbox-services
SUBDIR += rbot
SUBDIR += riece
diff --git a/irc/ratbox-respond/Makefile b/irc/ratbox-respond/Makefile
new file mode 100644
index 000000000000..f003c2824e3a
--- /dev/null
+++ b/irc/ratbox-respond/Makefile
@@ -0,0 +1,32 @@
+# Created by: Shaun Amott <shaun@inerd.com>
+# $FreeBSD$
+
+PORTNAME= ratbox-respond
+PORTVERSION= 1.0
+PORTREVISION= 2
+CATEGORIES= irc sysutils
+MASTER_SITES= http://www.ratbox.org/download/${PORTNAME}/ \
+ http://mirrors.gigenet.com/ratbox/${PORTNAME}/
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Client-side implementation of the challenge oper system in ircd-ratbox
+
+CONFIGURE_WRKSRC=${WRKSRC}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+
+USES= tar:tgz
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+
+PORTDOCS= challenge.txt
+PORTEXAMPLES= *
+PLIST_FILES= bin/ratbox-respond bin/makekeypair
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/makekeypair ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/challenge.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/client-scripts/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/irc/ratbox-respond/distinfo b/irc/ratbox-respond/distinfo
new file mode 100644
index 000000000000..bc3a2cf06d3c
--- /dev/null
+++ b/irc/ratbox-respond/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476020049
+SHA256 (ratbox-respond-1.0.tgz) = e3641296fc9cc245c951c6daf24b51c295f21aacf8f25317744c718b791e9bdc
+SIZE (ratbox-respond-1.0.tgz) = 41710
diff --git a/irc/ratbox-respond/files/pkg-message.in b/irc/ratbox-respond/files/pkg-message.in
new file mode 100644
index 000000000000..826b46ba980c
--- /dev/null
+++ b/irc/ratbox-respond/files/pkg-message.in
@@ -0,0 +1,9 @@
+------------------------------------------------------------------------
+ratbox-respond has been successfully installed.
+
+Be sure to look in:
+
+ %%EXAMPLESDIR%%/client-scripts
+
+for some example scripts for various popular IRC clients.
+------------------------------------------------------------------------
diff --git a/irc/ratbox-respond/pkg-descr b/irc/ratbox-respond/pkg-descr
new file mode 100644
index 000000000000..4af2896ad35a
--- /dev/null
+++ b/irc/ratbox-respond/pkg-descr
@@ -0,0 +1,6 @@
+ratbox-respond is a tool that provides a client side implementation of
+the challenge opering system in ircd-ratbox. The challenge system
+provides the ability to oper using private key authentication instead of
+passwords to improve security.
+
+WWW: http://respond.ratbox.org/