aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-10-06 17:54:31 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-10-06 17:54:31 +0000
commit2ca92489221a090974f904b693b68eff3558fde6 (patch)
tree730ce09fa172efe75ac64385fb0e5ae3f6948239 /irc
parent34eed15e2a8a4e55103736e9e6494aaab497ea89 (diff)
downloadports-2ca92489221a090974f904b693b68eff3558fde6.tar.gz
ports-2ca92489221a090974f904b693b68eff3558fde6.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/eggdrop/Makefile6
-rw-r--r--irc/eggdrop/files/patch-src_tclhash.c21
2 files changed, 24 insertions, 3 deletions
diff --git a/irc/eggdrop/Makefile b/irc/eggdrop/Makefile
index ec7f3595022a..7607bb011564 100644
--- a/irc/eggdrop/Makefile
+++ b/irc/eggdrop/Makefile
@@ -10,6 +10,7 @@
PORTNAME= eggdrop
PORTVERSION= 1.6.20
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/ \
http://www.egghelp.org/files/patches/:ssl
@@ -20,8 +21,9 @@ DISTFILES= ${PORTNAME}${PORTVERSION}.tar.bz2 \
MAINTAINER= beech@FreeBSD.org
COMMENT= The most popular open source Internet Relay Chat bot
-USE_TCL= 85+
+LICENSE= GPLv2
+USE_TCL= 85+
GNU_CONFIGURE= yes
#CONFIGURE_ARGS= --with-tcllib=${LOCALBASE}/lib/libtcl${TCL_VER:S/.//}.so \
# --with-tclinc=${TCL_INCLUDEDIR}/tcl.h
@@ -35,8 +37,6 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-LICENSE= GPLv2
-
.if defined(WITH_SSL)
. if ${ARCH} == "amd64"
BROKEN= ssl support is broken on amd64
diff --git a/irc/eggdrop/files/patch-src_tclhash.c b/irc/eggdrop/files/patch-src_tclhash.c
new file mode 100644
index 000000000000..7ed875ed59de
--- /dev/null
+++ b/irc/eggdrop/files/patch-src_tclhash.c
@@ -0,0 +1,21 @@
+--- src/tclhash.c.orig 2011-10-06 09:19:05.000000000 -0800
++++ src/tclhash.c 2011-10-06 09:25:14.000000000 -0800
+@@ -1264,7 +1264,7 @@
+ for (i = 0; cc[i].name; i++) {
+ egg_snprintf(p, sizeof p, "*%s:%s", tl->name,
+ cc[i].funcname ? cc[i].funcname : cc[i].name);
+- l = nmalloc(Tcl_ScanElement(p, &k));
++ l = nmalloc(Tcl_ScanElement(p, &k) + 1);
+ Tcl_ConvertElement(p, l, k | TCL_DONT_USE_BRACES);
+ table[0].cdata = (void *) cc[i].func;
+ add_cd_tcl_cmds(table);
+@@ -1282,7 +1282,7 @@
+ for (i = 0; cc[i].name; i++) {
+ egg_snprintf(p, sizeof p, "*%s:%s", table->name,
+ cc[i].funcname ? cc[i].funcname : cc[i].name);
+- l = nmalloc(Tcl_ScanElement(p, &k));
++ l = nmalloc(Tcl_ScanElement(p, &k) + 1);
+ Tcl_ConvertElement(p, l, k | TCL_DONT_USE_BRACES);
+ Tcl_DeleteCommand(interp, p);
+ unbind_bind_entry(table, cc[i].flags, cc[i].name, l);
+