aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2008-06-21 08:13:25 +0000
committerJohan van Selst <johans@FreeBSD.org>2008-06-21 08:13:25 +0000
commit71c13ef11658b49c5e7869a8a758cdca3d4935d8 (patch)
tree28b7dcd73375fb08034994c91f9f575cc698555b /irc
parentb36550c4e89e332a2f5951cee82da9707a845a8b (diff)
downloadports-71c13ef11658b49c5e7869a8a758cdca3d4935d8.tar.gz
ports-71c13ef11658b49c5e7869a8a758cdca3d4935d8.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/irc/Makefile42
-rw-r--r--irc/irc/distinfo6
-rw-r--r--irc/irc/files/ircd.sh15
-rw-r--r--irc/irc/files/ircd.sh.in30
-rw-r--r--irc/irc/files/patch-ab2
-rw-r--r--irc/irc/files/patch-support::Makefile.in11
-rw-r--r--irc/irc/pkg-plist3
-rw-r--r--irc/irc/scripts/pre-configure7
8 files changed, 43 insertions, 73 deletions
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index 51f70b77d8a3..2ff3e890be87 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -6,58 +6,32 @@
#
PORTNAME= irc
-PORTVERSION= 2.11.1.1
+PORTVERSION= 2.11.2
CATEGORIES= irc ipv6
-MASTER_SITES= ftp://ftp.irc.org/irc/server/ \
- ftp://ftp2.nchu.edu.tw/UNIX/IRC/server/ \
- ftp://ftp.plig.net/pub/irc/ftp.irc.org/server/ \
+MASTER_SITES= http://ftp.irc.org/ftp/irc/server/ \
ftp://ftp.archive.de.uu.net/pub/mirrors/ftp.irc.org/server/ \
- ftp://ftp.iway.fr/pub/mirrors/ftp.irc.org/server/ \
ftp://ftp.nl.uu.net/pub/mirrors/ftp.irc.org/server/
-DISTNAME= ${PORTNAME}2.11.1p1
+DISTNAME= ${PORTNAME}${PORTVERSION}
EXTRACT_SUFX= .tgz
+USE_RC_SUBR= ircd.sh
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@stack.nl
COMMENT= The "Internet Relay Chat" Server
-# the NOTE command is disabled by default
-# ENABLE_NOTE=yes
-
-# Syslog-Facility to use for logging
-# default:
-SYSLOG_FACILITY=LOG_LOCAL5
-
-SCRIPTS_ENV= SYSLOG_FACILITY="${SYSLOG_FACILITY}"
-
MAN5= iauth.conf.5
MAN8= ircd.8 iauth.8 ircdwatch.8
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/ircd
-STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/ircd.sh
+BUILD_WRKSRC= ${WRKSRC}/${MACHINE_ARCH}-unknown-freebsd${OSREL}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
OPTIONS= IPV6 "Enable IPv6 support" on
.include <bsd.port.pre.mk>
.if defined(WITH_IPV6)
-CONFIGURE_ARGS+= --enable-ip6
+CONFIGURE_ARGS+= --enable-ipv6
.endif
-pre-build:
- @${RM} -f ${WRKDIR}/ircd.sh
- @${SED} -e "s;%%PREFIX%%;${PREFIX};g" ${FILESDIR}/ircd.sh > ${WRKDIR}/ircd.sh
-
-do-build:
- @(cd ${WRKSRC}/${MACHINE_ARCH}-unknown-freebsd${OSREL}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
-
-do-install:
- @(cd ${WRKSRC}/${MACHINE_ARCH}-unknown-freebsd${OSREL} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-
-post-install:
- @if [ ! -f ${STARTUP_SCRIPT} ]; then \
- ${ECHO_MSG} "Installing ${STARTUP_SCRIPT} startup file."; \
- ${INSTALL_SCRIPT} ${WRKDIR}/ircd.sh ${STARTUP_SCRIPT};\
- fi
-
.include <bsd.port.post.mk>
diff --git a/irc/irc/distinfo b/irc/irc/distinfo
index 273785629c18..848e2291e27d 100644
--- a/irc/irc/distinfo
+++ b/irc/irc/distinfo
@@ -1,3 +1,3 @@
-MD5 (irc2.11.1p1.tgz) = c5a2b3097a5fbeb91b39412730b02ab5
-SHA256 (irc2.11.1p1.tgz) = 29f83e82cd55f2e2f4362d95eae1da6b53dc1b7d05ff3f41be7b42e6dcbf2e1d
-SIZE (irc2.11.1p1.tgz) = 770458
+MD5 (irc2.11.2.tgz) = 23cd680a4dd38d2a2281315659fec2d8
+SHA256 (irc2.11.2.tgz) = bd4653627642eef0fe56e305811eaef574499cb534d9037d6e8f18f43c3a7e8c
+SIZE (irc2.11.2.tgz) = 794119
diff --git a/irc/irc/files/ircd.sh b/irc/irc/files/ircd.sh
deleted file mode 100644
index 530cc0e52280..000000000000
--- a/irc/irc/files/ircd.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-start)
- [ -f %%PREFIX%%/etc/ircd/ircd.conf ] && %%PREFIX%%/sbin/ircd && echo -n ' ircd'
- ;;
-stop)
- killall ircd && echo -n ' ircd'
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/irc/irc/files/ircd.sh.in b/irc/irc/files/ircd.sh.in
new file mode 100644
index 000000000000..3a6fbb3732ef
--- /dev/null
+++ b/irc/irc/files/ircd.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ircd
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable ircd:
+# ircd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable ircd.
+#
+
+. /etc/rc.subr
+
+name="ircd"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${ircd_enable="NO"}
+
+pidfile="%%PREFIX%%/var/run/ircd.pid"
+command="%%PREFIX%%/sbin/ircd"
+
+run_rc_command "$1"
+
diff --git a/irc/irc/files/patch-ab b/irc/irc/files/patch-ab
index e0977b907fd1..e1c9242d90b9 100644
--- a/irc/irc/files/patch-ab
+++ b/irc/irc/files/patch-ab
@@ -49,7 +49,7 @@
* this define.
*/
-#define LOG_FACILITY LOG_DAEMON
-+#define LOG_FACILITY !!SYSLOG_FACILITY!!
++#define LOG_FACILITY LOG_LOCAL5
#endif /* USE_SYSLOG */
/*
diff --git a/irc/irc/files/patch-support::Makefile.in b/irc/irc/files/patch-support::Makefile.in
deleted file mode 100644
index 1d9788e3e421..000000000000
--- a/irc/irc/files/patch-support::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- support/Makefile.in.orig Mon Aug 16 05:38:53 2004
-+++ support/Makefile.in Mon Aug 16 05:39:09 2004
-@@ -44,7 +44,7 @@
- LIBS = @LIBS@
- MATHLIBS = @MATHLIBS@
- # zlib, eventually
--ZLIBS = @IRC_ZLIB_LIBRARY@
-+ZLIBS = @IRC_ZLIB_LIBRARY@ -lm
- # for DSM support (dlopen(), dlsym(), dlclose())
- DLIBS = @IRC_DLIB@
- # curses library
diff --git a/irc/irc/pkg-plist b/irc/irc/pkg-plist
index 3801d9d107d5..7f492613f9bc 100644
--- a/irc/irc/pkg-plist
+++ b/irc/irc/pkg-plist
@@ -2,11 +2,10 @@ etc/ircd/ircd.conf.example
etc/ircd/iauth.conf.example
etc/ircd/iauth.conf
etc/ircd/ircd.motd
-etc/rc.d/ircd.sh
etc/ircd/ircd.m4
sbin/chkconf
sbin/ircd
sbin/iauth
sbin/ircd-mkpasswd
sbin/ircdwatch
-@dirrm etc/ircd
+@dirrmtry etc/ircd
diff --git a/irc/irc/scripts/pre-configure b/irc/irc/scripts/pre-configure
deleted file mode 100644
index 542a9139e26a..000000000000
--- a/irc/irc/scripts/pre-configure
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-mv ${WRKSRC}/support/config.h.dist ${WRKSRC}/support/config.h.dist.bak.2
-sed <${WRKSRC}/support/config.h.dist.bak.2 >${WRKSRC}/support/config.h.dist s+!!SYSLOG_FACILITY!!+$SYSLOG_FACILITY+g