aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-06-05 13:13:38 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-06-05 13:13:38 +0000
commitaf956edfd2f830dcb562f894dd36eca09d7cf9f2 (patch)
treec849b57aff88c02b3c5c5ae0722896728a799969 /irc
parent1504a2809ca576d9c499f0135d1b8d2e930f0a7d (diff)
downloadports-af956edfd2f830dcb562f894dd36eca09d7cf9f2.tar.gz
ports-af956edfd2f830dcb562f894dd36eca09d7cf9f2.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/smartirc4net/Makefile23
-rw-r--r--irc/smartirc4net/distinfo3
-rw-r--r--irc/smartirc4net/pkg-descr5
-rw-r--r--irc/smartirc4net/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index dcc781d2d207..1454014c58fe 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -126,6 +126,7 @@
SUBDIR += simpleirc
SUBDIR += sirc
SUBDIR += slirc
+ SUBDIR += smartirc4net
SUBDIR += solid-ircd
SUBDIR += srvx
SUBDIR += talksoup
diff --git a/irc/smartirc4net/Makefile b/irc/smartirc4net/Makefile
new file mode 100644
index 000000000000..2c07ab677771
--- /dev/null
+++ b/irc/smartirc4net/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: smartirc4net
+# Date created: 2009-08-25
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smartirc4net
+PORTVERSION= 0.4.5.1
+CATEGORIES= irc
+MASTER_SITES= http://www.smuxi.org/jaws/data/files/
+
+MAINTAINER= romain@blogreen.org
+COMMENT= Multi-layered IRC library
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/irc/smartirc4net/distinfo b/irc/smartirc4net/distinfo
new file mode 100644
index 000000000000..46f1baf44299
--- /dev/null
+++ b/irc/smartirc4net/distinfo
@@ -0,0 +1,3 @@
+MD5 (smartirc4net-0.4.5.1.tar.gz) = a0f091d3796e6dce4c5158d973a937ee
+SHA256 (smartirc4net-0.4.5.1.tar.gz) = 56403be3be7c541828d6eabac70ffdcf49d8ce8c9506ac92160300a0d6823bc9
+SIZE (smartirc4net-0.4.5.1.tar.gz) = 112374
diff --git a/irc/smartirc4net/pkg-descr b/irc/smartirc4net/pkg-descr
new file mode 100644
index 000000000000..a65d81e37313
--- /dev/null
+++ b/irc/smartirc4net/pkg-descr
@@ -0,0 +1,5 @@
+SmartIrc4net is a multi-threaded and thread-safe IRC library written in C#. It
+allows you to communicate with IRC servers. The API features full channel
+syncing and is splitted in 3 layers: IrcConnection, IrcCommands and IrcClient.
+
+WWW: http://smartirc4net.meebey.net/jaws/
diff --git a/irc/smartirc4net/pkg-plist b/irc/smartirc4net/pkg-plist
new file mode 100644
index 000000000000..8519349737a8
--- /dev/null
+++ b/irc/smartirc4net/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+lib/smartirc4net/Meebey.SmartIrc4net.dll
+lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f/Meebey.SmartIrc4net.dll
+lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f/Meebey.SmartIrc4net.dll.mdb
+libdata/pkgconfig/smartirc4net.pc
+@dirrm lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f
+@dirrm lib/mono/gac/Meebey.SmartIrc4net
+@dirrm lib/smartirc4net