aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2019-11-24 18:57:21 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2019-11-24 18:57:21 +0000
commit677780dac11d3b3969c07cb4a57e636fd2846776 (patch)
treebf31d00b54f883fd13da84007825c1ec245113b9 /irc
parent60e55aa2622154e700424cdcd6c19a8a0e8e68bc (diff)
downloadports-677780dac11d3b3969c07cb4a57e636fd2846776.tar.gz
ports-677780dac11d3b3969c07cb4a57e636fd2846776.zip
irc/eggdrop: Update to 1.8.4
Notes
Notes: svn path=/head/; revision=518350
Diffstat (limited to 'irc')
-rw-r--r--irc/eggdrop/Makefile30
-rw-r--r--irc/eggdrop/distinfo5
-rw-r--r--irc/eggdrop/files/patch-eggdrop.conf18
-rw-r--r--irc/eggdrop/files/patch-src__Makefile.in11
-rw-r--r--irc/eggdrop/files/patch-src_eggdrop.h11
-rw-r--r--irc/eggdrop/files/patch-src_main.c29
-rw-r--r--irc/eggdrop/files/patch-src_match.c13
-rw-r--r--irc/eggdrop/files/patch-src_mod_share.mod__share.c22
-rw-r--r--irc/eggdrop/files/patch-src_modules.c11
-rw-r--r--irc/eggdrop/files/patch-src_net.c13
-rw-r--r--irc/eggdrop/files/patch-src_proto.h13
-rw-r--r--irc/eggdrop/files/patch-src_tclhash.c13
-rw-r--r--irc/eggdrop/files/patch-src_tclhash.h13
-rw-r--r--irc/eggdrop/pkg-plist51
14 files changed, 71 insertions, 182 deletions
diff --git a/irc/eggdrop/Makefile b/irc/eggdrop/Makefile
index e158001f9ed9..01bd059708a4 100644
--- a/irc/eggdrop/Makefile
+++ b/irc/eggdrop/Makefile
@@ -2,29 +2,33 @@
# $FreeBSD$
PORTNAME= eggdrop
-PORTVERSION= 1.6.21
-PORTREVISION= 1
+PORTVERSION= 1.8.4
+DISTVERSIONPREFIX= v
CATEGORIES= irc
-MASTER_SITES= ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/
-DISTNAME= ${PORTNAME}${PORTVERSION}
-DISTFILES= ${PORTNAME}${PORTVERSION}.tar.bz2
MAINTAINER= dbaio@FreeBSD.org
-COMMENT= The most popular open source Internet Relay Chat bot
+COMMENT= Eggdrop is the most popular Internet Relay Chat (IRC) bot
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= DOCS
+USES= tcl ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= eggheads
-USES= tcl
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcllib=${LOCALBASE}/lib/libtcl${TCL_SHLIB_VER}.so \
--with-tclinc=${LOCALBASE}/include/tcl${TCL_VER}/tcl.h
+
MAKE_JOBS_UNSAFE= yes
LLD_UNSAFE= yes
SUB_FILES= pkg-message
-PORTDOCS= *
+
+CONFLICTS= eggdrop-devel eggdrop16
+
+OPTIONS_DEFINE= DOCS
post-patch:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${WRKSRC}/eggdrop.conf \
@@ -32,8 +36,6 @@ post-patch:
post-configure:
@(cd ${WRKSRC}; ${MAKE} config)
-# Workaround broken relative path in SSL-patch
-# @(cd ${WRKSRC}/src && ${LN} -fs ../config.h)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/eggdrop ${STAGEDIR}${PREFIX}/bin
@@ -42,7 +44,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/eggdrop
.for f in assoc.so blowfish.so channels.so compress.so console.so ctcp.so \
dns.so filesys.so irc.so notes.so seen.so server.so share.so \
- transfer.so uptime.so wire.so
+ transfer.so uptime.so
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/lib/eggdrop
.endfor
@${MKDIR} ${STAGEDIR}${DATADIR}/help
@@ -52,8 +54,8 @@ do-install:
filesys.mod/help/filesys.help irc.mod/help/irc.help \
notes.mod/help/notes.help seen.mod/help/seen.help \
server.mod/help/server.help share.mod/help/share.help \
- transfer.mod/help/transfer.help uptime.mod/help/uptime.help \
- wire.mod/help/wire.help
+ transfer.mod/help/transfer.help uptime.mod/help/uptime.help
+
${INSTALL_DATA} ${WRKSRC}/src/mod/${f} ${STAGEDIR}${DATADIR}/help
.endfor
@${MKDIR} ${STAGEDIR}${DATADIR}/help/set
diff --git a/irc/eggdrop/distinfo b/irc/eggdrop/distinfo
index a780638a3803..c9cd311bae68 100644
--- a/irc/eggdrop/distinfo
+++ b/irc/eggdrop/distinfo
@@ -1,2 +1,3 @@
-SHA256 (eggdrop1.6.21.tar.bz2) = 75bd5573a609eac3940c0b6ca8251c3f38ea5d54b520e1cad93c650b4bc21754
-SIZE (eggdrop1.6.21.tar.bz2) = 999211
+TIMESTAMP = 1574378274
+SHA256 (eggheads-eggdrop-v1.8.4_GH0.tar.gz) = 960c7813ccd70e14ac145941f253c8ab394e8876b0ff0cff8327438533419fdf
+SIZE (eggheads-eggdrop-v1.8.4_GH0.tar.gz) = 1766635
diff --git a/irc/eggdrop/files/patch-eggdrop.conf b/irc/eggdrop/files/patch-eggdrop.conf
index 8490199bc5d0..a8c1635b29dc 100644
--- a/irc/eggdrop/files/patch-eggdrop.conf
+++ b/irc/eggdrop/files/patch-eggdrop.conf
@@ -1,12 +1,12 @@
---- eggdrop.conf 2010-07-05 14:07:05.000000000 +0200
-+++ eggdrop.conf 2011-01-07 06:13:49.000000000 +0100
+--- eggdrop.conf.orig 2018-12-27 18:51:16 UTC
++++ eggdrop.conf
@@ -1,4 +1,4 @@
-#! /path/to/executable/eggdrop
+#!%%PREFIX%%/bin/eggdrop
# ^- This should contain a fully qualified path to your Eggdrop executable.
#
- # $Id: eggdrop.conf,v 1.66 2010/07/05 12:07:05 pseudo Exp $
-@@ -444,7 +444,7 @@
+ # This is a sample Eggdrop configuration file which includes all possible
+@@ -604,7 +604,7 @@ die "Please make sure you edit your config file comple
# If you run the bot from the compilation directory, you will want to set
# this to "". If you use 'make install' (like all good kiddies do ;), this
# is a fine default. Otherwise, use your head :)
@@ -15,15 +15,15 @@
#### BLOWFISH MODULE ####
-@@ -842,6 +842,11 @@
- another.example.com:7000:password
+@@ -1047,6 +1047,11 @@ set servers {
+ [2001:db8:618:5c0:263::]:6669:password
+ ssl.example.net:+6697
}
-
++
+# Set this option, if you want a SSL connection to the IRC Server(s) specified
+# above. This setting applies to all servers, so make sure they all support SSL
+# connections. Eggdrop has to be compiled with SSL support for this to work!
+set use-ssl 0
-+
+
# Number of seconds to wait between transmitting queued lines to the server.
# Lower this value at your own risk. ircd is known to start flood control
- # at 512 bytes/2 seconds.
diff --git a/irc/eggdrop/files/patch-src__Makefile.in b/irc/eggdrop/files/patch-src__Makefile.in
deleted file mode 100644
index 1b1bf646acd6..000000000000
--- a/irc/eggdrop/files/patch-src__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Mon Feb 9 22:42:35 2004
-+++ src/Makefile.in Mon Feb 9 22:43:23 2004
-@@ -18,7 +18,7 @@
- LD = @CC@
- STRIP = @STRIP@
- CFLAGS = @CFLAGS@ -I.. -I$(top_srcdir) @DEFS@ $(CFLGS)
--CPPFLAGS = @CPPFLAGS@
-+CPPFLAGS = @CPPFLAGS@ '-D__PREFIX__="@prefix@"'
-
- eggdrop_objs = bg.o botcmd.o botmsg.o botnet.o chanprog.o cmds.o dcc.o \
- dccutil.o dns.o flags.o language.o match.o main.o mem.o misc.o misc_file.o \
diff --git a/irc/eggdrop/files/patch-src_eggdrop.h b/irc/eggdrop/files/patch-src_eggdrop.h
deleted file mode 100644
index bd6079e5704d..000000000000
--- a/irc/eggdrop/files/patch-src_eggdrop.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/eggdrop.h 2011-01-07 06:12:27.000000000 +0100
-+++ src/eggdrop.h 2011-01-07 06:14:26.000000000 +0100
-@@ -64,7 +64,7 @@
-
-
- /* Language stuff */
--#define LANGDIR "./language" /* language file directory */
-+#define LANGDIR __PREFIX__ "/share/eggdrop/language" /* language file directory */
- #define BASELANG "english" /* language which always gets loaded before
- all other languages. You do not want to
- change this. */
diff --git a/irc/eggdrop/files/patch-src_main.c b/irc/eggdrop/files/patch-src_main.c
deleted file mode 100644
index 018d5911c310..000000000000
--- a/irc/eggdrop/files/patch-src_main.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/main.c 2011-01-07 06:12:27.000000000 +0100
-+++ src/main.c 2011-01-07 06:16:35.000000000 +0100
-@@ -72,7 +72,7 @@
- # define _POSIX_SOURCE 1 /* Solaris needs this */
- #endif
-
--extern char origbotname[], userfile[], botnetnick[];
-+extern char origbotname[], userfile[], botnetnick[], tempdir[];
- extern int dcc_total, conmask, cache_hit, cache_miss, max_logs, quick_logs,
- quiet_save;
- extern struct dcc_t *dcc;
-@@ -105,7 +105,7 @@
- int term_z = 0; /* Foreground: use the terminal as a partyline? */
- int use_stderr = 1; /* Send stuff to stderr instead of logfiles? */
-
--char configfile[121] = "eggdrop.conf"; /* Default config file name */
-+char configfile[121] = __PREFIX__ "/etc/eggdrop.conf"; /* Default config file name */
- char pid_file[120]; /* Name of the pid file */
- char helpdir[121] = "help/"; /* Directory of help files */
- char textdir[121] = "text/"; /* Directory for text files */
-@@ -1064,7 +1064,7 @@
- cache_miss = 0;
- cache_hit = 0;
- if (!pid_file[0])
-- egg_snprintf(pid_file, sizeof pid_file, "pid.%s", botnetnick);
-+ egg_snprintf(pid_file, sizeof pid_file, "%s/pid.%s", tempdir, botnetnick);
-
- /* Check for pre-existing eggdrop! */
- f = fopen(pid_file, "r");
diff --git a/irc/eggdrop/files/patch-src_match.c b/irc/eggdrop/files/patch-src_match.c
deleted file mode 100644
index 56e71ea8e09f..000000000000
--- a/irc/eggdrop/files/patch-src_match.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$NetBSD: patch-src_match.c,v 1.1 2012/11/16 00:35:28 joerg Exp $
-
---- src/match.c.orig 2012-11-15 10:29:42.000000000 +0000
-+++ src/match.c
-@@ -367,7 +367,7 @@ int cidr_match(char *m, char *n, int cou
- /* Inline for cron_match (obviously).
- * Matches a single field of a crontab expression.
- */
--inline int cron_matchfld(char *mask, int match)
-+static inline int cron_matchfld(char *mask, int match)
- {
- int skip = 0, f, t;
- char *p, *q;
diff --git a/irc/eggdrop/files/patch-src_mod_share.mod__share.c b/irc/eggdrop/files/patch-src_mod_share.mod__share.c
deleted file mode 100644
index c0f7d2172f9e..000000000000
--- a/irc/eggdrop/files/patch-src_mod_share.mod__share.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/mod/share.mod/share.c 2010-02-18 10:52:30.000000000 +0100
-+++ src/mod/share.mod/share.c 2011-01-07 06:22:16.000000000 +0100
-@@ -1122,7 +1122,7 @@
- int i, sock;
- FILE *f;
-
-- egg_snprintf(s, sizeof s, ".share.%s.%li.users", botnetnick, now);
-+ egg_snprintf(s, sizeof s, "%s/.share.%s.%li.users", tempdir, botnetnick, now);
- if (!(b_status(idx) & STAT_SHARE)) {
- dprintf(idx, "s e You didn't ask; you just started sending.\n");
- dprintf(idx, "s e Ask before sending the userfile.\n");
-@@ -1891,8 +1891,8 @@
- struct chanuserrec *ch;
- struct chanset_t *cst;
-
-- egg_snprintf(share_file, sizeof share_file, ".share.%s.%lu", dcc[idx].nick,
-- now);
-+ egg_snprintf(share_file, sizeof share_file, "%s/.share.%s.%lu",
-+ tempdir, dcc[idx].nick, now);
- if (dcc[idx].u.bot->uff_flags & UFF_OVERRIDE) {
- debug1("NOTE: Sharing aggressively with %s, overriding its local bots.",
- dcc[idx].nick);
diff --git a/irc/eggdrop/files/patch-src_modules.c b/irc/eggdrop/files/patch-src_modules.c
deleted file mode 100644
index 0f7528625d86..000000000000
--- a/irc/eggdrop/files/patch-src_modules.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/modules.c 2011-01-07 06:12:27.000000000 +0100
-+++ src/modules.c 2011-01-07 06:21:42.000000000 +0100
-@@ -118,7 +118,7 @@
- static int module_rename(char *name, char *newname);
-
- #ifndef STATIC
--char moddir[121] = "modules/";
-+char moddir[121] = __PREFIX__ "/lib/eggdrop/";
- #endif
-
- #ifdef STATIC
diff --git a/irc/eggdrop/files/patch-src_net.c b/irc/eggdrop/files/patch-src_net.c
deleted file mode 100644
index d46308e86e17..000000000000
--- a/irc/eggdrop/files/patch-src_net.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$NetBSD: patch-src_net.c,v 1.1 2012/11/16 00:35:28 joerg Exp $
-
---- src/net.c.orig 2012-11-15 10:30:07.000000000 +0000
-+++ src/net.c
-@@ -564,7 +564,7 @@ int open_address_listen(IP addr, int *po
- /* Returns a socket number for a listening socket that will accept any
- * connection -- port # is returned in port
- */
--inline int open_listen(int *port)
-+int open_listen(int *port)
- {
- return open_address_listen(myip[0] ? getmyip() : INADDR_ANY, port);
- }
diff --git a/irc/eggdrop/files/patch-src_proto.h b/irc/eggdrop/files/patch-src_proto.h
deleted file mode 100644
index 893d532a7d8b..000000000000
--- a/irc/eggdrop/files/patch-src_proto.h
+++ /dev/null
@@ -1,13 +0,0 @@
-$NetBSD: patch-src_proto.h,v 1.1 2012/11/16 00:35:28 joerg Exp $
-
---- src/proto.h.orig 2012-11-15 10:30:20.000000000 +0000
-+++ src/proto.h
-@@ -271,7 +271,7 @@ int getsock(int);
- void killsock(int);
- void killtclsock(int);
- int answer(int, char *, unsigned long *, unsigned short *, int);
--inline int open_listen(int *);
-+int open_listen(int *);
- int open_address_listen(IP addr, int *);
- int open_telnet(char *, int);
- int open_telnet_dcc(int, char *, char *);
diff --git a/irc/eggdrop/files/patch-src_tclhash.c b/irc/eggdrop/files/patch-src_tclhash.c
deleted file mode 100644
index 69fc2eea7a3d..000000000000
--- a/irc/eggdrop/files/patch-src_tclhash.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$NetBSD: patch-src_tclhash.c,v 1.1 2012/11/16 00:35:28 joerg Exp $
-
---- src/tclhash.c.orig 2012-11-15 10:32:40.000000000 +0000
-+++ src/tclhash.c
-@@ -109,7 +109,7 @@ static inline void tcl_bind_list_delete(
- nfree(tl);
- }
-
--inline void garbage_collect_tclhash(void)
-+void garbage_collect_tclhash(void)
- {
- tcl_bind_list_t *tl, *tl_next, *tl_prev;
- tcl_bind_mask_t *tm, *tm_next, *tm_prev;
diff --git a/irc/eggdrop/files/patch-src_tclhash.h b/irc/eggdrop/files/patch-src_tclhash.h
deleted file mode 100644
index d03481152d33..000000000000
--- a/irc/eggdrop/files/patch-src_tclhash.h
+++ /dev/null
@@ -1,13 +0,0 @@
-$NetBSD: patch-src_tclhash.h,v 1.1 2012/11/16 00:35:28 joerg Exp $
-
---- src/tclhash.h.orig 2012-11-15 10:32:27.000000000 +0000
-+++ src/tclhash.h
-@@ -75,7 +75,7 @@ typedef struct tcl_bind_list_b {
-
- #ifndef MAKING_MODS
-
--inline void garbage_collect_tclhash(void);
-+void garbage_collect_tclhash(void);
-
- void init_bind(void);
- void kill_bind(void);
diff --git a/irc/eggdrop/pkg-plist b/irc/eggdrop/pkg-plist
index af25372fef33..e7591f460d5b 100644
--- a/irc/eggdrop/pkg-plist
+++ b/irc/eggdrop/pkg-plist
@@ -1,6 +1,5 @@
bin/eggdrop
etc/eggdrop.conf.sample
-man/man1/eggdrop.1.gz
lib/eggdrop/assoc.so
lib/eggdrop/blowfish.so
lib/eggdrop/channels.so
@@ -16,7 +15,44 @@ lib/eggdrop/server.so
lib/eggdrop/share.so
lib/eggdrop/transfer.so
lib/eggdrop/uptime.so
-lib/eggdrop/wire.so
+man/man1/eggdrop.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/ABOUT
+%%PORTDOCS%%%%DOCSDIR%%/BANS
+%%PORTDOCS%%%%DOCSDIR%%/BOTNET
+%%PORTDOCS%%%%DOCSDIR%%/BUG-REPORT
+%%PORTDOCS%%%%DOCSDIR%%/COMPILE-GUIDE
+%%PORTDOCS%%%%DOCSDIR%%/CONTENTS
+%%PORTDOCS%%%%DOCSDIR%%/Changes1.6
+%%PORTDOCS%%%%DOCSDIR%%/FIRST-SCRIPT
+%%PORTDOCS%%%%DOCSDIR%%/KNOWN-PROBLEMS
+%%PORTDOCS%%%%DOCSDIR%%/MODULES
+%%PORTDOCS%%%%DOCSDIR%%/PARTYLINE
+%%PORTDOCS%%%%DOCSDIR%%/PATCH-HOWTO
+%%PORTDOCS%%%%DOCSDIR%%/TEXT-SUBSTITUTIONS
+%%PORTDOCS%%%%DOCSDIR%%/TRICKS
+%%PORTDOCS%%%%DOCSDIR%%/USERS
+%%PORTDOCS%%%%DOCSDIR%%/WEIRD-MESSAGES
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/search.html
+%%PORTDOCS%%%%DOCSDIR%%/settings/CONTENTS
+%%PORTDOCS%%%%DOCSDIR%%/settings/core.settings
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.assoc
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.blowfish
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.channels
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.compress
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.console
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.ctcp
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.dns
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.filesys
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.irc
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.notes
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.seen
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.server
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.share
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.transfer
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.uptime
+%%PORTDOCS%%%%DOCSDIR%%/settings/mod.woobie
+%%PORTDOCS%%%%DOCSDIR%%/tcl-commands.doc
%%DATADIR%%/help/assoc.help
%%DATADIR%%/help/chaninfo.help
%%DATADIR%%/help/channels.help
@@ -48,22 +84,24 @@ lib/eggdrop/wire.so
%%DATADIR%%/help/share.help
%%DATADIR%%/help/transfer.help
%%DATADIR%%/help/uptime.help
-%%DATADIR%%/help/wire.help
%%DATADIR%%/language/assoc.danish.lang
%%DATADIR%%/language/assoc.english.lang
%%DATADIR%%/language/assoc.finnish.lang
%%DATADIR%%/language/assoc.french.lang
%%DATADIR%%/language/assoc.german.lang
+%%DATADIR%%/language/assoc.portuguese.lang
%%DATADIR%%/language/console.danish.lang
%%DATADIR%%/language/console.english.lang
%%DATADIR%%/language/console.finnish.lang
%%DATADIR%%/language/console.french.lang
%%DATADIR%%/language/console.german.lang
+%%DATADIR%%/language/console.portuguese.lang
%%DATADIR%%/language/core.danish.lang
%%DATADIR%%/language/core.english.lang
%%DATADIR%%/language/core.finnish.lang
%%DATADIR%%/language/core.french.lang
%%DATADIR%%/language/core.german.lang
+%%DATADIR%%/language/core.portuguese.lang
%%DATADIR%%/language/filesys.danish.lang
%%DATADIR%%/language/filesys.english.lang
%%DATADIR%%/language/filesys.finnish.lang
@@ -74,16 +112,13 @@ lib/eggdrop/wire.so
%%DATADIR%%/language/notes.finnish.lang
%%DATADIR%%/language/notes.french.lang
%%DATADIR%%/language/notes.german.lang
+%%DATADIR%%/language/notes.portuguese.lang
%%DATADIR%%/language/transfer.danish.lang
%%DATADIR%%/language/transfer.english.lang
%%DATADIR%%/language/transfer.finnish.lang
%%DATADIR%%/language/transfer.french.lang
%%DATADIR%%/language/transfer.german.lang
-%%DATADIR%%/language/wire.danish.lang
-%%DATADIR%%/language/wire.english.lang
-%%DATADIR%%/language/wire.finnish.lang
-%%DATADIR%%/language/wire.french.lang
-%%DATADIR%%/language/wire.german.lang
+%%DATADIR%%/language/transfer.portuguese.lang
%%DATADIR%%/scripts/CONTENTS
%%DATADIR%%/scripts/action.fix.tcl
%%DATADIR%%/scripts/alltools.tcl