aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-10-03 16:09:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-10-03 16:09:59 +0000
commit30bc262d2a70c5bebb5409acd5fe75f15cfc92c6 (patch)
tree5cfbe1f102942511763ec3922736e09d689466db /irc
parent394ef442cac26819efa23a4e260f381f5a134438 (diff)
downloadports-30bc262d2a70c5bebb5409acd5fe75f15cfc92c6.tar.gz
ports-30bc262d2a70c5bebb5409acd5fe75f15cfc92c6.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/hexchat/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index 1d75423c5532..c2ecb2e32b41 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -11,19 +11,17 @@ COMMENT= IRC chat program with GTK and Text Frontend
LICENSE= GPLv2
-BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common
LIB_DEPENDS= libproxy.so:${PORTSDIR}/net/libproxy
USES= gmake desktop-file-utils libtool pkgconfig tar:xz
USE_GNOME= gtk20 libxml2
-USE_AUTOTOOLS= automake autoconf libtoolize
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-openssl --enable-gtkfe --disable-sysinfo \
--with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig
-MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
-LDFLAGS+= -pthread
+CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lX11
SUB_FILES= pkg-message
@@ -81,9 +79,6 @@ USES+= perl5
USE_GNOME+= gconf2
.endif
-pre-configure:
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
-
post-patch:
@${REINPLACE_CMD} -e '/^appdata_DATA/s|hexchat.appdata.xml||' \
${WRKSRC}/data/misc/Makefile.in
@@ -91,20 +86,11 @@ post-patch:
${WRKSRC}/src/common/server.c
post-install:
-# Ugly CP and RM, only this works. Not works pathfix,
-# --localedir=${LOCALBASE}/share/locale and patching.
-# Upstream can't fix this and think that glib-gettextize (devel/glib20)
-# is broken in FreeBSD.
- @${CP} -a ${STAGEDIR}/usr/local/lib/locale/* ${STAGEDIR}/usr/local/share/locale/
- @${RM} -fr ${STAGEDIR}/usr/local/lib/locale/
-
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
-
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.md ${STAGEDIR}${DOCSDIR}
.endif
-# @(cd ${PREFIX}/lib/hexchat/plugins/ && ${RM} -f *.a)
.include <bsd.port.mk>