aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-03-24 04:52:31 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-03-24 04:52:31 +0000
commit6261706d40f0d7582b7893455e70edff259d0633 (patch)
treeab69d7a9eadfd87414c8caed3e306ee80b828e92 /irc
parent01dd31731816415e443e624f4afbd4cf36412662 (diff)
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat/Makefile2
-rw-r--r--irc/xchat/files/patch-src_fe-gtk_fe-gtk.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 51f5e823659b..a4c5309177a4 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xchat
PORTVERSION= 2.8.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
diff --git a/irc/xchat/files/patch-src_fe-gtk_fe-gtk.c b/irc/xchat/files/patch-src_fe-gtk_fe-gtk.c
new file mode 100644
index 000000000000..6573e33626fe
--- /dev/null
+++ b/irc/xchat/files/patch-src_fe-gtk_fe-gtk.c
@@ -0,0 +1,22 @@
+--- src/fe-gtk/fe-gtk.c.orig 2008-03-07 13:04:07.000000000 -0600
++++ src/fe-gtk/fe-gtk.c 2008-03-07 13:05:24.000000000 -0600
+@@ -660,7 +660,7 @@
+ session *sess;
+ gdouble per;
+ char lagtext[64];
+- char lagtip[64];
++ char lagtip[128];
+ unsigned long nowtim;
+
+ if (lag == -1)
+@@ -716,8 +716,8 @@
+ GSList *list = sess_list;
+ struct session *sess;
+ float per;
+- char tbuf[64];
+- char tip[64];
++ char tbuf[96];
++ char tip[160];
+
+ per = (float) serv->sendq_len / 1024.0;
+ if (per > 1.0)