aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-06-10 11:26:04 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-06-10 11:26:04 +0000
commitd770f79e0bd1c5c8c08e4f1839ce6c907ba4617a (patch)
tree49036bcd32a02284cf67312360eb969168d5274b /irc
parent505106ea56fe2fcbac03ab0dec4f776d8018e150 (diff)
downloadports-d770f79e0bd1c5c8c08e4f1839ce6c907ba4617a.tar.gz
ports-d770f79e0bd1c5c8c08e4f1839ce6c907ba4617a.zip
Remove -std=gnu11 from internal compiler flags to attempt to fix build
on GCC-based systems such as powerpc64: cc1: error: unrecognized command line option "-std=gnu11" This is necessary but insufficient. I have not yet tried the patch from PR 247107, which may be needed.. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=538390
Diffstat (limited to 'irc')
-rw-r--r--irc/srain/Makefile2
-rw-r--r--irc/srain/files/patch-src_Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/irc/srain/Makefile b/irc/srain/Makefile
index aed02818caf5..48b426c497ee 100644
--- a/irc/srain/Makefile
+++ b/irc/srain/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libconfig.so:devel/libconfig \
libsecret-1.so:security/libsecret \
libsoup-2.4.so:devel/libsoup
-USES= gettext-tools gmake gnome pkgconfig ssl
+USES= compiler:c11 gettext-tools gmake gnome pkgconfig ssl
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 pango
USE_GITHUB= yes
diff --git a/irc/srain/files/patch-src_Makefile b/irc/srain/files/patch-src_Makefile
index 34fcb4826742..993ad7e29538 100644
--- a/irc/srain/files/patch-src_Makefile
+++ b/irc/srain/files/patch-src_Makefile
@@ -5,7 +5,7 @@
LIBSECRETLIBS =$(shell pkg-config --libs libsecret-1)
-CFLAGS += -std=gnu99 -O2 -Wall -Iinc -Wno-deprecated-declarations \
-+CFLAGS += -std=gnu11 -Wall -Iinc -Wno-deprecated-declarations \
++CFLAGS += -Wall -Iinc -Wno-deprecated-declarations \
$(DEFS) \
$(DBGFLAGS) \
$(GTK3FLAGS) \