aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-19 14:03:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-19 14:03:06 +0000
commit14c0b2cb8b27383cd1c3e5d5209b81c410e59420 (patch)
tree1aa6c11a5d43ba6a816a5e58d6ea20964036b7e4 /irc
parent8f68b17158d23118e4fea2639fe2f1c6a92ee6d5 (diff)
downloadports-14c0b2cb8b27383cd1c3e5d5209b81c410e59420.tar.gz
ports-14c0b2cb8b27383cd1c3e5d5209b81c410e59420.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/conspire/Makefile73
-rw-r--r--irc/conspire/distinfo3
-rw-r--r--irc/conspire/pkg-descr8
-rw-r--r--irc/conspire/pkg-plist87
5 files changed, 172 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 79d580dc744c..c03bb0875161 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -12,6 +12,7 @@
SUBDIR += bobot++
SUBDIR += bopm
SUBDIR += cgiirc
+ SUBDIR += conspire
SUBDIR += ctrlproxy
SUBDIR += cwirc
SUBDIR += dancer
diff --git a/irc/conspire/Makefile b/irc/conspire/Makefile
new file mode 100644
index 000000000000..dc46fff53d15
--- /dev/null
+++ b/irc/conspire/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: conspire
+# Date created: Thu Jul 17 2008
+# Whom: Jacob Myers (jacob@whotookspaz.org)
+#
+# $FreeBSD$
+
+PORTNAME= conspire
+PORTVERSION= 0.20
+CATEGORIES= irc gnome
+MASTER_SITES= http://distfiles.atheme.org/
+EXTRACT_SUFX= .tbz2
+
+MAINTAINER= jacob@whotookspaz.org
+COMMENT= A high quality IRC client which uses a multitude of interfaces
+
+LIB_DEPENDS= sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
+ mowgli.2:${PORTSDIR}/devel/libmowgli \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ notify.1:${PORTSDIR}/devel/libnotify
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack gtk20
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+MAN1= conspire-bot.1 \
+ conspire.1
+
+OPTIONS= IPV6 "Enable IPv6 support" off \
+ PLUGIN "Enable plugin support" on \
+ REGEX "Enable regex substitution support" on \
+ GNUTLS "Enale gnutls support" on \
+ SOCKS "Build with socks5 support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
+
+.if !defined(WITH_PLUGIN)
+CONFIGURE_ARGS+=--disable-plugin
+.endif
+
+.if !defined(WITH_REGEX)
+CONFIGURE_ARGS+=--disable-regex
+.endif
+
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+=--enable-gnutls
+.endif
+
+.if defined(WITH_SOCKS)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+CONFIGURE_ARGS+=--enable-socks
+.endif
+
+# Create plugins directory even when no plugins are installed
+post-install:
+ @${MKDIR} ${PREFIX}/lib/conspire/plugins
+
+post-patch:
+ @${REINPLACE_CMD} 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/irc/conspire/distinfo b/irc/conspire/distinfo
new file mode 100644
index 000000000000..4d0a89a870bb
--- /dev/null
+++ b/irc/conspire/distinfo
@@ -0,0 +1,3 @@
+MD5 (conspire-0.20.tbz2) = f070e841564495bfc83ad8e20bf65cda
+SHA256 (conspire-0.20.tbz2) = 8029f3ce87c6392e4305ae49a826832e14342b224a315f8020d9804eb30f2065
+SIZE (conspire-0.20.tbz2) = 1150730
diff --git a/irc/conspire/pkg-descr b/irc/conspire/pkg-descr
new file mode 100644
index 000000000000..fcf7c1e6fcff
--- /dev/null
+++ b/irc/conspire/pkg-descr
@@ -0,0 +1,8 @@
+Conspire is an advanced, lightweight IRC client for UNIX. It includes
+a GTK interface, and a "bot" interface which has no UI. Interface
+segregation is accomplished through libconspire, which contains the
+common code. Conspire started as a fork of XChat 2.9 CVS.
+
+Scripting is not yet officially supported, but is being worked on.
+
+WWW: http://nenolod.net/conspire
diff --git a/irc/conspire/pkg-plist b/irc/conspire/pkg-plist
new file mode 100644
index 000000000000..9be014653df5
--- /dev/null
+++ b/irc/conspire/pkg-plist
@@ -0,0 +1,87 @@
+bin/conspire
+bin/conspire-bot
+include/conspire/base64.h
+include/conspire/cap.h
+include/conspire/cfgfiles.h
+include/conspire/command_factory.h
+include/conspire/ctcp.h
+include/conspire/dcc.h
+include/conspire/debug.h
+include/conspire/fe.h
+include/conspire/history.h
+include/conspire/ignore.h
+include/conspire/inbound.h
+include/conspire/inet.h
+include/conspire/linequeue.h
+include/conspire/modes.h
+include/conspire/network.h
+include/conspire/notify.h
+include/conspire/outbound.h
+include/conspire/plugin.h
+include/conspire/proto-irc.h
+include/conspire/sasl.h
+include/conspire/server.h
+include/conspire/servlist.h
+include/conspire/signal_factory.h
+include/conspire/signal_printer.h
+include/conspire/text.h
+include/conspire/textenums.h
+include/conspire/textevents.h
+include/conspire/timer.h
+include/conspire/tree.h
+include/conspire/upnp.h
+include/conspire/url.h
+include/conspire/userlist.h
+include/conspire/util.h
+include/conspire/xchat.h
+include/conspire/xchatc.h
+lib/conspire/plugins/autoaway.so
+lib/conspire/plugins/helloworld.so
+lib/conspire/plugins/highlight-notify.so
+lib/libconspire.so
+lib/libconspire.so.0
+lib/libconspire.so.0.1.0
+libdata/pkgconfig/conspire.pc
+share/applications/conspire.desktop
+%%DATADIR%%/pixmaps/balloon.png
+%%DATADIR%%/pixmaps/book.png
+%%DATADIR%%/pixmaps/conspire.png
+%%DATADIR%%/pixmaps/fileoffer.png
+%%DATADIR%%/pixmaps/hop.png
+%%DATADIR%%/pixmaps/op.png
+%%DATADIR%%/pixmaps/purple.png
+%%DATADIR%%/pixmaps/red.png
+%%DATADIR%%/pixmaps/voice.png
+share/locale/be/LC_MESSAGES/conspire.mo
+share/locale/ca/LC_MESSAGES/conspire.mo
+share/locale/cs/LC_MESSAGES/conspire.mo
+share/locale/de/LC_MESSAGES/conspire.mo
+share/locale/el/LC_MESSAGES/conspire.mo
+share/locale/es/LC_MESSAGES/conspire.mo
+share/locale/fi/LC_MESSAGES/conspire.mo
+share/locale/fr/LC_MESSAGES/conspire.mo
+share/locale/gl/LC_MESSAGES/conspire.mo
+share/locale/hu/LC_MESSAGES/conspire.mo
+share/locale/it/LC_MESSAGES/conspire.mo
+share/locale/ja/LC_MESSAGES/conspire.mo
+share/locale/ko/LC_MESSAGES/conspire.mo
+share/locale/lt/LC_MESSAGES/conspire.mo
+share/locale/mk/LC_MESSAGES/conspire.mo
+share/locale/nl/LC_MESSAGES/conspire.mo
+share/locale/pa/LC_MESSAGES/conspire.mo
+share/locale/pt/LC_MESSAGES/conspire.mo
+share/locale/ru/LC_MESSAGES/conspire.mo
+share/locale/sq/LC_MESSAGES/conspire.mo
+share/locale/sr/LC_MESSAGES/conspire.mo
+share/locale/sv/LC_MESSAGES/conspire.mo
+share/locale/uk/LC_MESSAGES/conspire.mo
+share/locale/vi/LC_MESSAGES/conspire.mo
+share/locale/zh_CN/LC_MESSAGES/conspire.mo
+share/locale/zh_TW/LC_MESSAGES/conspire.mo
+share/pixmaps/conspire.png
+@dirrmtry share/applications
+@dirrm %%DATADIR%%/pixmaps
+@dirrm share/conspire
+@dirrm lib/conspire/plugins
+@dirrm lib/conspire
+@dirrm include/conspire