aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-11-27 05:58:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-11-27 05:58:14 +0000
commit1ce2dea08be2dd94a3c50594e7ddc16e3ed86dd5 (patch)
tree81e4158aa2cbafb37ebc341aefa21e93fc948497 /irc
parent89f933cbd659339df813e76a4f51e2985c62f8e4 (diff)
downloadports-1ce2dea08be2dd94a3c50594e7ddc16e3ed86dd5.tar.gz
ports-1ce2dea08be2dd94a3c50594e7ddc16e3ed86dd5.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/ruby-rica/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/irc/ruby-rica/Makefile b/irc/ruby-rica/Makefile
index 2b8aa43f54fb..193b0a5840b9 100644
--- a/irc/ruby-rica/Makefile
+++ b/irc/ruby-rica/Makefile
@@ -26,21 +26,23 @@ MODULES= rica.rb \
DOCS= CHANGES README classes_and_methods.txt event.lst *.png
EXAMPLES= erica.* ricaco.rb rica-example.rb
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
do-install:
+ ${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
.for f in ${MODULES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_SITELIBDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_SITELIBDIR}/
.endfor
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.endfor
.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
.endif