aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-20 17:52:16 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-20 17:52:16 +0000
commit734b63302e4eff161f45e72e9888eb8fbd1ad403 (patch)
treef03527561482ff1ea85dbb668e027491c45829f5 /irc
parent6d83e65a8b50cb4f07da7184b20fca3165a54747 (diff)
downloadports-734b63302e4eff161f45e72e9888eb8fbd1ad403.tar.gz
ports-734b63302e4eff161f45e72e9888eb8fbd1ad403.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/kvirc/Makefile2
-rw-r--r--irc/py-fishcrypt/Makefile3
-rw-r--r--irc/py-gozerbot/Makefile6
-rw-r--r--irc/py-irc/Makefile6
-rw-r--r--irc/py-supybot-plugins/Makefile3
-rw-r--r--irc/py-supybot/Makefile5
-rw-r--r--irc/qwebirc/Makefile3
-rw-r--r--irc/weechat-devel/Makefile2
-rw-r--r--irc/xchat/Makefile2
-rw-r--r--irc/znc/Makefile3
10 files changed, 14 insertions, 21 deletions
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index b3c79e6bfb07..94ece25775e3 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -87,7 +87,7 @@ CMAKE_ARGS+= -DWANT_GSM=no
#scripting support
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
PLIST_SUB+= PYTHON=""
.else
CMAKE_ARGS+= -DWANT_PYTHON=no
diff --git a/irc/py-fishcrypt/Makefile b/irc/py-fishcrypt/Makefile
index d487b7cd5e95..e7b1081022c1 100644
--- a/irc/py-fishcrypt/Makefile
+++ b/irc/py-fishcrypt/Makefile
@@ -17,8 +17,7 @@ GH_PROJECT= py-fishcrypt
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= c001c75
-USES= dos2unix
-USE_PYTHON_RUN= yes
+USES= dos2unix python:run
NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/irc/py-gozerbot/Makefile b/irc/py-gozerbot/Makefile
index 11c8d63c1498..e656dd7c51fb 100644
--- a/irc/py-gozerbot/Makefile
+++ b/irc/py-gozerbot/Makefile
@@ -12,9 +12,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sten@blinkenlights.nl
COMMENT= Gozerbot - A modular Python IRC and Jabber bot
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-SUB_FILES= pkg-message
+USES= python
+USE_PYTHON= distutils
+SUB_FILES= pkg-message
OPTIONS_DEFINE= XMPP MYSQL DOCS
XMPP_DESC= Jabber functions
diff --git a/irc/py-irc/Makefile b/irc/py-irc/Makefile
index da5711f4f040..49755921501f 100644
--- a/irc/py-irc/Makefile
+++ b/irc/py-irc/Makefile
@@ -17,10 +17,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hgtools>0:${PORTSDIR}/devel/py-hgtools \
${PYTHON_PKGNAMEPREFIX}pytest-runner>0:${PORTSDIR}/devel/py-pytest-runner
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-USES= zip
+USES= python zip
+USE_PYTHON= distutils autoplist
PORTEXAMPLES= irccat.py irccat2.py servermap.py testbot.py \
dccreceive.py dccsend.py ssl-cat.py
diff --git a/irc/py-supybot-plugins/Makefile b/irc/py-supybot-plugins/Makefile
index cad131e03dd6..7e752bd62eb9 100644
--- a/irc/py-supybot-plugins/Makefile
+++ b/irc/py-supybot-plugins/Makefile
@@ -14,8 +14,7 @@ COMMENT= Official plugin pack for Supybot
RUN_DEPENDS= supybot:${PORTSDIR}/irc/py-supybot
-USE_PYTHON= yes
-USES= tar:bzip2
+USES= python tar:bzip2
post-extract:
# Delete, because it now included in irc/py-supybot
diff --git a/irc/py-supybot/Makefile b/irc/py-supybot/Makefile
index 35ddb167aecf..02649336d756 100644
--- a/irc/py-supybot/Makefile
+++ b/irc/py-supybot/Makefile
@@ -11,9 +11,8 @@ DISTNAME= Supybot-${PORTVERSION}
MAINTAINER= dhn@FreeBSD.org
COMMENT= Supybot - A Superb Python IRC bot
-USES= tar:bzip2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python tar:bzip2
+USE_PYTHON= distutils
PYDISTUTILS_PKGVERSION= 0.83.1+darcs
PYDISTUTILS_EGGINFO= supybot-${PORTVERSION}-py${PYTHON_VER}.egg-info
diff --git a/irc/qwebirc/Makefile b/irc/qwebirc/Makefile
index 963677f2510c..e3843d04b07b 100644
--- a/irc/qwebirc/Makefile
+++ b/irc/qwebirc/Makefile
@@ -12,10 +12,9 @@ EXTRACT_SUFX= .gz
MAINTAINER= tabmow@freenode.net
COMMENT= Fast, easy to use, free, and open source web IRC client
-USES= twisted:run,conch,mail,names,web,words
+USES= python twisted:run,conch,mail,names,web,words
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USE_PYTHON= yes
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
do-install:
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 7a488e8339ea..00e5acac5f95 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -75,7 +75,7 @@ PLIST_SUB+= ASPELL="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2
+USES+= python:2
CMAKE_ARGS+= -DBSD_PYTHON_CMD=${PYTHON_CMD} \
-DBSD_PYTHON_VER=${PYTHON_VERSION}
PLIST_SUB+= PYTHON=""
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 395a48cf005c..7a97ec0b544b 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -70,7 +70,7 @@ PLIST_SUB+= PERL="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
.else
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index 9c85fb2f6e32..5827bdaa1402 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -38,7 +38,7 @@ PERL_CONFIGURE_ON= --enable-swig
PERL_USES= perl5
PYTHON_BUILD_DEPENDS= swig>=2.0.11:${PORTSDIR}/devel/swig20
PYTHON_CONFIGURE_ON= --enable-python=python-${PYTHON_VER} --enable-swig
-PYTHON_USES= perl5
+PYTHON_USES= perl5 python:3
OPENSSL_CONFIGURE_OFF= --disable-openssl
TCL_CONFIGURE_ENABLE= tcl
@@ -59,7 +59,6 @@ CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 3
USE_PERL5+= build
.endif